summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Eichert <viz@gentoo.org>2002-12-23 00:42:06 +0000
committerTobias Eichert <viz@gentoo.org>2002-12-23 00:42:06 +0000
commitf8a5810e9a62d866a33ca9ef86f8b6bfc9aa5e5d (patch)
tree71a0b385a5e5964b99b93a04b0650daf0f9c0d31 /sys-kernel
parentNew version (diff)
downloadgentoo-2-f8a5810e9a62d866a33ca9ef86f8b6bfc9aa5e5d.tar.gz
gentoo-2-f8a5810e9a62d866a33ca9ef86f8b6bfc9aa5e5d.tar.bz2
gentoo-2-f8a5810e9a62d866a33ca9ef86f8b6bfc9aa5e5d.zip
xfs-sources version bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/xfs-sources/ChangeLog31
-rw-r--r--sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre12
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.20_pre1.ebuild51
3 files changed, 82 insertions, 2 deletions
diff --git a/sys-kernel/xfs-sources/ChangeLog b/sys-kernel/xfs-sources/ChangeLog
index 4ce5fcca708b..d9ce3126b2f4 100644
--- a/sys-kernel/xfs-sources/ChangeLog
+++ b/sys-kernel/xfs-sources/ChangeLog
@@ -1,7 +1,34 @@
# ChangeLog for sys-kernel/xfs-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.9 2002/12/18 00:12:48 lostlogic Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.10 2002/12/23 00:42:06 viz Exp $
+
+*xfs-sources-2.4.20_pre1 (22 Dec 2002)
+
+ 22 Dec 2002; Tobias Eichert <viz@gentoo.org> xfs-sources-2.4.20_pre1.ebuild:
+
+ Version bump.
+
+ This is the first xfs-sources release I did by myself;
+ it aims for having a lot of nice and stable features
+ in the near future. Please test it and report bugs
+ since it's going to become the next Live CD kernel.
+
+ Features:
+
+ - Update 3.5 GB address space patch
+ - Update to latest XFS (full features)
+ - Update ACPI snapshot (12 Dec 2002)
+ - Update EVMS
+ - Add Win4Lin (including mki adapter patch)
+ - Add dc395x (Driver for older Tekram SCSI host adapters, fixes bug #12218)
+ - Add imon support (SGI's Inode Monitor)
+ - Update patch-int (aka CryptoAPI)
+ - Update loop-jari (for encrypted loopback devices)
+ - Add openwall (security related things
+ like non-executable user stack area,etc.)
+ - Miscellaneous little patches
+
+
17 Dec 2002; Brandon Low <lostlogic@gentoo.org>:
Make all kernel-sources SLOT="${KV}"
diff --git a/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre1 b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre1
new file mode 100644
index 000000000000..37a53905009a
--- /dev/null
+++ b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre1
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 4055430680dcfcd8099a540af1e1460e patches-2.4.20-xfs_pre1.tar.bz2 1819308
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre1.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre1.ebuild
new file mode 100644
index 000000000000..ca0a840b525f
--- /dev/null
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre1.ebuild,v 1.1 2002/12/23 00:42:06 viz Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV=2.4.20
+EXTRAVERSION=-xfs_pre1
+KV=${OKV}${EXTRAVERSION}
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/xfs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the XFS Specialized Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.databoogie.net/kernel/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ kernel_src_unpack
+}