summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-09-19 23:48:01 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-09-19 23:48:01 +0000
commitde9264874c4846a8c22726a9343306b4bd2804fd (patch)
tree64099775163c9b0db2342d27656564c4144e0873 /sys-libs/db
parentHost ftp.planetmirror.com not found: 3(NXDOMAIN) (diff)
downloadgentoo-2-de9264874c4846a8c22726a9343306b4bd2804fd.tar.gz
gentoo-2-de9264874c4846a8c22726a9343306b4bd2804fd.tar.bz2
gentoo-2-de9264874c4846a8c22726a9343306b4bd2804fd.zip
Bug #285516: Build fix for java compile.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog6
-rw-r--r--sys-libs/db/db-4.8.24.ebuild9
-rw-r--r--sys-libs/db/files/db-4.8.24-java-manifest-location.patch12
3 files changed, 22 insertions, 5 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index ca4e16c7470a..39afb904051b 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.290 2009/09/18 22:26:16 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.291 2009/09/19 23:48:01 robbat2 Exp $
+
+ 19 Sep 2009; Robin H. Johnson <robbat2@gentoo.org> db-4.8.24.ebuild,
+ +files/db-4.8.24-java-manifest-location.patch:
+ Bug #285516: Build fix for java compile.
*db-4.8.24 (18 Sep 2009)
diff --git a/sys-libs/db/db-4.8.24.ebuild b/sys-libs/db/db-4.8.24.ebuild
index 7921d54469b6..77e3888f2d7d 100644
--- a/sys-libs/db/db-4.8.24.ebuild
+++ b/sys-libs/db/db-4.8.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.8.24.ebuild,v 1.1 2009/09/18 22:26:16 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.8.24.ebuild,v 1.2 2009/09/19 23:48:01 robbat2 Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -44,11 +44,12 @@ src_unpack() {
do
epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
done
- epatch "${FILESDIR}"/"${PN}"-4.8-libtool.patch
+ epatch "${FILESDIR}"/${PN}-4.8-libtool.patch
+ epatch "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
# use the includes from the prefix
- epatch "${FILESDIR}"/"${PN}"-4.6-jni-check-prefix-first.patch
- epatch "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
+ epatch "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
+ epatch "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
sed -e "/^DB_RELEASE_DATE=/s/%B %e, %Y/%Y-%m-%d/" -i dist/RELEASE
diff --git a/sys-libs/db/files/db-4.8.24-java-manifest-location.patch b/sys-libs/db/files/db-4.8.24-java-manifest-location.patch
new file mode 100644
index 000000000000..9cebadc52064
--- /dev/null
+++ b/sys-libs/db/files/db-4.8.24-java-manifest-location.patch
@@ -0,0 +1,12 @@
+diff -Nuar db-4.8.24.orig/dist/Makefile.in db-4.8.24/dist/Makefile.in
+--- db-4.8.24.orig/dist/Makefile.in 2009-09-19 23:39:45.286001896 +0000
++++ db-4.8.24/dist/Makefile.in 2009-09-19 23:41:13.079326882 +0000
+@@ -830,7 +830,7 @@
+ $(JAVA) -classpath $(JAVA_CLASSTOP) \
+ com.sleepycat.persist.model.ClassEnhancer $(JAVA_CLASSTOP)
+ cd $(JAVA_CLASSTOP) && \
+- $(JAR) cfm ../$(libj_jarfile) ../$(JAVA_MANIFEST) ./com/sleepycat
++ $(JAR) cfm ../$(libj_jarfile) $(JAVA_MANIFEST) ./com/sleepycat
+
+ $(libj_exjarfile): $(libj_jarfile) $(JAVA_EXSRCS)
+ @test -d $(JAVA_EXCLASSTOP) || \