summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-03-23 21:18:24 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-03-23 21:18:24 +0000
commit1c770077e2498cce1aa73e93ddd8bc57abb09444 (patch)
treeebe7f2389788063aeb986df3c4d48ae50dfe8d68 /sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
parentFix for change in location of mozilla-launcher (diff)
downloadgentoo-2-1c770077e2498cce1aa73e93ddd8bc57abb09444.tar.gz
gentoo-2-1c770077e2498cce1aa73e93ddd8bc57abb09444.tar.bz2
gentoo-2-1c770077e2498cce1aa73e93ddd8bc57abb09444.zip
Fixup copy operations to not replace symlinks with files. Add a fix ala
vapier for bug #85555 (more a abort if this glibc is going to kill / than a fix). (Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
index 6d6405820b86..90c1e1f330a2 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.2 2005/03/21 16:20:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.3 2005/03/23 21:18:24 azarah Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -899,13 +899,13 @@ src_install() {
# now, strip everything but the thread libs #46186
mkdir -p ${T}/thread-backup
- mv ${D}/$(alt_libdir)/lib{pthread,thread_db}* ${T}/thread-backup/
+ mv -f ${D}/$(alt_libdir)/lib{pthread,thread_db}* ${T}/thread-backup/
if use !nptlonly && want_nptl ; then
mkdir -p ${T}/thread-backup/tls
- mv ${D}/$(alt_libdir)/tls/lib{pthread,thread_db}* ${T}/thread-backup/tls
+ mv -f ${D}/$(alt_libdir)/tls/lib{pthread,thread_db}* ${T}/thread-backup/tls
fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -R -- ${T}/thread-backup/* ${D}/$(alt_libdir)/ || die
+ cp -a -- ${T}/thread-backup/* ${D}/$(alt_libdir)/ || die
# If librt.so is a symlink, change it into linker script (Redhat)
if [ -L "${D}/usr/$(get_libdir)/librt.so" -a "${LIBRT_LINKERSCRIPT}" = "yes" ]; then
@@ -1002,6 +1002,11 @@ EOF
doins ${FILESDIR}/locales.build
# example host.conf with multicast dns disabled by default
doins ${FILESDIR}/2.3.4/host.conf
+
+ for x in ls ps date ; do
+ env LD_LIBRARY_PATH="${D}/$(get_libdir)" ${x} > /dev/null \
+ || die "simple run test (${x}) failed"
+ done
}
must_exist() {