summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ostrow <dostrow@gentoo.org>2005-04-07 04:01:22 +0000
committerDaniel Ostrow <dostrow@gentoo.org>2005-04-07 04:01:22 +0000
commitdc7f9c5121d3598a696713fe9ea9b8b92b44b0c5 (patch)
tree291f9d311d843710483ff74f33f2965959a6ef5b /sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
parentfixed subshell sillyness (diff)
downloadgentoo-2-dc7f9c5121d3598a696713fe9ea9b8b92b44b0c5.tar.gz
gentoo-2-dc7f9c5121d3598a696713fe9ea9b8b92b44b0c5.tar.bz2
gentoo-2-dc7f9c5121d3598a696713fe9ea9b8b92b44b0c5.zip
fixed subshell sillyness
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
index 2558498bc880..3b19351908af 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.5 2005/03/25 06:17:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.6 2005/04/07 03:58:29 dostrow Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -732,6 +732,11 @@ src_compile() {
export CPATH=/usr/include/gentoo-multilib/default
fi
+ # hardened ppc64 parallelization periodically fails so drop to -j1
+ if use ppc64 && use hardened; then
+ MAKEOPTS="${MAKEOPTS} -j1"
+ fi
+
# do the linuxthreads build unless we're using nptlonly
if use !nptlonly ; then
glibc_do_configure linuxthreads