summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-07-31 15:05:20 +0000
committerHanno Böck <hanno@gentoo.org>2008-07-31 15:05:20 +0000
commitba29a3052376a61181d149b01d4d173e80532400 (patch)
tree13ef476550eca8b480cf797ea877d885c78f9cb4 /sys-libs/libchipcard
parentversion bump wrt #233002 (diff)
downloadgentoo-2-ba29a3052376a61181d149b01d4d173e80532400.tar.gz
gentoo-2-ba29a3052376a61181d149b01d4d173e80532400.tar.bz2
gentoo-2-ba29a3052376a61181d149b01d4d173e80532400.zip
libchipcard bump
(Portage version: 2.2_rc5/cvs/Linux 2.6.26 i686)
Diffstat (limited to 'sys-libs/libchipcard')
-rw-r--r--sys-libs/libchipcard/ChangeLog7
-rw-r--r--sys-libs/libchipcard/libchipcard-4.1.3.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-libs/libchipcard/ChangeLog b/sys-libs/libchipcard/ChangeLog
index 0dbf81968e0c..f00db4078131 100644
--- a/sys-libs/libchipcard/ChangeLog
+++ b/sys-libs/libchipcard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libchipcard
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libchipcard/ChangeLog,v 1.66 2008/06/26 12:11:19 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libchipcard/ChangeLog,v 1.67 2008/07/31 15:05:20 hanno Exp $
+
+*libchipcard-4.1.3 (31 Jul 2008)
+
+ 31 Jul 2008; Hanno Boeck <hanno@gentoo.org> +libchipcard-4.1.3.ebuild:
+ Version bump.
26 Jun 2008; Hanno Boeck <hanno@gentoo.org>
-files/libchipcard-ccid-dir.diff, libchipcard-3.0.3.ebuild,
diff --git a/sys-libs/libchipcard/libchipcard-4.1.3.ebuild b/sys-libs/libchipcard/libchipcard-4.1.3.ebuild
new file mode 100644
index 000000000000..71da2606f55b
--- /dev/null
+++ b/sys-libs/libchipcard/libchipcard-4.1.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libchipcard/libchipcard-4.1.3.ebuild,v 1.1 2008/07/31 15:05:20 hanno Exp $
+
+DESCRIPTION="Libchipcard is a library for easy access to chip cards via chip card readers (terminals)."
+HOMEPAGE="http://www.libchipcard.de"
+SRC_URI="http://files.hboeck.de/aq/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="debug doc ssl usb"
+
+DEPEND=">=sys-libs/gwenhywfar-3.1.1
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ usb? ( dev-libs/libusb )
+ >=sys-fs/sysfsutils-1.2.0"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable usb libusb` \
+ --localstatedir=/var \
+ --enable-pcsc || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ keepdir /var/log/chipcard \
+ /var/lib/chipcardd/newcerts \
+ /usr/lib/chipcardd/server/lowlevel
+
+ doinitd "${FILESDIR}/chipcardd4" || die
+
+ dodoc AUTHORS ChangeLog README doc/CERTIFICATES doc/CONFIG doc/IPCCOMMANDS || die
+ if use doc ; then
+ docinto tutorials
+ dodoc tutorials/*.{c,h,xml} tutorials/README || die
+ fi
+}