summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-01 13:06:01 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-01 13:06:01 +0000
commitccbec3d5023903612e719dcf49c0228fe8bd23ac (patch)
tree82b267c02cd76ac979a356a59ad851879ef1c88c /sys-libs/libcxx/libcxx-9999.ebuild
parentRemove vulnerable versions, bug #470904 (diff)
downloadgentoo-2-ccbec3d5023903612e719dcf49c0228fe8bd23ac.tar.gz
gentoo-2-ccbec3d5023903612e719dcf49c0228fe8bd23ac.tar.bz2
gentoo-2-ccbec3d5023903612e719dcf49c0228fe8bd23ac.zip
use clang -nostdlib / clang++ -nostdlib for compiling to try to avoid chicken and egg problems when bootstrapping.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs/libcxx/libcxx-9999.ebuild')
-rw-r--r--sys-libs/libcxx/libcxx-9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/sys-libs/libcxx/libcxx-9999.ebuild b/sys-libs/libcxx/libcxx-9999.ebuild
index 634966f3dfae..476f922575b8 100644
--- a/sys-libs/libcxx/libcxx-9999.ebuild
+++ b/sys-libs/libcxx/libcxx-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-9999.ebuild,v 1.11 2013/06/18 16:08:08 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-9999.ebuild,v 1.12 2013/07/01 13:06:01 aballier Exp $
EAPI=5
@@ -60,9 +60,8 @@ src_configure() {
# Needs to be built with clang. gcc-4.6.3 fails at least.
# TODO: cross-compile ?
- export CC=clang
- export CXX=clang++
- has_version 'sys-libs/libcxx' && export CXX="clang++ -stdlib=libc++"
+ export CC="clang -nostdlib"
+ export CXX="clang++ -nostdlib"
if use static-libs ; then
local mycmakeargs=( "${mycmakeargs_base[@]}" "-DLIBCXX_ENABLE_SHARED=OFF" )