summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2013-04-25 19:58:02 +0000
committerSven Vermeulen <swift@gentoo.org>2013-04-25 19:58:02 +0000
commitef05b0fc91d63303e78ab2d0f8f3f255d0fa9c79 (patch)
tree38529290403213020b6440d469a9ebba84babf28 /sys-libs/libselinux
parentEnabling utf-8 support (diff)
downloadgentoo-2-ef05b0fc91d63303e78ab2d0f8f3f255d0fa9c79.tar.gz
gentoo-2-ef05b0fc91d63303e78ab2d0f8f3f255d0fa9c79.tar.bz2
gentoo-2-ef05b0fc91d63303e78ab2d0f8f3f255d0fa9c79.zip
Fix bug #467258
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xCDBA2FDB)
Diffstat (limited to 'sys-libs/libselinux')
-rw-r--r--sys-libs/libselinux/ChangeLog13
-rw-r--r--sys-libs/libselinux/libselinux-2.1.13-r1.ebuild129
-rw-r--r--sys-libs/libselinux/libselinux-2.1.13-r2.ebuild129
3 files changed, 270 insertions, 1 deletions
diff --git a/sys-libs/libselinux/ChangeLog b/sys-libs/libselinux/ChangeLog
index 4aa8b3a1eb0a..9808b41a6bfc 100644
--- a/sys-libs/libselinux/ChangeLog
+++ b/sys-libs/libselinux/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-libs/libselinux
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.95 2013/04/16 09:54:25 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.96 2013/04/25 19:58:02 swift Exp $
+
+*libselinux-2.1.13-r2 (25 Apr 2013)
+
+ 25 Apr 2013; Sven Vermeulen <swift@gentoo.org> +libselinux-2.1.13-r1.ebuild,
+ +libselinux-2.1.13-r2.ebuild:
+ Fix bug #467258 - add selinux_current_policy_path
+
+*libselinux-2.1.13-r1 (25 Apr 2013)
+
+ 25 Apr 2013; Sven Vermeulen <swift@gentoo.org> +libselinux-2.1.13-r1.ebuild:
+ New upstream release
16 Apr 2013; Sven Vermeulen <swift@gentoo.org> libselinux-2.1.12-r3.ebuild:
Stabilize libselinux-2.1.12-r3
diff --git a/sys-libs/libselinux/libselinux-2.1.13-r1.ebuild b/sys-libs/libselinux/libselinux-2.1.13-r1.ebuild
new file mode 100644
index 000000000000..e1353fe291af
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-2.1.13-r1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.1.13-r1.ebuild,v 1.1 2013/04/25 19:58:02 swift Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 *-jython *-pypy-*"
+USE_RUBY="ruby18 ruby19"
+RUBY_OPTIONAL="yes"
+
+inherit multilib python toolchain-funcs eutils ruby-ng
+
+SEPOL_VER="2.1.9"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20130423/${P}.tar.gz
+ http://dev.gentoo.org/~swift/patches/${PN}/patchbundle-${P}-r1.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python ruby static-libs"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=dev-libs/libpcre-8.30-r2[static-libs?]
+ ruby? ( $(ruby_implementations_depend) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ ruby? ( >=dev-lang/swig-2.0.9 )
+ python? ( >=dev-lang/swig-2.0.9 )"
+
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i \
+ -e "/^LIBDIR/s/lib/$(get_libdir)/" \
+ -e "/^SHLIBDIR/s/lib/$(get_libdir)/" \
+ src/Makefile utils/Makefile || die
+
+ EPATCH_MULTI_MSG="Applying libselinux patches ... " \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
+ EPATCH_FORCE="yes" \
+ epatch
+
+ epatch_user
+}
+
+each_ruby_compile() {
+ local RUBYLIBVER=$(${RUBY} -e 'print RUBY_VERSION.split(".")[0..1].join(".")')
+ cd "${WORKDIR}/${P}"
+ cp -r src src-ruby-${RUBYLIBVER}
+ cd src-ruby-${RUBYLIBVER}
+
+ if [[ "${RUBYLIBVER}" == "1.8" ]]; then
+ emake CC="$(tc-getCC)" RUBY="${RUBY}" RUBYINC="-I$(ruby_get_hdrdir)" LDFLAGS="-fPIC $($(tc-getPKG_CONFIG) libpcre --libs) -lpthread ${LDFLAGS}" rubywrap || die
+ else
+ emake CC="$(tc-getCC)" RUBY="${RUBY}" LDFLAGS="-fPIC $($(tc-getPKG_CONFIG) libpcre --libs) ${LDFLAGS} -lpthread" rubywrap || die
+ fi
+}
+
+src_compile() {
+ tc-export RANLIB
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ LDFLAGS="-fPIC $($(tc-getPKG_CONFIG) libpcre --libs) ${LDFLAGS} -lpthread" all || die
+
+ if use python; then
+ python_copy_sources src
+ building() {
+ emake CC="$(tc-getCC)" PYINC="-I$(python_get_includedir)" PYTHONLIBDIR="$(python_get_library -l)" PYPREFIX="python-$(python_get_version)" LDFLAGS="-fPIC $($(tc-getPKG_CONFIG) libpcre --libs) ${LDFLAGS} -lpthread" pywrap
+ }
+ python_execute_function -s --source-dir src building
+ fi
+
+ if use ruby; then
+ ruby-ng_src_compile
+ fi
+}
+
+each_ruby_install() {
+ local RUBYLIBVER=$(${RUBY} -e 'print RUBY_VERSION.split(".")[0..1].join(".")')
+
+ cd "${WORKDIR}/${P}/src-ruby-${RUBYLIBVER}"
+ emake RUBY="${RUBY}" DESTDIR="${D}" install-rubywrap || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" install-pywrap
+ }
+ python_execute_function -s --source-dir src installation
+ fi
+
+ if use ruby; then
+ ruby-ng_src_install
+ fi
+
+ use static-libs || rm "${D}"/usr/lib*/*.a
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize selinux
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup selinux
+ fi
+}
diff --git a/sys-libs/libselinux/libselinux-2.1.13-r2.ebuild b/sys-libs/libselinux/libselinux-2.1.13-r2.ebuild
new file mode 100644
index 000000000000..bca50def9f86
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-2.1.13-r2.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.1.13-r2.ebuild,v 1.1 2013/04/25 19:58:02 swift Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 *-jython *-pypy-*"
+USE_RUBY="ruby18 ruby19"
+RUBY_OPTIONAL="yes"
+
+inherit multilib python toolchain-funcs eutils ruby-ng
+
+SEPOL_VER="2.1.9"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20130423/${P}.tar.gz
+ http://dev.gentoo.org/~swift/patches/${PN}/patchbundle-${P}-r2.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python ruby static-libs"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=dev-libs/libpcre-8.30-r2[static-libs?]
+ ruby? ( $(ruby_implementations_depend) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ ruby? ( >=dev-lang/swig-2.0.9 )
+ python? ( >=dev-lang/swig-2.0.9 )"
+
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i \
+ -e "/^LIBDIR/s/lib/$(get_libdir)/" \
+ -e "/^SHLIBDIR/s/lib/$(get_libdir)/" \
+ src/Makefile utils/Makefile || die
+
+ EPATCH_MULTI_MSG="Applying libselinux patches ... " \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
+ EPATCH_FORCE="yes" \
+ epatch
+
+ epatch_user
+}
+
+each_ruby_compile() {
+ local RUBYLIBVER=$(${RUBY} -e 'print RUBY_VERSION.split(".")[0..1].join(".")')
+ cd "${WORKDIR}/${P}"
+ cp -r src src-ruby-${RUBYLIBVER}
+ cd src-ruby-${RUBYLIBVER}
+
+ if [[ "${RUBYLIBVER}" == "1.8" ]]; then
+ emake CC="$(tc-getCC)" RUBY="${RUBY}" RUBYINC="-I$(ruby_get_hdrdir)" LDFLAGS="-fPIC $($(tc-getPKG_CONFIG) libpcre --libs) -lpthread ${LDFLAGS}" rubywrap || die
+ else
+ emake CC="$(tc-getCC)" RUBY="${RUBY}" LDFLAGS="-fPIC $($(tc-getPKG_CONFIG) libpcre --libs) ${LDFLAGS} -lpthread" rubywrap || die
+ fi
+}
+
+src_compile() {
+ tc-export RANLIB
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ LDFLAGS="-fPIC $($(tc-getPKG_CONFIG) libpcre --libs) ${LDFLAGS} -lpthread" all || die
+
+ if use python; then
+ python_copy_sources src
+ building() {
+ emake CC="$(tc-getCC)" PYINC="-I$(python_get_includedir)" PYTHONLIBDIR="$(python_get_library -l)" PYPREFIX="python-$(python_get_version)" LDFLAGS="-fPIC $($(tc-getPKG_CONFIG) libpcre --libs) ${LDFLAGS} -lpthread" pywrap
+ }
+ python_execute_function -s --source-dir src building
+ fi
+
+ if use ruby; then
+ ruby-ng_src_compile
+ fi
+}
+
+each_ruby_install() {
+ local RUBYLIBVER=$(${RUBY} -e 'print RUBY_VERSION.split(".")[0..1].join(".")')
+
+ cd "${WORKDIR}/${P}/src-ruby-${RUBYLIBVER}"
+ emake RUBY="${RUBY}" DESTDIR="${D}" install-rubywrap || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" install-pywrap
+ }
+ python_execute_function -s --source-dir src installation
+ fi
+
+ if use ruby; then
+ ruby-ng_src_install
+ fi
+
+ use static-libs || rm "${D}"/usr/lib*/*.a
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize selinux
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup selinux
+ fi
+}