summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2013-08-23 07:26:05 +0000
committerSven Vermeulen <swift@gentoo.org>2013-08-23 07:26:05 +0000
commit77e17e39cc24e1993c5f10e405e8976bd84f1f96 (patch)
treeecf32d3a475974a962ddfb81fa1f3cee0e443103 /sys-libs/libsepol
parentadd upstream bug reference (diff)
downloadgentoo-2-77e17e39cc24e1993c5f10e405e8976bd84f1f96.tar.gz
gentoo-2-77e17e39cc24e1993c5f10e405e8976bd84f1f96.tar.bz2
gentoo-2-77e17e39cc24e1993c5f10e405e8976bd84f1f96.zip
Fix bug #481782 - Put right library paths in libsepol.pc file to get proper pkg-config --libs output
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xCDBA2FDB)
Diffstat (limited to 'sys-libs/libsepol')
-rw-r--r--sys-libs/libsepol/ChangeLog8
-rw-r--r--sys-libs/libsepol/libsepol-2.1.9-r3.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index 5b46f5f6cacc..715956a6a745 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libsepol
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.58 2013/08/15 18:22:22 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.59 2013/08/23 07:26:05 swift Exp $
+
+*libsepol-2.1.9-r3 (23 Aug 2013)
+
+ 23 Aug 2013; Sven Vermeulen <swift@gentoo.org> +libsepol-2.1.9-r3.ebuild:
+ Fix bug #481782 - Put right library paths in libsepol.pc file to get proper
+ pkg-config --libs output
*libsepol-2.1.9-r2 (15 Aug 2013)
diff --git a/sys-libs/libsepol/libsepol-2.1.9-r3.ebuild b/sys-libs/libsepol/libsepol-2.1.9-r3.ebuild
new file mode 100644
index 000000000000..adc6dbae496b
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.1.9-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.1.9-r3.ebuild,v 1.1 2013/08/23 07:26:05 swift Exp $
+
+EAPI="4"
+
+inherit multilib toolchain-funcs eutils multilib-minimal
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20130423/${P}.tar.gz
+ http://dev.gentoo.org/~swift/patches/${PN}/patchbundle-${P}-r1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ EPATCH_MULTI_MSG="Applying libsepol patches ... " \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
+ EPATCH_FORCE="yes" \
+ epatch
+
+ epatch_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export RANLIB;
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+multilib_src_install() {
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake DESTDIR="${D}" install
+}