summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2004-11-22 03:22:20 +0000
committerTom Gall <tgall@gentoo.org>2004-11-22 03:22:20 +0000
commitbac1e2e17d26ed2d6ee113d30f180effeb3a8575 (patch)
treef27492fc027b98f274690efc0c26197c18dd851e /sys-libs/libstdc++-v3
parentold (Manifest recommit) (diff)
downloadgentoo-2-bac1e2e17d26ed2d6ee113d30f180effeb3a8575.tar.gz
gentoo-2-bac1e2e17d26ed2d6ee113d30f180effeb3a8575.tar.bz2
gentoo-2-bac1e2e17d26ed2d6ee113d30f180effeb3a8575.zip
fix bug #70972
Diffstat (limited to 'sys-libs/libstdc++-v3')
-rw-r--r--sys-libs/libstdc++-v3/ChangeLog5
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild8
2 files changed, 10 insertions, 3 deletions
diff --git a/sys-libs/libstdc++-v3/ChangeLog b/sys-libs/libstdc++-v3/ChangeLog
index 59d3ddd5113f..719bf10287e7 100644
--- a/sys-libs/libstdc++-v3/ChangeLog
+++ b/sys-libs/libstdc++-v3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/libstdc++-v3
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.29 2004/11/11 09:33:09 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.30 2004/11/22 03:22:20 tgall Exp $
+
+ 21 Nov 2004; Tom Gall <tgall@gentoo.org> libstdc++-v3-3.3.4.ebuild:
+ fix bug #70972 on ppc64
11 Nov 2004; Joshua Kinard <kumba@gentoo.org> libstdc++-v3-3.3.3-r1.ebuild,
libstdc++-v3-3.3.4.ebuild:
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
index 24f7572eaaf2..89a561788723 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild,v 1.9 2004/11/11 09:33:09 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild,v 1.10 2004/11/22 03:22:20 tgall Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -60,11 +60,15 @@ do_filter_flags() {
# it is safe. This is especially true for gcc 3.3 + 3.4
replace-flags -O? -O2
-
# gcc 3.3 doesn't support -mtune on numerous archs, so xgcc will fail
setting="`get-flag mtune`"
[ ! -z "${setting}" ] && filter-flags -mtune="${setting}"
+ # in gcc 3.3 there is a bug on ppc64 where if -mcpu is used
+ # the compiler incorrectly assumes the code you are about to build
+ # is 32 bit
+ use ppc64 setting="`get-flag mcpu`"
+ [ ! -z "${setting}" ] && filter-flags -mcpu="${setting}"
# only allow the flags that we -know- are supported
transform_known_flags