summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-27 08:01:12 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-27 08:01:12 +0000
commite628908e469aad2bc8b0437c4f8500223609f1ee (patch)
tree445b2e980791f03f4f16c5110358423d5197b9bb /sys-libs/newlib/newlib-2.1.0.ebuild
parentVersion Bump (diff)
downloadgentoo-2-e628908e469aad2bc8b0437c4f8500223609f1ee.tar.gz
gentoo-2-e628908e469aad2bc8b0437c4f8500223609f1ee.tar.bz2
gentoo-2-e628908e469aad2bc8b0437c4f8500223609f1ee.zip
Use more readable CTARGET setup logic.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-libs/newlib/newlib-2.1.0.ebuild')
-rw-r--r--sys-libs/newlib/newlib-2.1.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/newlib/newlib-2.1.0.ebuild b/sys-libs/newlib/newlib-2.1.0.ebuild
index b8ed3d0b3f63..45f9ed8afb8f 100644
--- a/sys-libs/newlib/newlib-2.1.0.ebuild
+++ b/sys-libs/newlib/newlib-2.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-2.1.0.ebuild,v 1.3 2014/10/31 01:55:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-2.1.0.ebuild,v 1.4 2015/02/27 08:01:12 vapier Exp $
EAPI="4"
@@ -9,8 +9,8 @@ inherit flag-o-matic toolchain-funcs eutils
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
fi
fi