summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-03-23 23:09:33 +0000
committerMike Frysinger <vapier@gentoo.org>2012-03-23 23:09:33 +0000
commit54009d327ec57ec1812dc91713f7ccf79da13b5b (patch)
tree07002e439e6d1c0b3f04622bd775061574b783e6 /sys-libs/newlib
parentRestore ~x86-fbsd. (diff)
downloadgentoo-2-54009d327ec57ec1812dc91713f7ccf79da13b5b.tar.gz
gentoo-2-54009d327ec57ec1812dc91713f7ccf79da13b5b.tar.bz2
gentoo-2-54009d327ec57ec1812dc91713f7ccf79da13b5b.zip
Fix install for cris targets. Update to EAPI 4.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/newlib')
-rw-r--r--sys-libs/newlib/ChangeLog6
-rw-r--r--sys-libs/newlib/files/newlib-1.20.0-cris-install.patch13
-rw-r--r--sys-libs/newlib/newlib-1.20.0.ebuild22
3 files changed, 31 insertions, 10 deletions
diff --git a/sys-libs/newlib/ChangeLog b/sys-libs/newlib/ChangeLog
index 008ec53e61a1..c7e07c11caf2 100644
--- a/sys-libs/newlib/ChangeLog
+++ b/sys-libs/newlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/newlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.16 2012/01/14 10:32:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.17 2012/03/23 23:09:33 vapier Exp $
+
+ 23 Mar 2012; Mike Frysinger <vapier@gentoo.org> newlib-1.20.0.ebuild,
+ +files/newlib-1.20.0-cris-install.patch:
+ Fix install for cris targets. Update to EAPI 4.
*newlib-1.20.0 (14 Jan 2012)
diff --git a/sys-libs/newlib/files/newlib-1.20.0-cris-install.patch b/sys-libs/newlib/files/newlib-1.20.0-cris-install.patch
new file mode 100644
index 000000000000..05f571fbe258
--- /dev/null
+++ b/sys-libs/newlib/files/newlib-1.20.0-cris-install.patch
@@ -0,0 +1,13 @@
+sent upstream already
+
+--- libgloss/cris/Makefile.in
++++ libgloss/cris/Makefile.in
+@@ -228,7 +228,7 @@ install-lin:
+ *) \
+ set -e; \
+ for x in ${LIN_BSP} ${LIN_SCRIPTS} ${LIN_EXTRA}; do \
+- ${INSTALL_DATA} $$x ${tooldir}/lib${MULTISUBDIR}/$$x; \
++ ${INSTALL_DATA} $$x $(DESTDIR)${tooldir}/lib${MULTISUBDIR}/$$x; \
+ done;; \
+ esac
+
diff --git a/sys-libs/newlib/newlib-1.20.0.ebuild b/sys-libs/newlib/newlib-1.20.0.ebuild
index 64ad7f9e410d..29ea3b99ba94 100644
--- a/sys-libs/newlib/newlib-1.20.0.ebuild
+++ b/sys-libs/newlib/newlib-1.20.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.20.0.ebuild,v 1.1 2012/01/14 10:32:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.20.0.ebuild,v 1.2 2012/03/23 23:09:33 vapier Exp $
+
+EAPI="4"
inherit eutils flag-o-matic toolchain-funcs
@@ -36,12 +38,11 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
- mkdir -p "${NEWLIBBUILD}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cris-install.patch
}
-src_compile() {
+src_configure() {
# we should fix this ...
unset LDFLAGS
CHOST=${CTARGET} strip-unsupported-flags
@@ -55,20 +56,23 @@ src_compile() {
&& myconf="${myconf} --disable-newlib-multithread" \
|| myconf="${myconf} $(use_enable threads newlib-multithread)"
+ mkdir -p "${NEWLIBBUILD}"
cd "${NEWLIBBUILD}"
ECONF_SOURCE=${S} \
econf \
$(use_enable unicode newlib-mb) \
$(use_enable nls) \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
+ ${myconf}
+}
+
+src_compile() {
+ emake -C "${NEWLIBBUILD}"
}
src_install() {
cd "${NEWLIBBUILD}"
- emake -j1 DESTDIR="${D}" install || die
+ emake -j1 DESTDIR="${D}" install
# env -uRESTRICT CHOST=${CTARGET} prepallstrip
# minor hack to keep things clean
rm -fR "${D}"/usr/share/info