summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-11-01 08:19:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-11-01 08:19:05 +0000
commitcfdd2de5de3967c21239a043b9e6c18e2fab16df (patch)
tree2027c19ca58998ff4af98c8be52cb098a340ff33 /sys-libs/openhpi/openhpi-2.10.1.ebuild
parentCleanup of src_test part 1 for bug #193362. (diff)
downloadgentoo-2-cfdd2de5de3967c21239a043b9e6c18e2fab16df.tar.gz
gentoo-2-cfdd2de5de3967c21239a043b9e6c18e2fab16df.tar.bz2
gentoo-2-cfdd2de5de3967c21239a043b9e6c18e2fab16df.zip
Version bump, per bug #199024. Thanks to Tais M. Hansen <tais.hansen@osd.dk> for scripts.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-hardened-r4 x86_64)
Diffstat (limited to 'sys-libs/openhpi/openhpi-2.10.1.ebuild')
-rw-r--r--sys-libs/openhpi/openhpi-2.10.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-libs/openhpi/openhpi-2.10.1.ebuild b/sys-libs/openhpi/openhpi-2.10.1.ebuild
new file mode 100644
index 000000000000..6d41226df1a3
--- /dev/null
+++ b/sys-libs/openhpi/openhpi-2.10.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/openhpi/openhpi-2.10.1.ebuild,v 1.1 2008/11/01 08:19:05 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="OpenHPI provides an open source implementation of the Service Availability Forum (SAF) Hardware Platform Interface (HPI)"
+HOMEPAGE="http://www.openhpi.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="snmp"
+
+COMMONDEPEND=">=dev-libs/glib-2.2
+ sys-fs/e2fsprogs
+ sys-fs/sysfsutils
+ >=sys-libs/openipmi-1.4.20
+ snmp? ( >=net-analyzer/net-snmp-5.07 )"
+RDEPEND="${COMMONDEPEND}"
+DEPEND="${COMMONDEPEND}
+ >=sys-devel/autoconf-2.57
+ >=sys-devel/automake-1.8
+ >=sys-devel/gcc-3.2.0
+ virtual/os-headers"
+
+src_compile() {
+ econf --with-varpath=/var/lib/openhpi \
+ --enable-clients \
+ --enable-cpp_wrappers \
+ --enable-daemon \
+ --enable-ipmi \
+ --enable-ipmidirect \
+ --enable-sysfs \
+ --enable-thread \
+ --enable-watchdog \
+ --enable-simulator \
+ --disable-testcover \
+ $(use_enable snmp snmp_bc) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # Stage main files.
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # Stage conf.d-file and init.d-script.
+ newinitd "${FILESDIR}"/openhpi-initd openhpid
+ newconfd "${FILESDIR}"/openhpi-confd openhpid
+
+ # Stage documentation.
+ dodoc README
+
+ # Make sure the data dir exists or openhpid will fail silently.
+ keepdir /var/lib/openhpi/
+}