summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-29 02:11:42 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-29 02:11:42 +0000
commit833e5b9f1b3ebcf5329ef4f2bcd915d0e63cf337 (patch)
treec18994ea0fcec97a1236169cad7e3d44208ad833 /sys-libs/readline
parentstable on ppc64, bug #58191 (Manifest recommit) (diff)
downloadgentoo-2-833e5b9f1b3ebcf5329ef4f2bcd915d0e63cf337.tar.gz
gentoo-2-833e5b9f1b3ebcf5329ef4f2bcd915d0e63cf337.tar.bz2
gentoo-2-833e5b9f1b3ebcf5329ef4f2bcd915d0e63cf337.zip
ver bump #58648 and upgrade support #29865
Diffstat (limited to 'sys-libs/readline')
-rw-r--r--sys-libs/readline/ChangeLog9
-rw-r--r--sys-libs/readline/files/digest-readline-5.01
-rw-r--r--sys-libs/readline/readline-4.3-r4.ebuild27
-rw-r--r--sys-libs/readline/readline-4.3-r5.ebuild22
-rw-r--r--sys-libs/readline/readline-4.3-r6.ebuild16
-rw-r--r--sys-libs/readline/readline-5.0.ebuild71
6 files changed, 133 insertions, 13 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index b177b0ea449a..928c0f28d6c8 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/readline
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.31 2004/07/02 08:50:47 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.32 2004/07/29 02:11:42 vapier Exp $
+
+*readline-5.0 (28 Jul 2004)
+
+ 28 Jul 2004; Mike Frysinger <vapier@gentoo.org> readline-4.3-r4.ebuild,
+ readline-4.3-r5.ebuild, readline-4.3-r6.ebuild, +readline-5.0.ebuild:
+ Version bump #58648. Also add in support for upgrading from previous
+ incompatible versions #29865.
02 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
readline-4.1-r5.ebuild, readline-4.2a-r1.ebuild, readline-4.2a-r2.ebuild:
diff --git a/sys-libs/readline/files/digest-readline-5.0 b/sys-libs/readline/files/digest-readline-5.0
new file mode 100644
index 000000000000..fb556f249386
--- /dev/null
+++ b/sys-libs/readline/files/digest-readline-5.0
@@ -0,0 +1 @@
+MD5 9a39d15f1ed592883f8c6671e8c13120 readline-5.0.tar.gz 1808946
diff --git a/sys-libs/readline/readline-4.3-r4.ebuild b/sys-libs/readline/readline-4.3-r4.ebuild
index 59cc428bf4c8..441d7b632fd0 100644
--- a/sys-libs/readline/readline-4.3-r4.ebuild
+++ b/sys-libs/readline/readline-4.3-r4.ebuild
@@ -1,22 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r4.ebuild,v 1.20 2004/06/24 23:09:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r4.ebuild,v 1.21 2004/07/29 02:11:42 vapier Exp $
inherit eutils
# Official patches
PLEVEL="x001 x002"
-S="${WORKDIR}/${P}"
DESCRIPTION="Another cute console display library"
-SRC_URI="ftp://ftp.gnu.org/gnu/readline/${P}.tar.gz
- ftp://gatekeeper.dec.com/pub/GNU/readline/${P}.tar.gz
- ${PLEVEL//x/ftp://ftp.gnu.org/gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+SRC_URI="ftp://ftp.gnu.org/gnu/readline/${P}.tar.gz
+ ftp://gatekeeper.dec.com/pub/GNU/readline/${P}.tar.gz
+ ${PLEVEL//x/ftp://ftp.gnu.org/gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="amd64 x86 ppc sparc alpha hppa mips ia64"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha hppa amd64 ia64"
+IUSE=""
# We must be sertain that we have a bash that is linked
# to its internal readline, else we may get problems.
@@ -76,5 +76,18 @@ src_install() {
docinto ps
dodoc doc/*.ps
dohtml -r doc
+
+ # Backwards compatibility #29865
+ if [ -e ${ROOT}/lib/libreadline.so.4.1 ] ; then
+ cp -a ${ROOT}/lib/libreadline.so.4.1 ${D}/lib/
+ touch ${D}/lib/libreadline.so.4.1
+ fi
}
+pkg_postinst() {
+ if [ -e ${ROOT}/lib/libreadline.so.4.1 ] ; then
+ ewarn "Your old readline libraries have been copied over."
+ ewarn "You should run 'revdep-rebuild --soname libreadline.so.4.1' asap."
+ ewarn "Once you have, you can safely delete /lib/libreadline.so.4.1"
+ fi
+}
diff --git a/sys-libs/readline/readline-4.3-r5.ebuild b/sys-libs/readline/readline-4.3-r5.ebuild
index 4031c27a3155..cddeaf2920ec 100644
--- a/sys-libs/readline/readline-4.3-r5.ebuild
+++ b/sys-libs/readline/readline-4.3-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r5.ebuild,v 1.12 2004/07/27 14:29:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r5.ebuild,v 1.13 2004/07/29 02:11:42 vapier Exp $
inherit eutils gnuconfig
@@ -10,12 +10,12 @@ PLEVEL="x001 x002 x003 x004 x005"
DESCRIPTION="Another cute console display library"
HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
SRC_URI="ftp://ftp.gnu.org/gnu/readline/${P}.tar.gz
- ftp://gatekeeper.dec.com/pub/GNU/readline/${P}.tar.gz
- ${PLEVEL//x/ftp://ftp.gnu.org/gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
+ ftp://gatekeeper.dec.com/pub/GNU/readline/${P}.tar.gz
+ ${PLEVEL//x/ftp://ftp.gnu.org/gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc alpha arm ~mips hppa amd64 ~ia64 ppc64 s390"
+KEYWORDS="~x86 ~ppc ~sparc ~mips alpha arm hppa amd64 ~ia64 ppc64 s390"
IUSE=""
# We must be certain that we have a bash that is linked
@@ -71,4 +71,18 @@ src_install() {
docinto ps
dodoc doc/*.ps
dohtml -r doc
+
+ # Backwards compatibility #29865
+ if [ -e ${ROOT}/lib/libreadline.so.4.1 ] ; then
+ cp -a ${ROOT}/lib/libreadline.so.4.1 ${D}/lib/
+ touch ${D}/lib/libreadline.so.4.1
+ fi
+}
+
+pkg_postinst() {
+ if [ -e ${ROOT}/lib/libreadline.so.4.1 ] ; then
+ ewarn "Your old readline libraries have been copied over."
+ ewarn "You should run 'revdep-rebuild --soname libreadline.so.4.1' asap."
+ ewarn "Once you have, you can safely delete /lib/libreadline.so.4.1"
+ fi
}
diff --git a/sys-libs/readline/readline-4.3-r6.ebuild b/sys-libs/readline/readline-4.3-r6.ebuild
index af997e575d4b..c4b6b806ad63 100644
--- a/sys-libs/readline/readline-4.3-r6.ebuild
+++ b/sys-libs/readline/readline-4.3-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r6.ebuild,v 1.2 2004/07/27 14:29:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r6.ebuild,v 1.3 2004/07/29 02:11:42 vapier Exp $
inherit eutils gnuconfig
@@ -74,4 +74,18 @@ src_install() {
docinto ps
dodoc doc/*.ps
dohtml -r doc
+
+ # Backwards compatibility #29865
+ if [ -e ${ROOT}/lib/libreadline.so.4.1 ] ; then
+ cp -a ${ROOT}/lib/libreadline.so.4.1 ${D}/lib/
+ touch ${D}/lib/libreadline.so.4.1
+ fi
+}
+
+pkg_postinst() {
+ if [ -e ${ROOT}/lib/libreadline.so.4.1 ] ; then
+ ewarn "Your old readline libraries have been copied over."
+ ewarn "You should run 'revdep-rebuild --soname libreadline.so.4.1' asap."
+ ewarn "Once you have, you can safely delete /lib/libreadline.so.4.1"
+ fi
}
diff --git a/sys-libs/readline/readline-5.0.ebuild b/sys-libs/readline/readline-5.0.ebuild
new file mode 100644
index 000000000000..cbe4939bf6fb
--- /dev/null
+++ b/sys-libs/readline/readline-5.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.0.ebuild,v 1.1 2004/07/29 02:11:42 vapier Exp $
+
+inherit eutils gnuconfig
+
+# Official patches
+PLEVEL=""
+
+DESCRIPTION="Another cute console display library"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+SRC_URI="ftp://ftp.cwru.edu/pub/bash/${P}.tar.gz
+ mirror://gnu/readline/${P}.tar.gz
+ ftp://gatekeeper.dec.com/pub/GNU/readline/${P}.tar.gz
+ ${PLEVEL//x/ftp://ftp.gnu.org/gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+IUSE=""
+
+# We must be certain that we have a bash that is linked
+# to its internal readline, else we may get problems.
+DEPEND=">=app-shells/bash-2.05b-r2
+ >=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ for x in ${PLEVEL//x}
+ do
+ epatch ${DISTDIR}/${PN}${PV/\.}-${x}
+ done
+
+ gnuconfig_update
+}
+
+src_compile() {
+ econf --with-curses || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodir /lib
+ mv ${D}/usr/lib/*.so* ${D}/lib
+
+ # Bug #4411
+ gen_usr_ldscript libreadline.so
+ gen_usr_ldscript libhistory.so
+
+ dodoc CHANGELOG CHANGES README USAGE NEWS
+ docinto ps
+ dodoc doc/*.ps
+ dohtml -r doc
+
+ # Backwards compatibility #29865
+ if [ -e ${ROOT}/lib/libreadline.so.4 ] ; then
+ cp -a ${ROOT}/lib/libreadline.so.4* ${D}/lib/
+ touch ${D}/lib/libreadline.so.4*
+ fi
+}
+
+pkg_postinst() {
+ if [ -e ${ROOT}/lib/libreadline.so.4 ] ; then
+ ewarn "Your old readline libraries have been copied over."
+ ewarn "You should run 'revdep-rebuild --soname libreadline.so.4' asap."
+ ewarn "Once you have, you can safely delete /lib/libreadline.so.4*"
+ fi
+}