summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-04 00:05:23 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-04 00:05:23 +0000
commitaee61c274a5afe3abd74679429e902e9a459dbc9 (patch)
tree7ac36b7191e41ba2ff734c38d13bc474602fb2c5 /sys-libs/uclibc++/uclibc++-0.1.12.ebuild
parentold (diff)
downloadgentoo-2-aee61c274a5afe3abd74679429e902e9a459dbc9.tar.gz
gentoo-2-aee61c274a5afe3abd74679429e902e9a459dbc9.tar.bz2
gentoo-2-aee61c274a5afe3abd74679429e902e9a459dbc9.zip
alpha/amd64/hppa love
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-libs/uclibc++/uclibc++-0.1.12.ebuild')
-rw-r--r--sys-libs/uclibc++/uclibc++-0.1.12.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-libs/uclibc++/uclibc++-0.1.12.ebuild b/sys-libs/uclibc++/uclibc++-0.1.12.ebuild
index d787e5893c74..2292c468d4b1 100644
--- a/sys-libs/uclibc++/uclibc++-0.1.12.ebuild
+++ b/sys-libs/uclibc++/uclibc++-0.1.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc++/uclibc++-0.1.12.ebuild,v 1.1 2005/12/11 16:46:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc++/uclibc++-0.1.12.ebuild,v 1.2 2006/01/04 00:05:23 vapier Exp $
inherit eutils toolchain-funcs
@@ -19,7 +19,7 @@ LICENSE="GPL-2"
[[ ${CTARGET} != ${CHOST} ]] \
&& SLOT="${CTARGET}" \
|| SLOT="0"
-KEYWORDS="~arm ~ppc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~x86"
IUSE="debug static"
DEPEND=""
@@ -28,12 +28,15 @@ S=${WORKDIR}/uClibc++
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
make defconfig || die "defconfig failed"
local target
case $(tc-arch ${CTARGET}) in
+ alpha) target="alpha";;
+ amd64) target="x86_64";;
arm) target="arm";;
+ hppa) target="hppa";;
mips) target="mips";;
ppc) target="powerpc";;
x86) target="i386";;