summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-04 20:06:39 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-04 20:06:39 +0000
commit0655216643acbf68637b730dad7c1d3dc8be342d (patch)
tree596ded2c9155a3566be9d19d368c0b420b2e0aa8 /sys-libs
parentWeekly gcc-4.1 snapshot bump (diff)
downloadgentoo-2-0655216643acbf68637b730dad7c1d3dc8be342d.tar.gz
gentoo-2-0655216643acbf68637b730dad7c1d3dc8be342d.tar.bz2
gentoo-2-0655216643acbf68637b730dad7c1d3dc8be342d.zip
Version bump.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/ChangeLog7
-rw-r--r--sys-libs/readline/files/digest-readline-5.1_p29
-rw-r--r--sys-libs/readline/readline-5.1_p2.ebuild109
3 files changed, 124 insertions, 1 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index a09b540c346c..fd8d1789e386 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.59 2006/01/05 11:20:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.60 2006/02/04 20:06:39 vapier Exp $
+
+*readline-5.1_p2 (04 Feb 2006)
+
+ 04 Feb 2006; Mike Frysinger <vapier@gentoo.org> +readline-5.1_p2.ebuild:
+ Version bump.
05 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+files/readline-5.1-rlfe-libutil.patch, readline-5.1-r2.ebuild:
diff --git a/sys-libs/readline/files/digest-readline-5.1_p2 b/sys-libs/readline/files/digest-readline-5.1_p2
new file mode 100644
index 000000000000..5f3ee530055d
--- /dev/null
+++ b/sys-libs/readline/files/digest-readline-5.1_p2
@@ -0,0 +1,9 @@
+MD5 7ee5a692db88b30ca48927a13fd60e46 readline-5.1.tar.gz 2030276
+RMD160 e7e755bcde7a38740dd0ef6fc10d66614b74ea21 readline-5.1.tar.gz 2030276
+SHA256 163ec6407ec75a709c9077657b1fca9314cc74999d57d1c35ab185702bb067c6 readline-5.1.tar.gz 2030276
+MD5 63faf622820ca0828131c8b5aeac1e6a readline51-001 2042
+RMD160 93dd36106f68682c4dc73a9b1ecf62bf7943fae4 readline51-001 2042
+SHA256 2c9786b231a454504c3f38361af6fd74e61789bc1009eba5fb2447b5a3ac5774 readline51-001 2042
+MD5 e60f96f9277f42aa2e66020b2f30e55f readline51-002 1149
+RMD160 3eb4a80089d23f05d76f702952f0dbb7ef3ba24d readline51-002 1149
+SHA256 61b560d4a8e5e3b99a2911a46c0d4c4916f5d0ff61723b21c64cc7c0d59dfd35 readline51-002 1149
diff --git a/sys-libs/readline/readline-5.1_p2.ebuild b/sys-libs/readline/readline-5.1_p2.ebuild
new file mode 100644
index 000000000000..ee9d80713185
--- /dev/null
+++ b/sys-libs/readline/readline-5.1_p2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.1_p2.ebuild,v 1.1 2006/02/04 20:06:39 vapier Exp $
+
+inherit eutils multilib toolchain-funcs
+
+# Official patches
+# See ftp://ftp.cwru.edu/pub/bash/readline-5.1-patches/
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Another cute console display library"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+SRC_URI="mirror://gnu/readline/${MY_P}.tar.gz
+ $(for ((i=1; i<=PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ done)"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# We must be certain that we have a bash that is linked
+# to its internal readline, else we may get problems.
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-2.05b-r2"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd "${S}"
+ # Official patches
+ local i
+ for ((i=1; i<=PLEVEL; i++)); do
+ epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
+ done
+ epatch "${FILESDIR}"/bash-3.0-etc-inputrc.patch
+ epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
+ epatch "${FILESDIR}"/${MY_P}-cleanups.patch
+ epatch "${FILESDIR}"/${MY_P}-rlfe-build.patch #116483
+ epatch "${FILESDIR}"/${MY_P}-rlfe-uclibc.patch
+ epatch "${FILESDIR}"/${MY_P}-rlfe-libutil.patch
+
+ ln -s ../.. examples/rlfe/readline
+
+ # force ncurses linking #71420
+ sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
+}
+
+src_compile() {
+ # the --libdir= is needed because if lib64 is a directory, it will default
+ # to using that... even if CONF_LIBDIR isnt set or we're using a version
+ # of portage without CONF_LIBDIR support.
+ econf --with-curses --libdir=/usr/$(get_libdir) || die
+ emake || die
+
+ if ! tc-is-cross-compiler; then
+ cd examples/rlfe
+ econf || die
+ emake || die "make rlfe failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodir /$(get_libdir)
+
+ if ! use userland_Darwin ; then
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ chmod a+rx "${D}"/$(get_libdir)/*.so*
+
+ # Bug #4411
+ gen_usr_ldscript libreadline.so
+ gen_usr_ldscript libhistory.so
+ fi
+
+ if ! tc-is-cross-compiler; then
+ dobin examples/rlfe/rlfe || die
+ fi
+
+ dodoc CHANGELOG CHANGES README USAGE NEWS
+ docinto ps
+ dodoc doc/*.ps
+ dohtml -r doc
+}
+
+pkg_preinst() {
+ # Backwards compatibility #29865
+ if [[ -e ${ROOT}/$(get_libdir)/libreadline.so.4 ]] ; then
+ cp -pPR "${ROOT}"/$(get_libdir)/libreadline.so.4* "${D}"/$(get_libdir)/
+ touch "${D}"/$(get_libdir)/libreadline.so.4*
+ fi
+}
+
+pkg_postinst() {
+ if [[ -e ${ROOT}/$(get_libdir)/libreadline.so.4 ]] ; then
+ ewarn "Your old readline libraries have been copied over."
+ ewarn "You should run 'revdep-rebuild --library libreadline.so.4' asap."
+ ewarn "Once you have, you can safely delete /$(get_libdir)/libreadline.so.4*"
+ fi
+}