summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-15 12:05:12 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-15 12:05:12 +0000
commit18277891e5e78005494836fc0ae503a6b6fd033f (patch)
tree77956eabb9c9eda444d375af732af15e3ebc3dd9 /sys-libs
parentVersion bump. (diff)
downloadgentoo-2-18277891e5e78005494836fc0ae503a6b6fd033f.tar.gz
gentoo-2-18277891e5e78005494836fc0ae503a6b6fd033f.tar.bz2
gentoo-2-18277891e5e78005494836fc0ae503a6b6fd033f.zip
Version bump.
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libosinfo/ChangeLog8
-rw-r--r--sys-libs/libosinfo/libosinfo-0.2.0.ebuild57
2 files changed, 63 insertions, 2 deletions
diff --git a/sys-libs/libosinfo/ChangeLog b/sys-libs/libosinfo/ChangeLog
index 5814b7107fe2..56bf7306e561 100644
--- a/sys-libs/libosinfo/ChangeLog
+++ b/sys-libs/libosinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libosinfo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/ChangeLog,v 1.10 2012/08/14 09:25:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/ChangeLog,v 1.11 2012/09/15 12:05:12 pacho Exp $
+
+*libosinfo-0.2.0 (15 Sep 2012)
+
+ 15 Sep 2012; Pacho Ramos <pacho@gentoo.org> +libosinfo-0.2.0.ebuild:
+ Version bump.
14 Aug 2012; Samuli Suominen <ssuominen@gentoo.org> libosinfo-0.1.2.ebuild:
Use temporary PN_VALA_SLOT variable to avoid duplicating the version twice.
@@ -52,4 +57,3 @@
16 Nov 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +libosinfo-0.0.1.ebuild,
+metadata.xml:
Add new package libosinfo, will be used by gnome-boxes
-
diff --git a/sys-libs/libosinfo/libosinfo-0.2.0.ebuild b/sys-libs/libosinfo/libosinfo-0.2.0.ebuild
new file mode 100644
index 000000000000..21bc25f0d9a3
--- /dev/null
+++ b/sys-libs/libosinfo/libosinfo-0.2.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/libosinfo-0.2.0.ebuild,v 1.1 2012/09/15 12:05:12 pacho Exp $
+
+EAPI=4
+VALA_MIN_API_VERSION="0.16"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils toolchain-funcs vala
+
+DESCRIPTION="GObject library for managing information about real and virtual OSes"
+HOMEPAGE="http://fedorahosted.org/libosinfo/"
+SRC_URI="http://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection +vala test"
+
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/libxslt-1.0.0
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ net-libs/libsoup-gnome:2.4
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ test? ( dev-libs/check )
+ vala? ( $(vala_depend) )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ local udevdir=/lib/udev
+ has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+
+ # --enable-udev is only for rules.d file install
+ econf \
+ --disable-static \
+ --disable-silent-rules \
+ $(use_enable doc gtk-doc) \
+ $(use_enable test tests) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ --enable-udev \
+ --disable-coverage \
+ --with-udev-rulesdir="${udevdir}"/rules.d \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}