summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-06-29 01:18:43 +0000
committerMike Gilbert <floppym@gentoo.org>2015-06-29 01:18:43 +0000
commit1f18562b54dcdda99b2d535a8e62aaeddf61cd65 (patch)
treee509d6964c1af345e5b1d31924a05d46d8f6c35e /sys-libs
parentUse qmake-utils helper functions to simplify src_configure. Remove double cal... (diff)
downloadgentoo-2-1f18562b54dcdda99b2d535a8e62aaeddf61cd65.tar.gz
gentoo-2-1f18562b54dcdda99b2d535a8e62aaeddf61cd65.tar.bz2
gentoo-2-1f18562b54dcdda99b2d535a8e62aaeddf61cd65.zip
Version bump, bug 553220.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/efivar/ChangeLog7
-rw-r--r--sys-libs/efivar/efivar-0.20.ebuild23
2 files changed, 29 insertions, 1 deletions
diff --git a/sys-libs/efivar/ChangeLog b/sys-libs/efivar/ChangeLog
index 98bec5c60823..af26c6351232 100644
--- a/sys-libs/efivar/ChangeLog
+++ b/sys-libs/efivar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/efivar
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/efivar/ChangeLog,v 1.6 2015/06/25 14:04:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/efivar/ChangeLog,v 1.7 2015/06/29 01:18:43 floppym Exp $
+
+*efivar-0.20 (29 Jun 2015)
+
+ 29 Jun 2015; Mike Gilbert <floppym@gentoo.org> +efivar-0.20.ebuild:
+ Version bump, bug 553220.
25 Jun 2015; Mike Gilbert <floppym@gentoo.org> efivar-0.15.ebuild:
Update HOMEPAGE and SRC_URI.
diff --git a/sys-libs/efivar/efivar-0.20.ebuild b/sys-libs/efivar/efivar-0.20.ebuild
new file mode 100644
index 000000000000..013189049bef
--- /dev/null
+++ b/sys-libs/efivar/efivar-0.20.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/efivar/efivar-0.20.ebuild,v 1.1 2015/06/29 01:18:43 floppym Exp $
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Tools and library to manipulate EFI variables"
+HOMEPAGE="https://github.com/rhinstaller/efivar"
+SRC_URI="https://github.com/rhinstaller/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ tc-export CC
+ export libdir="/usr/$(get_libdir)"
+}