summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-27 14:11:21 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-27 14:11:21 +0000
commit3565f51b50f0e1f8a12de1b559e9cbfb8bdcd4e8 (patch)
treee1c28c1f1a450e59f792e8440955f1f4e4bb43f1 /sys-libs
parentPatched po/Makefile.inin to work with DESTDIR (diff)
downloadgentoo-2-3565f51b50f0e1f8a12de1b559e9cbfb8bdcd4e8.tar.gz
gentoo-2-3565f51b50f0e1f8a12de1b559e9cbfb8bdcd4e8.tar.bz2
gentoo-2-3565f51b50f0e1f8a12de1b559e9cbfb8bdcd4e8.zip
Now uses his own patched Makefiles instead of pathcing redhat's patch
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/cracklib/cracklib-2.7-r2.ebuild7
-rw-r--r--sys-libs/cracklib/files/cracklib-2.7-gentoo.diff131
-rw-r--r--sys-libs/cracklib/files/cracklib-2.7-redhat.patch127
3 files changed, 135 insertions, 130 deletions
diff --git a/sys-libs/cracklib/cracklib-2.7-r2.ebuild b/sys-libs/cracklib/cracklib-2.7-r2.ebuild
index 35bf9671dd68..30c33c6d1293 100644
--- a/sys-libs/cracklib/cracklib-2.7-r2.ebuild
+++ b/sys-libs/cracklib/cracklib-2.7-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.7-r2.ebuild,v 1.1 2001/02/07 16:10:52 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.7-r2.ebuild,v 1.2 2001/02/27 14:11:21 achim Exp $
A=cracklib2_${PV}.orig.tar.gz
A0=${P}-redhat.patch
@@ -16,13 +16,14 @@ src_unpack() {
unpack ${A}
cd ${S}
patch -p1 <${FILESDIR}/${A0}
+ patch -p1 <${FILESDIR}/${P}-gentoo.diff
}
src_compile() {
# Parallel make does not work for 2.7
- try RPM_OPT_FLAGS=\"${CFLAGS}\" make DICTPATH=\"/usr/share/cracklib/pw_dict\" all
+ try make all
}
@@ -33,7 +34,7 @@ src_install() {
dodir /usr/include
dodir /usr/share/cracklib
- ROOT=${D} try make DICTPATH=\"/usr/share/cracklib/pw_dict\" install
+ try make DESTDIR=${D} install
mv ${D}/usr/lib ${D}
preplib /
diff --git a/sys-libs/cracklib/files/cracklib-2.7-gentoo.diff b/sys-libs/cracklib/files/cracklib-2.7-gentoo.diff
new file mode 100644
index 000000000000..527ea30ac2a7
--- /dev/null
+++ b/sys-libs/cracklib/files/cracklib-2.7-gentoo.diff
@@ -0,0 +1,131 @@
+diff -N -r -U3 cracklib,2.7.orig/Makefile cracklib,2.7/Makefile
+--- cracklib,2.7.orig/Makefile Wed Dec 31 11:33:53 1997
++++ cracklib,2.7/Makefile Tue Feb 27 16:03:32 2001
+@@ -7,14 +7,21 @@
+ ###
+
+ ###
++# cracklib version
++MAJOR=2
++MINOR=7
++VERSION=$(MAJOR).$(MINOR)
++export MAJOR MINOR VERSION
++
++###
+ # set this to the absolute path (less extn) of compressed dict.
+
+-DICTPATH="/usr/local/lib/pw_dict"
++DICTPATH="/usr/share/cracklib/pw_dict"
+
+ ###
+ # Set this to the path of one or more files continaing wordlists.
+
+-SRCDICTS=/usr/dict/words
++SRCDICTS=/usr/dict/words /usr/dict/extra.words
+
+ ###
+ # If you have installed the cracklib-dicts directory, use this
+@@ -36,7 +43,9 @@
+ -rm -f all installed Part* *.BAK *.bak *~
+
+ install: all
++ ( cd cracklib && make install && exit $$? )
++ ( cd util && make install && exit $$? )
+ @echo 'if "sort" dies from lack of space, see "util/mkdict"'
+- util/mkdict $(SRCDICTS) | util/packer $(DICTPATH)
++ util/mkdict $(SRCDICTS) | LD_LIBRARY_PATH=cracklib util/packer $(DESTDIR)$(DICTPATH)
+ touch installed
+ ### @echo 'now go install passwd/passwd where you want it'
+diff -N -r -U3 cracklib,2.7.orig/cracklib/Makefile cracklib,2.7/cracklib/Makefile
+--- cracklib,2.7.orig/cracklib/Makefile Sun Dec 14 23:49:21 1997
++++ cracklib,2.7/cracklib/Makefile Tue Feb 27 16:03:39 2001
+@@ -6,13 +6,21 @@
+ # and upwards.
+ ###
+
+-LIB= libcrack.a
+-OBJ= fascist.o packlib.o rules.o stringlib.o
+-CFLAGS= -O -I../cracklib -DIN_CRACKLIB
++LIB = libcrack.so
++OBJ = fascist.o packlib.o rules.o stringlib.o
++CFLAGS += -g -I../cracklib -DIN_CRACKLIB -fPIC
++LD = ld
+
+-$(LIB): $(OBJ)
+- ar rv $(LIB) $?
+- -ranlib $(LIB)
++$(LIB): $(OBJ) Makefile
++ $(LD) -shared -soname $(LIB).$(MAJOR) -o $(LIB).$(VERSION) $(OBJ) -lc
++ rm -f $(LIB).$(MAJOR) $(LIB)
++ ln -s $(LIB).$(VERSION) $(LIB).$(MAJOR)
++ ln -s $(LIB).$(MAJOR) $(LIB)
+
+ clean:
+- -rm -f $(OBJ) $(LIB) *~
++ -rm -f $(OBJ) $(LIB) $(LIB).$(VERSION) *~
++
++install: $(LIB) crack.h
++ install -m 755 $(LIB).$(VERSION) $(DESTDIR)/usr/lib
++ ln -sf $(LIB).$(VERSION) $(DESTDIR)/usr/lib/$(LIB)
++ install -m 644 crack.h $(DESTDIR)/usr/include
+diff -N -r -U3 cracklib,2.7.orig/util/Makefile cracklib,2.7/util/Makefile
+--- cracklib,2.7.orig/util/Makefile Sun Dec 14 23:49:34 1997
++++ cracklib,2.7/util/Makefile Tue Feb 27 16:03:46 2001
+@@ -14,27 +14,31 @@
+ #SunOS users (and others?) should consider static linking of their passwd binary
+ #CFLAGS= -O -I../cracklib '-DCRACKLIB_DICTPATH="$(DICTPATH)"' -Bstatic
+
+-CFLAGS= -O -I../cracklib '-DCRACKLIB_DICTPATH="$(DICTPATH)"'
+-LIBS= ../cracklib/libcrack.a
++CFLAGS += -I../cracklib '-DCRACKLIB_DICTPATH="$(DICTPATH)"'
++LDFLAGS = -L../cracklib -lcrack
++LIBS = ../cracklib/libcrack.so
+
+ all: packer unpacker testnum teststr testlib
+ touch all
+
+ packer: packer.o $(LIBS)
+- cc $(CFLAGS) -o $@ $@.o $(LIBS)
++ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
+
+ unpacker: unpacker.o $(LIBS)
+- cc $(CFLAGS) -o $@ $@.o $(LIBS)
++ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
+
+ testnum: testnum.o $(LIBS)
+- cc $(CFLAGS) -o $@ $@.o $(LIBS)
++ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
+
+ teststr: teststr.o $(LIBS)
+- cc $(CFLAGS) -o $@ $@.o $(LIBS)
++ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
+
+ testlib: testlib.o $(LIBS)
+- cc $(CFLAGS) -o $@ $@.o $(LIBS)
++ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
+
+ clean:
+ -rm *.o *~ all
+ -rm teststr testnum testlib packer unpacker
++
++install: all create-cracklib-dict
++ install -m 755 mkdict packer create-cracklib-dict $(DESTDIR)/usr/sbin
+diff -N -r -U3 cracklib,2.7.orig/util/create-cracklib-dict cracklib,2.7/util/create-cracklib-dict
+--- cracklib,2.7.orig/util/create-cracklib-dict Thu Jan 1 01:00:00 1970
++++ cracklib,2.7/util/create-cracklib-dict Tue Feb 27 16:03:51 2001
+@@ -0,0 +1,15 @@
++#!/bin/sh
++if [ -z "$*" ]; then
++ echo "Usage:"
++ echo " /usr/sbin/create-cracklib-dict wordlist ..."
++ echo
++ echo "This script takes one or more word list files as arguments"
++ echo "and converts them into cracklib dictionaries for use"
++ echo "by password checking programs. The results are placed in"
++ echo "/usr/lib/cracklib_dict.*"
++ echo
++ echo "Example:"
++ echo "/usr/sbin/create-cracklib-dict /usr/dict/words"
++else
++ /usr/sbin/mkdict $* | /usr/sbin/packer /usr/share/cracklib/pw_dict
++fi
diff --git a/sys-libs/cracklib/files/cracklib-2.7-redhat.patch b/sys-libs/cracklib/files/cracklib-2.7-redhat.patch
index 7720c485dc91..415df9d16ae5 100644
--- a/sys-libs/cracklib/files/cracklib-2.7-redhat.patch
+++ b/sys-libs/cracklib/files/cracklib-2.7-redhat.patch
@@ -26,37 +26,6 @@
for (i = 0; r_destructors[i]; i++)
{
---- cracklib,2.7/cracklib/Makefile.rh Sun Dec 14 17:49:21 1997
-+++ cracklib,2.7/cracklib/Makefile Tue Mar 10 18:54:11 1998
-@@ -6,13 +6,21 @@
- # and upwards.
- ###
-
--LIB= libcrack.a
--OBJ= fascist.o packlib.o rules.o stringlib.o
--CFLAGS= -O -I../cracklib -DIN_CRACKLIB
-+LIB = libcrack.so
-+OBJ = fascist.o packlib.o rules.o stringlib.o
-+CFLAGS = $(RPM_OPT_FLAGS) -g -I../cracklib -DIN_CRACKLIB -fPIC
-+LD = ld
-
--$(LIB): $(OBJ)
-- ar rv $(LIB) $?
-- -ranlib $(LIB)
-+$(LIB): $(OBJ) Makefile
-+ $(LD) -shared -soname $(LIB).$(MAJOR) -o $(LIB).$(VERSION) $(OBJ) -lc
-+ rm -f $(LIB).$(MAJOR) $(LIB)
-+ ln -s $(LIB).$(VERSION) $(LIB).$(MAJOR)
-+ ln -s $(LIB).$(MAJOR) $(LIB)
-
- clean:
-- -rm -f $(OBJ) $(LIB) *~
-+ -rm -f $(OBJ) $(LIB) $(LIB).$(VERSION) *~
-+
-+install: $(LIB) crack.h
-+ install -m 755 $(LIB).$(VERSION) $(ROOT)/usr/lib
-+ ln -sf $(LIB).$(VERSION) $(ROOT)/usr/lib/$(LIB)
-+ install -m 644 crack.h $(ROOT)/usr/include
--- cracklib,2.7/cracklib/crack.h.rh Tue Mar 10 18:17:43 1998
+++ cracklib,2.7/cracklib/crack.h Tue Mar 10 18:17:43 1998
@@ -0,0 +1,15 @@
@@ -75,99 +44,3 @@
+extern char *FascistCheck(char *pw, char *dictpath);
+
+#endif
---- cracklib,2.7/util/Makefile.rh Sun Dec 14 17:49:34 1997
-+++ cracklib,2.7/util/Makefile Tue Mar 10 18:17:43 1998
-@@ -14,27 +14,31 @@
- #SunOS users (and others?) should consider static linking of their passwd binary
- #CFLAGS= -O -I../cracklib '-DCRACKLIB_DICTPATH="$(DICTPATH)"' -Bstatic
-
--CFLAGS= -O -I../cracklib '-DCRACKLIB_DICTPATH="$(DICTPATH)"'
--LIBS= ../cracklib/libcrack.a
-+CFLAGS = $(RPM_OPT_FLAGS) -I../cracklib '-DCRACKLIB_DICTPATH="$(DICTPATH)"'
-+LDFLAGS = -L../cracklib -lcrack
-+LIBS = ../cracklib/libcrack.so
-
- all: packer unpacker testnum teststr testlib
- touch all
-
- packer: packer.o $(LIBS)
-- cc $(CFLAGS) -o $@ $@.o $(LIBS)
-+ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
-
- unpacker: unpacker.o $(LIBS)
-- cc $(CFLAGS) -o $@ $@.o $(LIBS)
-+ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
-
- testnum: testnum.o $(LIBS)
-- cc $(CFLAGS) -o $@ $@.o $(LIBS)
-+ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
-
- teststr: teststr.o $(LIBS)
-- cc $(CFLAGS) -o $@ $@.o $(LIBS)
-+ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
-
- testlib: testlib.o $(LIBS)
-- cc $(CFLAGS) -o $@ $@.o $(LIBS)
-+ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
-
- clean:
- -rm *.o *~ all
- -rm teststr testnum testlib packer unpacker
-+
-+install: all create-cracklib-dict
-+ install -m 755 mkdict packer create-cracklib-dict $(ROOT)/usr/sbin
---- cracklib,2.7/util/create-cracklib-dict.rh Tue Mar 10 18:17:43 1998
-+++ cracklib,2.7/util/create-cracklib-dict Tue Mar 10 18:17:43 1998
-@@ -0,0 +1,15 @@
-+#!/bin/sh
-+if [ -z "$*" ]; then
-+ echo "Usage:"
-+ echo " /usr/sbin/create-cracklib-dict wordlist ..."
-+ echo
-+ echo "This script takes one or more word list files as arguments"
-+ echo "and converts them into cracklib dictionaries for use"
-+ echo "by password checking programs. The results are placed in"
-+ echo "/usr/lib/cracklib_dict.*"
-+ echo
-+ echo "Example:"
-+ echo "/usr/sbin/create-cracklib-dict /usr/dict/words"
-+else
-+ /usr/sbin/mkdict $* | /usr/sbin/packer /usr/lib/cracklib_dict
-+fi
---- cracklib,2.7/Makefile.rh Wed Dec 31 05:33:53 1997
-+++ cracklib,2.7/Makefile Tue Mar 10 18:52:47 1998
-@@ -7,14 +7,21 @@
- ###
-
- ###
-+# cracklib version
-+MAJOR=2
-+MINOR=7
-+VERSION=$(MAJOR).$(MINOR)
-+export MAJOR MINOR VERSION
-+
-+###
- # set this to the absolute path (less extn) of compressed dict.
-
--DICTPATH="/usr/local/lib/pw_dict"
-+DICTPATH="/usr/lib/cracklib_dict"
-
- ###
- # Set this to the path of one or more files continaing wordlists.
-
--SRCDICTS=/usr/dict/words
-+SRCDICTS=/usr/dict/words /usr/dict/extra.words
-
- ###
- # If you have installed the cracklib-dicts directory, use this
-@@ -36,7 +43,9 @@
- -rm -f all installed Part* *.BAK *.bak *~
-
- install: all
-+ ( cd cracklib && make install && exit $$? )
-+ ( cd util && make install && exit $$? )
- @echo 'if "sort" dies from lack of space, see "util/mkdict"'
-- util/mkdict $(SRCDICTS) | util/packer $(DICTPATH)
-+ util/mkdict $(SRCDICTS) | LD_LIBRARY_PATH=cracklib util/packer $(ROOT)$(DICTPATH)
- touch installed
- ### @echo 'now go install passwd/passwd where you want it'