summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-25 17:19:56 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-25 17:19:56 +0000
commit61fc7c744b6549590cf06f1f741ace416b7f952b (patch)
treedeee2e8172bc0b31b7bcfc6dbd44e1ad404ae393 /sys-libs
parentadded ~arm tested by me (diff)
downloadgentoo-2-61fc7c744b6549590cf06f1f741ace416b7f952b.tar.gz
gentoo-2-61fc7c744b6549590cf06f1f741ace416b7f952b.tar.bz2
gentoo-2-61fc7c744b6549590cf06f1f741ace416b7f952b.zip
Add USE=libatomic to control dependency #453704 by Jeroen Roovers.
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libunwind/ChangeLog8
-rw-r--r--sys-libs/libunwind/libunwind-1.1.ebuild13
-rw-r--r--sys-libs/libunwind/metadata.xml1
3 files changed, 16 insertions, 6 deletions
diff --git a/sys-libs/libunwind/ChangeLog b/sys-libs/libunwind/ChangeLog
index 188e2d022e0c..13734882e294 100644
--- a/sys-libs/libunwind/ChangeLog
+++ b/sys-libs/libunwind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libunwind
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/ChangeLog,v 1.30 2012/12/19 17:32:09 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/ChangeLog,v 1.31 2013/01/25 17:19:56 vapier Exp $
+
+ 25 Jan 2013; Mike Frysinger <vapier@gentoo.org> libunwind-1.1.ebuild,
+ metadata.xml:
+ Add USE=libatomic to control dependency #453704 by Jeroen Roovers.
19 Dec 2012; Sébastien Fabbro <bicatali@gentoo.org> libunwind-1.1.ebuild:
Keyword amd64-linux and x86-linux
diff --git a/sys-libs/libunwind/libunwind-1.1.ebuild b/sys-libs/libunwind/libunwind-1.1.ebuild
index ddbea4094c55..cbc8e42bc7e6 100644
--- a/sys-libs/libunwind/libunwind-1.1.ebuild
+++ b/sys-libs/libunwind/libunwind-1.1.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/libunwind-1.1.ebuild,v 1.4 2012/12/19 17:32:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/libunwind-1.1.ebuild,v 1.5 2013/01/25 17:19:56 vapier Exp $
EAPI="4"
+inherit eutils
+
DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
HOMEPAGE="http://savannah.nongnu.org/projects/libunwind"
SRC_URI="http://download.savannah.nongnu.org/releases/libunwind/${P}.tar.gz"
@@ -11,10 +13,12 @@ SRC_URI="http://download.savannah.nongnu.org/releases/libunwind/${P}.tar.gz"
LICENSE="MIT"
SLOT="7"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-fbsd ~x86-linux"
-IUSE="debug debug-frame lzma static-libs"
+IUSE="debug debug-frame libatomic lzma static-libs"
+# We just use the header from libatomic.
RDEPEND="lzma? ( app-arch/xz-utils )"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ libatomic? ( dev-libs/libatomic_ops )"
DOCS=( AUTHORS ChangeLog NEWS README TODO )
@@ -36,6 +40,7 @@ src_configure() {
# conservative-checks: validate memory addresses before use; as of 1.0.1,
# only x86_64 supports this, yet may be useful for debugging, couple it with
# debug useflag.
+ ac_cv_header_atomic_ops_h=$(usex libatomic) \
econf \
--enable-cxx-exceptions \
$(use_enable debug-frame) \
diff --git a/sys-libs/libunwind/metadata.xml b/sys-libs/libunwind/metadata.xml
index 4878bd084d1f..808179f059c8 100644
--- a/sys-libs/libunwind/metadata.xml
+++ b/sys-libs/libunwind/metadata.xml
@@ -4,5 +4,6 @@
<herd>toolchain</herd>
<use>
<flag name='debug-frame'>Adds support for DWARF .debug_frame section: Use the information from this section if available</flag>
+ <flag name='libatomic'>Use libatomic instead of builtin atomic operations</flag>
</use>
</pkgmetadata>