summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-05-05 12:28:53 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-05-05 12:28:53 +0000
commit93ea9dc3df601142ef671e03cc39ce9c73286d74 (patch)
tree05f44879079f44e9dc6ddd28d8ef0ece7bd8090c /sys-libs
parentUpdate SRC_URI for patches. (diff)
downloadgentoo-2-93ea9dc3df601142ef671e03cc39ce9c73286d74.tar.gz
gentoo-2-93ea9dc3df601142ef671e03cc39ce9c73286d74.tar.bz2
gentoo-2-93ea9dc3df601142ef671e03cc39ce9c73286d74.zip
Do not strip ld.so to enable setting breakpoints in shared libraries (Fix by
Lonnie Princehouse). (Portage version: 2.0.51.21)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.3.5.20050421.ebuild29
3 files changed, 24 insertions, 17 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 51350bc7bf2e..f54307494f81 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.344 2005/05/03 05:12:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.345 2005/05/05 12:28:53 azarah Exp $
+
+ 05 May 2005; Martin Schlemmer <azarah@gentoo.org>
+ glibc-2.3.4.20050125-r1.ebuild, glibc-2.3.5.20050421.ebuild:
+ Do not strip ld.so to enable setting breakpoints in shared libraries (Fix by
+ Lonnie Princehouse).
03 May 2005; Mike Frysinger <vapier@gentoo.org>
glibc-2.3.4.20041102-r1.ebuild, glibc-2.3.4.20050125-r1.ebuild,
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index e004ac15acd4..b9671602f888 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.44 2005/05/03 05:12:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.45 2005/05/05 12:28:53 azarah Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -387,6 +387,9 @@ toolchain-glibc_src_install() {
# now, strip everything but the thread libs #46186
mkdir -p ${T}/thread-backup
mv -f ${D}$(alt_libdir)/lib{pthread,thread_db}* ${T}/thread-backup/
+ # Also, don't strip the dynamic linker, else we cannot set breakpoints
+ # in shared libraries. Fix by Lonnie Princehouse.
+ mv -f ${D}/$(get_libdir)/ld-* ${T}/thread-backup/
if want_linuxthreads && want_nptl ; then
mkdir -p ${T}/thread-backup/tls
mv -f ${D}$(alt_libdir)/tls/lib{pthread,thread_db}* ${T}/thread-backup/tls
diff --git a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
index 3b142962e46a..179d5ddc773d 100644
--- a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.6 2005/05/03 05:12:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.7 2005/05/05 12:28:53 azarah Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -187,25 +187,16 @@ toolchain-glibc_src_unpack() {
unpack ${PN}-${PATCH_GLIBC_VER:-${GLIBC_RELEASE_VER}}-patches-${PATCH_VER}.tar.bz2
fi
- if [[ ${GLIBC_MANPAGE_VERSION} != "none" ]] ; then
- cd ${WORKDIR}
- unpack ${PN}-manpages-${GLIBC_MANPAGE_VERSION:-${GLIBC_RELEASE_VER}}.tar.bz2
- fi
-
-# FIXME: I updated the infopages, but forgot to regen th branch-update
-# if [[ ${GLIBC_INFOPAGE_VERSION} != "none" ]] ; then
-# cd ${S}
-# unpack ${PN}-infopages-${GLIBC_INFOPAGE_VERSION:-${GLIBC_RELEASE_VER}}.tar.bz2
-# fi
-
+ # XXX: We should do the branchupdate, before extracting the manpages and
+ # infopages else it does not help much (mtimes change if there is a change
+ # to them with branchupdate)
if [[ -n ${BRANCH_UPDATE} ]] ; then
cd ${WORKDIR}
unpack ${PN}-${GLIBC_RELEASE_VER}-branch-update-${BRANCH_UPDATE}.patch.bz2
fi
- cd ${S}
-
if [[ -n ${BRANCH_UPDATE} ]] ; then
+ cd ${S}
epatch ${WORKDIR}/${PN}-${GLIBC_RELEASE_VER}-branch-update-${BRANCH_UPDATE}.patch
# Snapshot date patch
@@ -213,7 +204,11 @@ toolchain-glibc_src_unpack() {
sed -i -e "s:\(#define RELEASE\).*:\1 \"${BRANCH_UPDATE}\":" version.h
fi
-# FIXME: I updated the infopages, but forgot to regen th branch-update
+ if [[ ${GLIBC_MANPAGE_VERSION} != "none" ]] ; then
+ cd ${WORKDIR}
+ unpack ${PN}-manpages-${GLIBC_MANPAGE_VERSION:-${GLIBC_RELEASE_VER}}.tar.bz2
+ fi
+
if [[ ${GLIBC_INFOPAGE_VERSION} != "none" ]] ; then
cd ${S}
unpack ${PN}-infopages-${GLIBC_INFOPAGE_VERSION:-${GLIBC_RELEASE_VER}}.tar.bz2
@@ -225,6 +220,7 @@ toolchain-glibc_src_unpack() {
OLD_ARCH="${ARCH}"
ARCH="$(tc-arch)"
+ cd ${S}
einfo "Applying Gentoo Glibc Patches: ${PATCH_GLIBC_VER:-${GLIBC_RELEASE_VER}}-${PATCH_VER}"
epatch ${WORKDIR}/patches
@@ -399,6 +395,9 @@ toolchain-glibc_src_install() {
# now, strip everything but the thread libs #46186
mkdir -p ${T}/thread-backup
mv -f ${D}$(alt_libdir)/lib{pthread,thread_db}* ${T}/thread-backup/
+ # Also, don't strip the dynamic linker, else we cannot set breakpoints
+ # in shared libraries. Fix by Lonnie Princehouse.
+ mv -f ${D}/$(get_libdir)/ld-* ${T}/thread-backup/
if want_linuxthreads && want_nptl ; then
mkdir -p ${T}/thread-backup/tls
mv -f ${D}$(alt_libdir)/tls/lib{pthread,thread_db}* ${T}/thread-backup/tls