summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-27 04:48:18 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-27 04:48:18 +0000
commita52f4721f6fab95a158e8003a8afb4f98ed8020d (patch)
tree7915ca32a840e5882b76b536905c3c0c43fcaffb /sys-libs
parentAdded ~sparc keyword to resolve bug #48564. (Manifest recommit) (diff)
downloadgentoo-2-a52f4721f6fab95a158e8003a8afb4f98ed8020d.tar.gz
gentoo-2-a52f4721f6fab95a158e8003a8afb4f98ed8020d.tar.bz2
gentoo-2-a52f4721f6fab95a158e8003a8afb4f98ed8020d.zip
few more arm patches
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog10
-rw-r--r--sys-libs/glibc/files/2.3.2/glibc-2.3.2-arm-bus-defines.patch11
-rw-r--r--sys-libs/glibc/files/2.3.2/glibc-2.3.2-arm-doargs.patch17
-rw-r--r--sys-libs/glibc/files/2.3.2/glibc-2.3.2-armformat.patch11
-rw-r--r--sys-libs/glibc/files/2.3.2/glibc-2.3.2-framestate-USING_SJLJ_EXCEPTIONS.patch (renamed from sys-libs/glibc/files/glibc-framestate-USING_SJLJ_EXCEPTIONS.patch)0
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r10.ebuild16
6 files changed, 59 insertions, 6 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 688a384846f0..4a0b761d6730 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.144 2004/04/25 21:50:06 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.145 2004/04/27 04:48:18 vapier Exp $
+
+ 27 Apr 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/2.3.2/glibc-2.3.2-arm-bus-defines.patch,
+ +files/2.3.2/glibc-2.3.2-armformat.patch,
+ +files/2.3.2/glibc-2.3.2-arm-doargs.patch,
+ +files/2.3.2/glibc-2.3.2-framestate-USING_SJLJ_EXCEPTIONS.patch,
+ glibc-2.3.2-r10.ebuild:
+ Add a few patches to make glibc compile cleanly on arm.
*glibc-2.3.3_pre20040420 (25 Apr 2004)
diff --git a/sys-libs/glibc/files/2.3.2/glibc-2.3.2-arm-bus-defines.patch b/sys-libs/glibc/files/2.3.2/glibc-2.3.2-arm-bus-defines.patch
new file mode 100644
index 000000000000..f1f20224916f
--- /dev/null
+++ b/sys-libs/glibc/files/2.3.2/glibc-2.3.2-arm-bus-defines.patch
@@ -0,0 +1,11 @@
+--- sysdeps/unix/sysv/linux/arm/ioperm.c.orig Tue Apr 27 00:30:01 2004
++++ sysdeps/unix/sysv/linux/arm/ioperm.c Tue Apr 27 00:29:57 2004
+@@ -41,6 +41,8 @@
+ #include <string.h>
+ #include <unistd.h>
+
++#include <linux/input.h>
++
+ #include <sys/types.h>
+ #include <sys/mman.h>
+
diff --git a/sys-libs/glibc/files/2.3.2/glibc-2.3.2-arm-doargs.patch b/sys-libs/glibc/files/2.3.2/glibc-2.3.2-arm-doargs.patch
new file mode 100644
index 000000000000..a06336ff88a0
--- /dev/null
+++ b/sys-libs/glibc/files/2.3.2/glibc-2.3.2-arm-doargs.patch
@@ -0,0 +1,17 @@
+--- linuxthreads/sysdeps/unix/sysv/linux/arm/sysdep-cancel.h.orig 2003-05-27 20:25:22.000000000 -0400
++++ linuxthreads/sysdeps/unix/sysv/linux/arm/sysdep-cancel.h 2003-05-27 20:07:12.000000000 -0400
+@@ -26,12 +26,14 @@
+
+ /* We push lr onto the stack, so we have to use ldmib instead of ldmia
+ to find the saved arguments. */
++#ifdef PIC
+ #undef DOARGS_5
+ #undef DOARGS_6
+ #undef DOARGS_7
+ #define DOARGS_5 str r4, [sp, $-4]!; ldr r4, [sp, $8];
+ #define DOARGS_6 mov ip, sp; stmfd sp!, {r4, r5}; ldmib ip, {r4, r5};
+ #define DOARGS_7 mov ip, sp; stmfd sp!, {r4, r5, r6}; ldmib ip, {r4, r5, r6};
++#endif /* PIC */
+
+ # undef PSEUDO_RET
+ # define PSEUDO_RET \
diff --git a/sys-libs/glibc/files/2.3.2/glibc-2.3.2-armformat.patch b/sys-libs/glibc/files/2.3.2/glibc-2.3.2-armformat.patch
new file mode 100644
index 000000000000..a3d51c654f4d
--- /dev/null
+++ b/sys-libs/glibc/files/2.3.2/glibc-2.3.2-armformat.patch
@@ -0,0 +1,11 @@
+--- glibc-2.3.2-200304020432/scripts/output-format.sed.armformat 2003-07-19 09:47:39.000000000 -0400
++++ glibc-2.3.2-200304020432/scripts/output-format.sed 2003-07-19 09:48:00.000000000 -0400
+@@ -5,7 +5,7 @@
+ }
+ t o
+ : o
+-s/^.*OUTPUT_FORMAT(\([^,]*\), \1, \1).*$/OUTPUT_FORMAT(\1)/
++s/^.*OUTPUT_FORMAT(\([^,]*\), .*, \1).*$/OUTPUT_FORMAT(\1)/
+ t q
+ s/^.*OUTPUT_FORMAT(\([^,]*\), \([^,]*\), \([^,]*\)).*$/\2,\3/
+ t s
diff --git a/sys-libs/glibc/files/glibc-framestate-USING_SJLJ_EXCEPTIONS.patch b/sys-libs/glibc/files/2.3.2/glibc-2.3.2-framestate-USING_SJLJ_EXCEPTIONS.patch
index 0c42b15c1777..0c42b15c1777 100644
--- a/sys-libs/glibc/files/glibc-framestate-USING_SJLJ_EXCEPTIONS.patch
+++ b/sys-libs/glibc/files/2.3.2/glibc-2.3.2-framestate-USING_SJLJ_EXCEPTIONS.patch
diff --git a/sys-libs/glibc/glibc-2.3.2-r10.ebuild b/sys-libs/glibc/glibc-2.3.2-r10.ebuild
index 57d8053b6d69..693933b8b4c2 100644
--- a/sys-libs/glibc/glibc-2.3.2-r10.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r10.ebuild,v 1.9 2004/04/27 03:17:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r10.ebuild,v 1.10 2004/04/27 04:46:58 vapier Exp $
IUSE="nls pic build nptl"
@@ -412,10 +412,16 @@ src_unpack() {
if [ "${ARCH}" == "arm" ]
then
- # sjlj exceptions can cause issues with undefined frame variables.
- # this patch has been ported from current glibc cvs.
- cd ${S}/sysdeps/generic
- epatch ${FILESDIR}/glibc-framestate-USING_SJLJ_EXCEPTIONS.patch
+ cd ${S}
+ # sjlj exceptions causes undefined frame variables (ported from cvs)
+ epatch ${FILESDIR}/2.3.2/${P}-framestate-USING_SJLJ_EXCEPTIONS.patch
+ # BUS_ISA is needed in ioperm.c but is defined in linux/input.h
+ epatch ${FILESDIR}/2.3.2/${P}-arm-bus-defines.patch
+ # these patches are taken from netwinder.org glibc rpm
+ # armformat fixes the linker script creation
+ # arm-doargs creates certain defines only when pic is used
+ epatch ${FILESDIR}/2.3.2/${P}-armformat.patch
+ epatch ${FILESDIR}/2.3.2/${P}-arm-doargs.patch
fi
# Fix permissions on some of the scripts