summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-03-13 22:36:15 +0000
committerHanno Böck <hanno@gentoo.org>2005-03-13 22:36:15 +0000
commitbbcc3ae6143cd942c63690c2a715d27b1367aaac (patch)
treebab029503bb5fa3f0298d2cff649138272c61634 /sys-libs
parentbug 70570 (diff)
downloadgentoo-2-bbcc3ae6143cd942c63690c2a715d27b1367aaac.tar.gz
gentoo-2-bbcc3ae6143cd942c63690c2a715d27b1367aaac.tar.bz2
gentoo-2-bbcc3ae6143cd942c63690c2a715d27b1367aaac.zip
gwenhywfar bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-1.9.01
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-1.9.0.ebuild41
3 files changed, 48 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index 4c4307d9ab5c..ecf13649900f 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.9 2005/02/22 17:07:50 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.10 2005/03/13 22:36:15 hanno Exp $
+
+*gwenhywfar-1.9.0 (13 Mar 2005)
+
+ 13 Mar 2005; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-1.9.0.ebuild:
+ Version bump.
22 Feb 2005; Hanno Boeck <hanno@gentoo.org> gwenhywfar-1.7.2.ebuild:
Stable on x86.
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.9.0 b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.9.0
new file mode 100644
index 000000000000..0e26e9d03322
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.9.0
@@ -0,0 +1 @@
+MD5 1d523877b0f30fe19e1cb365267f443d gwenhywfar-1.9.0.tar.gz 1045965
diff --git a/sys-libs/gwenhywfar/gwenhywfar-1.9.0.ebuild b/sys-libs/gwenhywfar/gwenhywfar-1.9.0.ebuild
new file mode 100644
index 000000000000..4adf11d72ebb
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-1.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-1.9.0.ebuild,v 1.1 2005/03/13 22:36:15 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 ~amd64 ~sparc ~alpha ~ppc"
+
+IUSE="debug ssl doc"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ if use doc; then
+ APIDOC="--with-docpath=/usr/share/doc/${P}/apidoc"
+ fi
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable doc full-doc` \
+ ${APIDOC} || die "configure failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "Building the api-doc failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
+ if use doc; then
+ make DESTDIR=${D} install-srcdoc || die "Installing the API-Doc failed"
+ fi
+}