summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-16 18:30:33 +0000
committerMike Frysinger <vapier@gentoo.org>2008-11-16 18:30:33 +0000
commite5bded0f1c5205e4939ddb74529d26ff81dd9e8d (patch)
treee875cc94a804d59fe0d6bc5eb06c4e1136eade91 /sys-libs
parentlibsidplay: fix gcc43 and repoman/qa-fixes (diff)
downloadgentoo-2-e5bded0f1c5205e4939ddb74529d26ff81dd9e8d.tar.gz
gentoo-2-e5bded0f1c5205e4939ddb74529d26ff81dd9e8d.tar.bz2
gentoo-2-e5bded0f1c5205e4939ddb74529d26ff81dd9e8d.zip
Link python module against python #246747 by Robert Wohlrab.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27.4 x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/cracklib/ChangeLog6
-rw-r--r--sys-libs/cracklib/cracklib-2.8.13.ebuild10
-rw-r--r--sys-libs/cracklib/files/cracklib-2.8.13-python-linkage.patch13
3 files changed, 26 insertions, 3 deletions
diff --git a/sys-libs/cracklib/ChangeLog b/sys-libs/cracklib/ChangeLog
index c2a1b91890f2..ba9edd983670 100644
--- a/sys-libs/cracklib/ChangeLog
+++ b/sys-libs/cracklib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/cracklib
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.121 2008/09/24 04:24:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.122 2008/11/16 18:30:32 vapier Exp $
+
+ 16 Nov 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/cracklib-2.8.13-python-linkage.patch, cracklib-2.8.13.ebuild:
+ Link python module against python #246747 by Robert Wohlrab.
*cracklib-2.8.13 (24 Sep 2008)
diff --git a/sys-libs/cracklib/cracklib-2.8.13.ebuild b/sys-libs/cracklib/cracklib-2.8.13.ebuild
index 783f2a3d137e..3092efc400ea 100644
--- a/sys-libs/cracklib/cracklib-2.8.13.ebuild
+++ b/sys-libs/cracklib/cracklib-2.8.13.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.8.13.ebuild,v 1.1 2008/09/24 04:24:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.8.13.ebuild,v 1.2 2008/11/16 18:30:32 vapier Exp $
-inherit toolchain-funcs multilib
+inherit eutils toolchain-funcs multilib
MY_P=${P/_}
DESCRIPTION="Password Checking Library"
@@ -27,6 +27,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-python-linkage.patch #246747
+}
+
src_compile() {
econf \
--with-default-dict='$(libdir)/cracklib_dict' \
diff --git a/sys-libs/cracklib/files/cracklib-2.8.13-python-linkage.patch b/sys-libs/cracklib/files/cracklib-2.8.13-python-linkage.patch
new file mode 100644
index 000000000000..568d08130263
--- /dev/null
+++ b/sys-libs/cracklib/files/cracklib-2.8.13-python-linkage.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/246747
+
+--- cracklib/python/Makefile.in
++++ cracklib/python/Makefile.in
+@@ -57,7 +57,7 @@
+ am__installdirs = "$(DESTDIR)$(pyexecdir)" "$(DESTDIR)$(pythondir)"
+ pyexecLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(pyexec_LTLIBRARIES)
+-_cracklibmodule_la_LIBADD =
++_cracklibmodule_la_LIBADD = -lpython$(PYTHON_VERSION)
+ _cracklibmodule_la_SOURCES = _cracklibmodule.c
+ _cracklibmodule_la_OBJECTS = _cracklibmodule.lo
+ _cracklibmodule_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \