summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-04 21:06:59 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-04 21:06:59 +0000
commitf05c8b159cae6ccbca18ef4c470e54fe86e7f814 (patch)
treebd7e00ddbbbb83d5646d0bfc943744b53a588459 /sys-libs
parentUpdate description to say Portable CLX is primarily for use with SBCL. (diff)
downloadgentoo-2-f05c8b159cae6ccbca18ef4c470e54fe86e7f814.tar.gz
gentoo-2-f05c8b159cae6ccbca18ef4c470e54fe86e7f814.tar.bz2
gentoo-2-f05c8b159cae6ccbca18ef4c470e54fe86e7f814.zip
Add back in sanity check to prevent people from downgrading their glibc.
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r2.ebuild13
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r3.ebuild13
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r3.ebuild12
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r4.ebuild12
-rw-r--r--sys-libs/glibc/glibc-2.4-r3.ebuild12
6 files changed, 61 insertions, 8 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 929ceb53cd3a..6e477871d0a2 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.470 2006/06/28 19:34:21 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.471 2006/07/04 21:06:59 vapier Exp $
+
+ 04 Jul 2006; Mike Frysinger <vapier@gentoo.org> glibc-2.3.5-r2.ebuild,
+ glibc-2.3.5-r3.ebuild, glibc-2.3.6-r3.ebuild, glibc-2.3.6-r4.ebuild,
+ glibc-2.4-r3.ebuild:
+ Add back in sanity check to prevent people from downgrading their glibc.
28 Jun 2006; Markus Rothe <corsair@gentoo.org> glibc-2.3.6-r4.ebuild:
Stable on ppc64
diff --git a/sys-libs/glibc/glibc-2.3.5-r2.ebuild b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
index 8f2975ec37be..bc38568a1467 100644
--- a/sys-libs/glibc/glibc-2.3.5-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.28 2006/05/30 19:45:22 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.29 2006/07/04 21:06:59 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1033,12 +1033,21 @@ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
fi
pkg_setup() {
+ # prevent native builds from downgrading ... maybe update to allow people
+ # to change between diff -r versions ? (2.3.6-r4 -> 2.3.6-r2)
+ if ! is_crosscompile && ! tc-is-cross-compiler ; then
+ if has_version '>'${CATEGORY}/${PF} ; then
+ eerror "Sanity check to keep you from breaking your system:"
+ eerror " Downgrading glibc is not supported and a sure way to destruction"
+ die "aborting to save your system"
+ fi
+ fi
+
if use nptlonly && ! use nptl ; then
eerror "If you want nptlonly, add nptl to your USE too ;p"
die "nptlonly without nptl"
fi
-
# give some sort of warning about the nptl logic changes...
if want_nptl && want_linuxthreads ; then
diff --git a/sys-libs/glibc/glibc-2.3.5-r3.ebuild b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
index 96f55d819e59..49dbd3154fa3 100644
--- a/sys-libs/glibc/glibc-2.3.5-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.26 2006/06/16 04:20:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.27 2006/07/04 21:06:59 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1025,12 +1025,21 @@ else
fi
pkg_setup() {
+ # prevent native builds from downgrading ... maybe update to allow people
+ # to change between diff -r versions ? (2.3.6-r4 -> 2.3.6-r2)
+ if ! is_crosscompile && ! tc-is-cross-compiler ; then
+ if has_version '>'${CATEGORY}/${PF} ; then
+ eerror "Sanity check to keep you from breaking your system:"
+ eerror " Downgrading glibc is not supported and a sure way to destruction"
+ die "aborting to save your system"
+ fi
+ fi
+
if use nptlonly && ! use nptl ; then
eerror "If you want nptlonly, add nptl to your USE too ;p"
die "nptlonly without nptl"
fi
-
# give some sort of warning about the nptl logic changes...
if want_nptl && want_linuxthreads ; then
diff --git a/sys-libs/glibc/glibc-2.3.6-r3.ebuild b/sys-libs/glibc/glibc-2.3.6-r3.ebuild
index 887e3a0f162f..8f883dce3815 100644
--- a/sys-libs/glibc/glibc-2.3.6-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r3.ebuild,v 1.20 2006/05/30 19:45:22 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r3.ebuild,v 1.21 2006/07/04 21:06:59 vapier Exp $
# TODO:
# - fix warning from glibc build system:
@@ -1092,6 +1092,16 @@ else
fi
pkg_setup() {
+ # prevent native builds from downgrading ... maybe update to allow people
+ # to change between diff -r versions ? (2.3.6-r4 -> 2.3.6-r2)
+ if ! is_crosscompile && ! tc-is-cross-compiler ; then
+ if has_version '>'${CATEGORY}/${PF} ; then
+ eerror "Sanity check to keep you from breaking your system:"
+ eerror " Downgrading glibc is not supported and a sure way to destruction"
+ die "aborting to save your system"
+ fi
+ fi
+
if has_version '>=sys-libs/glibc-2.3.5.20050201' && \
has_version '<sys-libs/glibc-2.3.6' ; then
eerror "Portage have a serious bug in regards to symlinks, and merging"
diff --git a/sys-libs/glibc/glibc-2.3.6-r4.ebuild b/sys-libs/glibc/glibc-2.3.6-r4.ebuild
index d0fe816953be..b497c931eb4f 100644
--- a/sys-libs/glibc/glibc-2.3.6-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r4.ebuild,v 1.21 2006/06/30 02:51:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r4.ebuild,v 1.22 2006/07/04 21:06:59 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1023,6 +1023,16 @@ else
fi
pkg_setup() {
+ # prevent native builds from downgrading ... maybe update to allow people
+ # to change between diff -r versions ? (2.3.6-r4 -> 2.3.6-r2)
+ if ! is_crosscompile && ! tc-is-cross-compiler ; then
+ if has_version '>'${CATEGORY}/${PF} ; then
+ eerror "Sanity check to keep you from breaking your system:"
+ eerror " Downgrading glibc is not supported and a sure way to destruction"
+ die "aborting to save your system"
+ fi
+ fi
+
if use nptlonly && ! use nptl ; then
eerror "If you want nptlonly, add nptl to your USE too ;p"
die "nptlonly without nptl"
diff --git a/sys-libs/glibc/glibc-2.4-r3.ebuild b/sys-libs/glibc/glibc-2.4-r3.ebuild
index 0d9d92380bae..f6036ffaed1d 100644
--- a/sys-libs/glibc/glibc-2.4-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r3.ebuild,v 1.13 2006/06/28 05:01:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r3.ebuild,v 1.14 2006/07/04 21:06:59 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1063,6 +1063,16 @@ else
fi
pkg_setup() {
+ # prevent native builds from downgrading ... maybe update to allow people
+ # to change between diff -r versions ? (2.3.6-r4 -> 2.3.6-r2)
+ if ! is_crosscompile && ! tc-is-cross-compiler ; then
+ if has_version '>'${CATEGORY}/${PF} ; then
+ eerror "Sanity check to keep you from breaking your system:"
+ eerror " Downgrading glibc is not supported and a sure way to destruction"
+ die "aborting to save your system"
+ fi
+ fi
+
if want_linuxthreads ; then
ewarn "glibc-2.4 is nptl-only!"
[[ ${CTARGET} == i386-* ]] && eerror "NPTL requires a CHOST of i486 or better"