summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-06-01 14:37:43 +0000
committerTravis Tilley <lv@gentoo.org>2004-06-01 14:37:43 +0000
commitff857bf0834f9baeb9ea45bf7d86e0e2040b4f11 (patch)
tree53e3a1108f26a684efe0b47d9d01b3ee0a746589 /sys-libs
parentarm KEYWORDS (diff)
downloadgentoo-2-ff857bf0834f9baeb9ea45bf7d86e0e2040b4f11.tar.gz
gentoo-2-ff857bf0834f9baeb9ea45bf7d86e0e2040b4f11.tar.bz2
gentoo-2-ff857bf0834f9baeb9ea45bf7d86e0e2040b4f11.zip
more grsex/pax/binutils fixes
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild
index aaa5c09d63ea..795aacf60346 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild,v 1.4 2004/05/30 15:18:39 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild,v 1.5 2004/06/01 14:37:43 lv Exp $
-IUSE="nls pic build nptl erandom"
+IUSE="nls pic build nptl erandom hardened"
inherit eutils flag-o-matic gcc
@@ -451,8 +451,8 @@ src_unpack() {
#use hardened || sed -e 's/^ASFLAGS-config.*/ASFLAGS-config =/' -i ${S}/config.make.in
# mandatory, if binutils supports relro and the kernel is pax/grsecurity enabled
# solves almost all segfaults building the locale files on grsecurity enabled kernels
- # lv_* remaining (it could depend on bind-now enabled later)
- use hardened && sed -e 's/^LDFLAGS-rtld += $(relro.*/LDFLAGS-rtld += -Wl,-z,norelro/' -i ${S}/Makeconfig
+ use build && sed -e 's/^LDFLAGS-rtld += $(relro.*/LDFLAGS-rtld += -Wl,-z,norelro/' -i ${S}/Makeconfig
+ use build || (use hardened && sed -e 's/^LDFLAGS-rtld += $(relro.*/LDFLAGS-rtld += -Wl,-z,norelro/' -i ${S}/Makeconfig)
}
setup_flags() {
@@ -519,8 +519,10 @@ src_compile() {
--enable-kernel=${MIN_NPTL_KV} \
--with-headers=${kernelheaders}"
else
- myconf="${myconf} --with-tls --without-__thread \
+ myconf="${myconf} --without-__thread \
--enable-add-ons=linuxthreads"
+ use build && myconf="${myconf} --without-tls" || \
+ myconf="${myconf} --with-tls"
# If we build for the build system we use the kernel headers from the target
# We also now set it without "build" as well, else it might use the