summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-06-04 17:57:51 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-06-04 17:57:51 +0000
commit92017febf9d9a2354b30f1177aec5b0c02280121 (patch)
tree4a80061b0597c5c815ec3a5b9c56ea02d6b1ee60 /sys-power/hibernate-script
parentQuiet QA compilation warnings. (diff)
downloadgentoo-2-92017febf9d9a2354b30f1177aec5b0c02280121.tar.gz
gentoo-2-92017febf9d9a2354b30f1177aec5b0c02280121.tar.bz2
gentoo-2-92017febf9d9a2354b30f1177aec5b0c02280121.zip
Add ususpend vbe mode support, thanks to Ricardo Salveti
(Portage version: 2.1.2.9)
Diffstat (limited to 'sys-power/hibernate-script')
-rw-r--r--sys-power/hibernate-script/ChangeLog8
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.95-r36
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.95-r3.ebuild71
3 files changed, 84 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index 0d0bc4bc58f3..255c13846ca6 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.56 2007/05/25 19:54:06 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.57 2007/06/04 17:57:51 alonbl Exp $
+
+*hibernate-script-1.95-r3 (04 Jun 2007)
+
+ 04 Jun 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +hibernate-script-1.95-r3.ebuild:
+ Add ususpend vbe mode support, thanks to Ricardo Salveti
*hibernate-script-1.95-r2 (25 May 2007)
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.95-r3 b/sys-power/hibernate-script/files/digest-hibernate-script-1.95-r3
new file mode 100644
index 000000000000..d3d8c8c81a08
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.95-r3
@@ -0,0 +1,6 @@
+MD5 05043b8ab3b2b2651bb7c92926295244 hibernate-script-1.95-patches-3.tar.bz2 2111
+RMD160 5a78ac9187b179f13576cef781516a3f6f6d4e51 hibernate-script-1.95-patches-3.tar.bz2 2111
+SHA256 2363769ecd92dcfce1cda7dbc025058059f4cfd1b8f75751bf2e182691879c6b hibernate-script-1.95-patches-3.tar.bz2 2111
+MD5 026a7a8992da4fe56fb19530df998806 hibernate-script-1.95.tar.gz 74954
+RMD160 032cb97c355248640107e779f99ad5a86fb74846 hibernate-script-1.95.tar.gz 74954
+SHA256 e0c73cd1c3af2c0f409dba07e6fbd86c23150cfe77c4f9286ce239aedbe0a123 hibernate-script-1.95.tar.gz 74954
diff --git a/sys-power/hibernate-script/hibernate-script-1.95-r3.ebuild b/sys-power/hibernate-script/hibernate-script-1.95-r3.ebuild
new file mode 100644
index 000000000000..b45f41e65a22
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.95-r3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.95-r3.ebuild,v 1.1 2007/06/04 17:57:51 alonbl Exp $
+
+inherit eutils
+
+PATCH_VERSION="3"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim-syntax"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Our patches
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "If you run suspend2, you should run the following command to"
+ elog "invalidate suspend images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}