summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-09-09 06:01:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-09-09 06:01:37 +0000
commit69895783b83f4117be46d30d7f5c6ecacf3bc6fb (patch)
treed7d17d2d29352509c2f7d57e9c45b183ecb4b909 /sys-power/iasl/files
parentFix bug #235025 for libtool-2.2 and non-bash boxes. (diff)
downloadgentoo-2-69895783b83f4117be46d30d7f5c6ecacf3bc6fb.tar.gz
gentoo-2-69895783b83f4117be46d30d7f5c6ecacf3bc6fb.tar.bz2
gentoo-2-69895783b83f4117be46d30d7f5c6ecacf3bc6fb.zip
Bug #236027, fix parallel make thanks to patch from flameeyes.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5-00283-g70bb089 x86_64)
Diffstat (limited to 'sys-power/iasl/files')
-rw-r--r--sys-power/iasl/files/iasl-20080701-parallelmake.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-power/iasl/files/iasl-20080701-parallelmake.patch b/sys-power/iasl/files/iasl-20080701-parallelmake.patch
new file mode 100644
index 000000000000..ce51efedbab7
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20080701-parallelmake.patch
@@ -0,0 +1,47 @@
+Index: acpica-unix-20080701.old/compiler/Makefile
+===================================================================
+--- acpica-unix-20080701.old.orig/compiler/Makefile
++++ acpica-unix-20080701.old/compiler/Makefile
+@@ -1,7 +1,7 @@
+
+
+ PROG= iasl
+-SRCS= aslcompilerparse.c aslcompilerlex.c aslanalyze.c aslcodegen.c \
++SRCS= aslcompiler.y.c aslcompilerlex.c aslanalyze.c aslcodegen.c \
+ aslcompile.c aslerror.c aslfiles.c asllength.c \
+ asllisting.c aslload.c asllookup.c aslmain.c aslmap.c aslopcodes.c \
+ asloperands.c aslresource.c aslrestype1.c aslrestype2.c aslstartup.c \
+@@ -89,6 +89,7 @@ SRCS= aslcompilerparse.c aslcompilerlex.
+ ../tables/tbutils.c \
+ ../tables/tbxface.c \
+ ../osunixxf.c
++OBJS = $(patsubst %.c,%.o, $(SRCS))
+
+ NOMAN= YES
+ CFLAGS+= -Wall -O2 -Wstrict-prototypes -D_LINUX -DACPI_ASL_COMPILER -I../include
+@@ -105,17 +106,19 @@ YFLAGS+= -y -pAslCompiler
+ #CFLAGS+= -D_USE_BERKELEY_YACC
+ #.endif
+
+-aslmain : $(patsubst %.c,%.o, $(SRCS))
++aslmain : $(OBJS)
+ $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) \
+ $(LOADLIBES) $(LDLIBS) -o iasl
+
++$(OBJS): aslcompiler.y.h
++
+ CLEANFILES= y.output y.tab.c y.tab.h aslcompiler.y.h \
+- aslcompilerparse.c aslcompilerlex.c iasl
++ aslcompiler.y.c aslcompilerlex.c iasl
++
++aslcompiler.y.h: aslcompiler.y.c
+
+-aslcompilerparse.c: aslcompiler.y
+- ${YACC} ${YFLAGS} aslcompiler.y
+- cp y.tab.c aslcompilerparse.c
+- cp y.tab.h aslcompiler.y.h
++aslcompiler.y.c: aslcompiler.y
++ ${YACC} ${YFLAGS} aslcompiler.y -o aslcompiler.y.c
+
+ aslcompilerlex.c: aslcompiler.l
+ ${LEX} ${LFLAGS} -PAslCompiler -oaslcompilerlex.c aslcompiler.l