summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-09-02 19:12:50 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-09-02 19:12:50 +0000
commit77d46b886f9abd6b95352011fbdcec9b80503cd2 (patch)
tree6e767cf5b9a19f1b7c3bef7c0f45eedadcc6ce0d /sys-power/powersoftplus/powersoftplus-0.1.8-r1.ebuild
parentdev-embedded/powersoftplus-libftdi: Moved libftd2xx to a separate package, Ch... (diff)
downloadgentoo-2-77d46b886f9abd6b95352011fbdcec9b80503cd2.tar.gz
gentoo-2-77d46b886f9abd6b95352011fbdcec9b80503cd2.tar.bz2
gentoo-2-77d46b886f9abd6b95352011fbdcec9b80503cd2.zip
sys-power/powersoftplus: Build against installed system library, Added notice regarding USB device usage
(Portage version: 2.1.2.12)
Diffstat (limited to 'sys-power/powersoftplus/powersoftplus-0.1.8-r1.ebuild')
-rw-r--r--sys-power/powersoftplus/powersoftplus-0.1.8-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/sys-power/powersoftplus/powersoftplus-0.1.8-r1.ebuild b/sys-power/powersoftplus/powersoftplus-0.1.8-r1.ebuild
new file mode 100644
index 000000000000..1e4b28bde240
--- /dev/null
+++ b/sys-power/powersoftplus/powersoftplus-0.1.8-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powersoftplus/powersoftplus-0.1.8-r1.ebuild,v 1.1 2007/09/02 19:12:49 jurek Exp $
+
+inherit autotools
+
+DESCRIPTION="Ever UPS daemon"
+HOMEPAGE="http://www.ever.com.pl"
+SRC_URI="http://www.ever.com.pl/pl/pliki/${P}-x86.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-embedded/libftd2xx
+ =dev-embedded/powersoftplus-libftdi-${PV}*"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Remove libftdi because we moved it to another package
+ # Remove scripts because we provide our own startup scripts
+ sed -i -e 's#^SUBDIRS = libftdi \(.*\) scripts#SUBDIRS = \1#' \
+ Makefile.am \
+ || die "sed failed"
+
+ # Fix libftd2xx header reference
+ sed -i \
+ -e 's@^#include "libftdi/ftd2xx.h$@#include <ftd2xx.h>@' \
+ src/ftccomm.h \
+ -e 's#-I$(top_srcdir)/libftdi##' \
+ Makefile.am \
+ || die "sed failed"
+
+ # Fix access violations
+ sed -i -e \
+ 's#^CONFPATH = @CONFIG_PATH@$#CONFPATH = ${DESTDIR}/@CONFIG_PATH@#' \
+ conf/Makefile.in \
+ || die "sed failed"
+
+ # Fix access violations
+ sed -i -e \
+ 's#^PIXPATH = @PIX_PATH@$#PIXPATH = ${DESTDIR}/@PIX_PATH@#' \
+ pix/Makefile.in \
+ || die "sed failed"
+
+ eautoreconf
+
+ epatch ${FILESDIR}/${P}-reduceverbosity.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ doinitd ${FILESDIR}/powersoftplus
+ dodoc AUTHORS COPYING INSTALL README TODO Pomoc.pdf
+}
+
+pkg_postinst() {
+ elog "Remeber that if you want to communicate with USB devices you"
+ elog "have to edit /etc/fstab so that it contains the following entry"
+ elog " none /proc/bus/usb usbfs defaults,devmode=0666 0 0"
+}