summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-04-14 00:27:54 +0000
committerMichael Weber <xmw@gentoo.org>2014-04-14 00:27:54 +0000
commit1c664b1ee5a39a65b34d491cf2cccffa2156c0d1 (patch)
treebe2db105cdbd155daeb8cdeac20e1e3c6a8e93e4 /sys-power
parentAdd maintainer information and wonder why we don't have a check for that. (diff)
downloadgentoo-2-1c664b1ee5a39a65b34d491cf2cccffa2156c0d1.tar.gz
gentoo-2-1c664b1ee5a39a65b34d491cf2cccffa2156c0d1.tar.bz2
gentoo-2-1c664b1ee5a39a65b34d491cf2cccffa2156c0d1.zip
Version bump for kernel 3.13 and 3.14
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/phc-intel/ChangeLog10
-rw-r--r--sys-power/phc-intel/files/phc-intel-pack-rev14-trailing-space-3.13.patch43
-rw-r--r--sys-power/phc-intel/files/phc-intel-pack-rev14-trailing-space-3.14.patch43
-rw-r--r--sys-power/phc-intel/phc-intel-0.3.2.12.14.ebuild67
4 files changed, 162 insertions, 1 deletions
diff --git a/sys-power/phc-intel/ChangeLog b/sys-power/phc-intel/ChangeLog
index c868a474576d..010ef9811716 100644
--- a/sys-power/phc-intel/ChangeLog
+++ b/sys-power/phc-intel/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-power/phc-intel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-intel/ChangeLog,v 1.15 2014/03/20 22:58:28 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-intel/ChangeLog,v 1.16 2014/04/14 00:27:54 xmw Exp $
+
+*phc-intel-0.3.2.12.14 (14 Apr 2014)
+
+ 14 Apr 2014; Michael Weber <xmw@gentoo.org>
+ +files/phc-intel-pack-rev14-trailing-space-3.13.patch,
+ +files/phc-intel-pack-rev14-trailing-space-3.14.patch,
+ +phc-intel-0.3.2.12.14.ebuild:
+ Version bump for kernel 3.13 and 3.14
20 Mar 2014; Michael Weber <xmw@gentoo.org>
+files/phc-intel-pack-rev12-trailing-space-r1.patch,
diff --git a/sys-power/phc-intel/files/phc-intel-pack-rev14-trailing-space-3.13.patch b/sys-power/phc-intel/files/phc-intel-pack-rev14-trailing-space-3.13.patch
new file mode 100644
index 000000000000..ac9ecd7c2987
--- /dev/null
+++ b/sys-power/phc-intel/files/phc-intel-pack-rev14-trailing-space-3.13.patch
@@ -0,0 +1,43 @@
+--- phc-intel-pack-rev14/inc/3.13/linux-phc-0.4.0.patch.orig 2014-04-14 02:18:58.464488475 +0200
++++ phc-intel-pack-rev14/inc/3.13/linux-phc-0.4.0.patch 2014-04-14 02:21:12.018581946 +0200
+@@ -225,7 +225,7 @@
+ static void __init acpi_cpufreq_boost_init(void)
+ {
+ if (boot_cpu_has(X86_FEATURE_CPB) || boot_cpu_has(X86_FEATURE_IDA)) {
+-@@ -956,6 +1064,587 @@
++@@ -956,6 +1064,591 @@
+ }
+ }
+
+@@ -355,6 +355,7 @@
+ + //add seperating space
+ + if(freq_table[i+1].frequency != CPUFREQ_TABLE_END) count += sprintf(&buf[count], " ");
+ + }
+++ if (count) count--;
+ + count += sprintf(&buf[count], "\n"); //add line break
+ + return count;
+ +
+@@ -382,6 +383,7 @@
+ + if(freq_table[i+1].frequency != CPUFREQ_TABLE_END) count += sprintf(&buf[count], " ");
+ + }
+ +
+++ if (count) count--;
+ + count += sprintf(&buf[count], "\n"); //add NewLine
+ + return count;
+ +}
+@@ -631,6 +633,7 @@
+ + //add seperating space
+ + if(freq_table[i+1].frequency != CPUFREQ_TABLE_END) count += sprintf(&buf[count], " ");
+ + }
+++ if (count) count--;
+ + count += sprintf(&buf[count], "\n");
+ +
+ + return count;
+@@ -660,6 +663,7 @@
+ + count += sprintf(&buf[count], "%u", vid);
+ + if(freq_table[i+1].frequency != CPUFREQ_TABLE_END) count += sprintf(&buf[count], " ");
+ + }
+++ if (count) count--;
+ + count += sprintf(&buf[count], "\n");
+ +
+ + return count;
diff --git a/sys-power/phc-intel/files/phc-intel-pack-rev14-trailing-space-3.14.patch b/sys-power/phc-intel/files/phc-intel-pack-rev14-trailing-space-3.14.patch
new file mode 100644
index 000000000000..f89b57052983
--- /dev/null
+++ b/sys-power/phc-intel/files/phc-intel-pack-rev14-trailing-space-3.14.patch
@@ -0,0 +1,43 @@
+--- phc-intel-pack-rev14/inc/3.14/linux-phc-0.4.0.patch
++++ phc-intel-pack-rev14/inc/3.14/linux-phc-0.4.0.patch
+@@ -226,7 +226,7 @@
+ static void __init acpi_cpufreq_boost_init(void)
+ {
+ if (boot_cpu_has(X86_FEATURE_CPB) || boot_cpu_has(X86_FEATURE_IDA)) {
+-@@ -929,6 +1036,588 @@
++@@ -929,6 +1036,592 @@
+ }
+ }
+
+@@ -356,6 +356,7 @@
+ + //add seperating space
+ + if(freq_table[i+1].frequency != CPUFREQ_TABLE_END) count += sprintf(&buf[count], " ");
+ + }
+++ if (count) count--;
+ + count += sprintf(&buf[count], "\n"); //add line break
+ + return count;
+ +
+@@ -383,6 +384,7 @@
+ + if(freq_table[i+1].frequency != CPUFREQ_TABLE_END) count += sprintf(&buf[count], " ");
+ + }
+ +
+++ if (count) count--;
+ + count += sprintf(&buf[count], "\n"); //add NewLine
+ + return count;
+ +}
+@@ -632,6 +634,7 @@
+ + //add seperating space
+ + if(freq_table[i+1].frequency != CPUFREQ_TABLE_END) count += sprintf(&buf[count], " ");
+ + }
+++ if (count) count--;
+ + count += sprintf(&buf[count], "\n");
+ +
+ + return count;
+@@ -661,6 +664,7 @@
+ + count += sprintf(&buf[count], "%u", vid);
+ + if(freq_table[i+1].frequency != CPUFREQ_TABLE_END) count += sprintf(&buf[count], " ");
+ + }
+++ if (count) count--;
+ + count += sprintf(&buf[count], "\n");
+ +
+ + return count;
diff --git a/sys-power/phc-intel/phc-intel-0.3.2.12.14.ebuild b/sys-power/phc-intel/phc-intel-0.3.2.12.14.ebuild
new file mode 100644
index 000000000000..57328fa030c9
--- /dev/null
+++ b/sys-power/phc-intel/phc-intel-0.3.2.12.14.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-intel/phc-intel-0.3.2.12.14.ebuild,v 1.1 2014/04/14 00:27:54 xmw Exp $
+
+EAPI=5
+
+inherit linux-info linux-mod eutils
+
+DESCRIPTION="Processor Hardware Control for Intel CPUs"
+HOMEPAGE="http://www.linux-phc.org/
+ http://www.linux-phc.org/forum/viewtopic.php?f=7&t=267"
+#no automatic filenames here, sorry
+SRC_URI="http://www.linux-phc.org/forum/download/file.php?id=159 -> phc-intel-pack-rev14.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CONFIG_CHECK="~!X86_ACPI_CPUFREQ"
+ERROR_X86_ACPI_CPUFREQ="CONFIG_X86_ACPI_CPUFREQ has to be configured to Module to enable the replacement of acpi-cpufreq with phc-intel."
+
+MODULE_NAMES="phc-intel(misc:)"
+BUILD_PARAMS="KERNELSRC=\"${KERNEL_DIR}\" -j1"
+BUILD_TARGETS="all"
+
+S=${WORKDIR}/${A/.tar.bz2}
+
+pkg_setup() {
+ if kernel_is lt 2 6 27 ; then
+ eerror "Your kernel version is no longer supported by this version of ${PN}."
+ eerror "Please use a previous version of ${PN} or a newer kernel."
+ die
+ fi
+ if kernel_is gt 3 14 ; then
+ eerror "Your kernel version is not yet supported by this version of ${PN}."
+ eerror "Please use a newer version of ${PN} or an older kernel."
+ die
+ fi
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/phc-intel-pack-rev12-trailing-space-r1.patch
+ epatch "${FILESDIR}"/phc-intel-pack-rev14-trailing-space-3.13.patch
+ epatch "${FILESDIR}"/phc-intel-pack-rev14-trailing-space-3.14.patch
+
+ sed -e '/^all:/s:prepare::' \
+ -i Makefile || die
+
+ local my_sub=arch/x86/kernel/cpu
+ if kernel_is gt 2 6 39 ; then
+ my_sub=drivers
+ fi
+ cp -v "${KERNEL_DIR}"/${my_sub}/cpufreq/acpi-cpufreq.c . || die
+ if kernel_is lt 3 12 ; then
+ cp -v "${KERNEL_DIR}"/${my_sub}/cpufreq/mperf.h . || die
+ fi
+
+ if kernel_is lt 3 0 ; then
+ epatch inc/${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}/linux-phc-0.3.2.patch
+ else
+ epatch inc/${KV_MAJOR}.${KV_MINOR}/linux-phc-0.3.2.patch
+ fi
+
+ mv acpi-cpufreq.c phc-intel.c || die
+}