summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-04-03 06:10:07 +0000
committerMike Frysinger <vapier@gentoo.org>2015-04-03 06:10:07 +0000
commit6e0faea75c50bfa0a99c451daa156b42f8d1e65f (patch)
treeff006aff0fd082ad1746138f2ef18193a3f946e3 /sys-process/numactl
parentFix upstream bug url. (diff)
downloadgentoo-2-6e0faea75c50bfa0a99c451daa156b42f8d1e65f.tar.gz
gentoo-2-6e0faea75c50bfa0a99c451daa156b42f8d1e65f.tar.bz2
gentoo-2-6e0faea75c50bfa0a99c451daa156b42f8d1e65f.zip
Respect user CFLAGS when building numademo #540856 by Arfrever Frehtes Taifersar Arahesis.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-process/numactl')
-rw-r--r--sys-process/numactl/ChangeLog9
-rw-r--r--sys-process/numactl/files/numactl-2.0.10-numademo-cflags.patch15
-rw-r--r--sys-process/numactl/numactl-2.0.10-r2.ebuild50
3 files changed, 73 insertions, 1 deletions
diff --git a/sys-process/numactl/ChangeLog b/sys-process/numactl/ChangeLog
index 093a30a877ca..bfaa9fcbc33e 100644
--- a/sys-process/numactl/ChangeLog
+++ b/sys-process/numactl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-process/numactl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.39 2015/02/20 02:47:47 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.40 2015/04/03 06:10:07 vapier Exp $
+
+*numactl-2.0.10-r2 (03 Apr 2015)
+
+ 03 Apr 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/numactl-2.0.10-numademo-cflags.patch, +numactl-2.0.10-r2.ebuild:
+ Respect user CFLAGS when building numademo #540856 by Arfrever Frehtes
+ Taifersar Arahesis.
*numactl-2.0.10-r1 (20 Feb 2015)
diff --git a/sys-process/numactl/files/numactl-2.0.10-numademo-cflags.patch b/sys-process/numactl/files/numactl-2.0.10-numademo-cflags.patch
new file mode 100644
index 000000000000..9b318df5a5ca
--- /dev/null
+++ b/sys-process/numactl/files/numactl-2.0.10-numademo-cflags.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/540856
+
+respect user CFLAGS
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -23,7 +23,7 @@ numastat_CFLAGS = $(AM_CFLAGS) -std=gnu99
+
+ numademo_SOURCES = numademo.c stream_lib.c stream_lib.h mt.c mt.h clearcache.c clearcache.h
+ numademo_CPPFLAGS = $(AM_CPPFLAGS) -DHAVE_STREAM_LIB -DHAVE_MT -DHAVE_CLEAR_CACHE
+-numademo_CFLAGS = -O3 -ffast-math -funroll-loops
++numademo_CFLAGS = $(AM_CFLAGS) -ffast-math -funroll-loops
+ if HAVE_TREE_VECTORIZE
+ numademo_CFLAGS += -ftree-vectorize
+ endif
diff --git a/sys-process/numactl/numactl-2.0.10-r2.ebuild b/sys-process/numactl/numactl-2.0.10-r2.ebuild
new file mode 100644
index 000000000000..f286d971c3b6
--- /dev/null
+++ b/sys-process/numactl/numactl-2.0.10-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.10-r2.ebuild,v 1.1 2015/04/03 06:10:07 vapier Exp $
+
+EAPI=5
+
+inherit autotools eutils toolchain-funcs multilib-minimal
+
+DESCRIPTION="Utilities and libraries for NUMA systems"
+HOMEPAGE="http://oss.sgi.com/projects/libnuma/"
+SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# ARM lacks the __NR_migrate_pages syscall.
+KEYWORDS="~amd64 -arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+ECONF_SOURCE=${S}
+
+src_prepare() {
+ eautoreconf
+ epatch "${FILESDIR}"/${PN}-2.0.8-cpuid-pic.patch #456238
+ epatch "${FILESDIR}"/${PN}-2.0.10-numademo-cflags.patch #540856
+}
+
+src_test() {
+ if [ -d /sys/devices/system/node ]; then
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ emake regress2
+ else
+ ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
+ fi
+}
+
+multilib_src_compile() {
+ multilib_is_native_abi && default || emake libnuma.la
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
+}
+
+multilib_src_install_all() {
+ DOCS=( README TODO CHANGES DESIGN )
+ einstalldocs
+ # delete man pages provided by the man-pages package #238805
+ rm -r "${ED}"/usr/share/man/man[25] || die
+}