summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-04-02 01:00:09 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-04-02 01:00:09 +0000
commit34fa97592ace154e2e1d2e51a6cb9993d5241b39 (patch)
treecb617cf5076164d5000a966c8a87876ed11f3e30 /sys-process
parentamd64 stable - 215702 (diff)
downloadgentoo-2-34fa97592ace154e2e1d2e51a6cb9993d5241b39.tar.gz
gentoo-2-34fa97592ace154e2e1d2e51a6cb9993d5241b39.tar.bz2
gentoo-2-34fa97592ace154e2e1d2e51a6cb9993d5241b39.zip
Version bump for security bug #215705.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/audit/ChangeLog7
-rw-r--r--sys-process/audit/audit-1.7.ebuild113
2 files changed, 119 insertions, 1 deletions
diff --git a/sys-process/audit/ChangeLog b/sys-process/audit/ChangeLog
index 0a9201169237..867cff1f90e5 100644
--- a/sys-process/audit/ChangeLog
+++ b/sys-process/audit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/audit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.41 2008/03/31 05:37:06 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.42 2008/04/02 01:00:09 robbat2 Exp $
+
+*audit-1.7 (02 Apr 2008)
+
+ 02 Apr 2008; Robin H. Johnson <robbat2@gentoo.org> +audit-1.7.ebuild:
+ Version bump for security bug #215705.
31 Mar 2008; <ricmm@gentoo.org> audit-1.5.4.ebuild:
Drop to ~mips due to unstable deps
diff --git a/sys-process/audit/audit-1.7.ebuild b/sys-process/audit/audit-1.7.ebuild
new file mode 100644
index 000000000000..4055c6f28ac8
--- /dev/null
+++ b/sys-process/audit/audit-1.7.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/audit-1.7.ebuild,v 1.1 2008/04/02 01:00:09 robbat2 Exp $
+
+inherit autotools multilib toolchain-funcs python
+
+DESCRIPTION="Userspace utilities for storing and processing auditing records"
+HOMEPAGE="http://people.redhat.com/sgrubb/audit/"
+SRC_URI="http://people.redhat.com/sgrubb/audit/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap"
+# Testcases are pretty useless as they are built for RedHat users/groups and
+# kernels.
+RESTRICT="test"
+
+RDEPEND=">=dev-lang/python-2.4
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ >=sys-kernel/linux-headers-2.6.23"
+# Do not use os-headers as this is linux specific
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Old patch applies fine
+ #EPATCH_OPTS="-p0 -d${S}" epatch "${FILESDIR}"/${PN}-1.5.4-build.patch
+
+ # Applied by upstream
+ #EPATCH_OPTS="-p1 -d${S}" epatch "${FILESDIR}"/${PN}-1.5.4-swig-gcc-attribute.patch
+
+ # Do not build GUI tools
+ sed -i \
+ -e '/AC_CONFIG_SUBDIRS.*system-config-audit/d' \
+ "${S}"/configure.ac
+ sed -i \
+ -e 's,system-config-audit,,g' \
+ -e '/^SUBDIRS/s,\\$,,g' \
+ "${S}"/Makefile.am
+ rm -rf "${S}"/system-config-audit
+
+ # Probably goes away in 1.6.9
+ EPATCH_OPTS="-p1 -d${S}" epatch "${FILESDIR}"/audit-1.6.8-subdirs-fix.patch
+
+ if ! use ldap; then
+ sed -i \
+ -e '/^AC_OUTPUT/s,audisp/plugins/zos-remote/Makefile,,g' \
+ "${S}"/configure.ac
+ sed -i \
+ -e '/^SUBDIRS/s,zos-remote,,g' \
+ "${S}"/audisp/plugins/Makefile.am
+ fi
+
+ # Regenerate autotooling
+ eautoreconf
+}
+
+src_compile() {
+ #append-flags -D'__attribute__(x)='
+ econf --sbindir=/sbin --without-prelude || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README* THANKS TODO
+ docinto contrib
+ dodoc contrib/*
+ docinto contrib/plugin
+ dodoc contrib/plugin/*
+
+ newinitd "${FILESDIR}"/auditd-init.d-1.2.3 auditd
+ newconfd "${FILESDIR}"/auditd-conf.d-1.2.3 auditd
+
+ # things like shadow use this so we need to be in /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/lib*.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libaudit.so libauparse.so
+
+ # remove RedHat garbage
+ rm -r "${D}"/etc/{rc.d,sysconfig} || die
+
+ # Gentoo rules
+ insinto /etc/audit/
+ doins "${FILESDIR}"/audit.rules*
+
+ # audit logs go here
+ keepdir /var/log/audit/
+
+ # Security
+ lockdown_perms "${D}"
+}
+
+pkg_postinst() {
+ lockdown_perms "${ROOT}"
+ python_mod_optimize
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
+
+lockdown_perms() {
+ # upstream wants these to have restrictive perms
+ basedir="$1"
+ chmod 0750 "${basedir}"/sbin/au{ditctl,report,dispd,ditd,search,trace} 2>/dev/null
+ chmod 0750 "${basedir}"/var/log/audit/ 2>/dev/null
+ chmod 0640 "${basedir}"/etc/{audit/,}{auditd.conf,audit.rules*} 2>/dev/null
+}