summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-18 10:26:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-18 10:26:21 +0000
commitbba905dbd66b5bee264bd427ddb7adba6ce9e53e (patch)
tree85615fe11f14724aed5169b73426686a3a832f76 /virtual/ruby-rdoc/ruby-rdoc-3.ebuild
parentAdd another Ruby virtual with four versions. (diff)
downloadgentoo-2-bba905dbd66b5bee264bd427ddb7adba6ce9e53e.tar.gz
gentoo-2-bba905dbd66b5bee264bd427ddb7adba6ce9e53e.tar.bz2
gentoo-2-bba905dbd66b5bee264bd427ddb7adba6ce9e53e.zip
Import the rdoc virtual for Ruby.
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'virtual/ruby-rdoc/ruby-rdoc-3.ebuild')
-rw-r--r--virtual/ruby-rdoc/ruby-rdoc-3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/virtual/ruby-rdoc/ruby-rdoc-3.ebuild b/virtual/ruby-rdoc/ruby-rdoc-3.ebuild
new file mode 100644
index 000000000000..afe9e9eb93e5
--- /dev/null
+++ b/virtual/ruby-rdoc/ruby-rdoc-3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ruby-rdoc-3.ebuild,v 1.1 2010/08/18 10:26:21 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ree18"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for bundled and unbundled RDoc"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( dev-ruby/rdoc[ruby_targets_ree18] dev-lang/ruby-enterprise )"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.