summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-12-26 09:29:33 +0000
committerHans de Graaff <graaff@gentoo.org>2013-12-26 09:29:33 +0000
commit7024884f09ecb1fd03ef719fee82ed2291b0441c (patch)
tree9c32cc99ebb3891a3a9d5259a832ae0473d8201b /virtual/ruby-rdoc
parentAdd ruby21. (diff)
downloadgentoo-2-7024884f09ecb1fd03ef719fee82ed2291b0441c.tar.gz
gentoo-2-7024884f09ecb1fd03ef719fee82ed2291b0441c.tar.bz2
gentoo-2-7024884f09ecb1fd03ef719fee82ed2291b0441c.zip
Add ruby21.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'virtual/ruby-rdoc')
-rw-r--r--virtual/ruby-rdoc/ChangeLog7
-rw-r--r--virtual/ruby-rdoc/ruby-rdoc-4.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/virtual/ruby-rdoc/ChangeLog b/virtual/ruby-rdoc/ChangeLog
index 7854939efc55..7312085ef43b 100644
--- a/virtual/ruby-rdoc/ChangeLog
+++ b/virtual/ruby-rdoc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for virtual/ruby-rdoc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ChangeLog,v 1.24 2013/12/20 15:55:48 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ChangeLog,v 1.25 2013/12/26 09:29:33 graaff Exp $
+
+*ruby-rdoc-4 (26 Dec 2013)
+
+ 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-rdoc-4.ebuild:
+ Add ruby21.
20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-rdoc-3.ebuild:
ia64 stable wrt bug #483254
diff --git a/virtual/ruby-rdoc/ruby-rdoc-4.ebuild b/virtual/ruby-rdoc/ruby-rdoc-4.ebuild
new file mode 100644
index 000000000000..35c96bc33061
--- /dev/null
+++ b/virtual/ruby-rdoc/ruby-rdoc-4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ruby-rdoc-4.ebuild,v 1.1 2013/12/26 09:29:33 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby21"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for bundled and unbundled RDoc"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="|| ( dev-ruby/rdoc[ruby_targets_ruby21] )"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.