summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-19 17:59:26 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-19 17:59:26 +0000
commit443fbb642bff4e191e58c982cdc6fe380fd41026 (patch)
tree11d88470aac166334f49d0f478e29aef74f366a5 /virtual
parentUse ${PYTHON_USEDEP} substitution support added to python_gen_cond_dep(). (diff)
downloadgentoo-2-443fbb642bff4e191e58c982cdc6fe380fd41026.tar.gz
gentoo-2-443fbb642bff4e191e58c982cdc6fe380fd41026.tar.bz2
gentoo-2-443fbb642bff4e191e58c982cdc6fe380fd41026.zip
Use ${PYTHON_USEDEP} substitution support added to python_gen_cond_dep().
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'virtual')
-rw-r--r--virtual/python-argparse/ChangeLog5
-rw-r--r--virtual/python-argparse/python-argparse-1.ebuild8
2 files changed, 7 insertions, 6 deletions
diff --git a/virtual/python-argparse/ChangeLog b/virtual/python-argparse/ChangeLog
index 1eb997a6d8d1..d42390b079fa 100644
--- a/virtual/python-argparse/ChangeLog
+++ b/virtual/python-argparse/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for virtual/python-argparse
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/ChangeLog,v 1.18 2014/04/02 19:01:44 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/ChangeLog,v 1.19 2014/04/19 17:59:26 mgorny Exp $
+
+ 19 Apr 2014; Michał Górny <mgorny@gentoo.org> python-argparse-1.ebuild:
+ Use ${PYTHON_USEDEP} substitution support added to python_gen_cond_dep().
02 Apr 2014; Patrick McLean <chutzpah@gentoo.org> python-argparse-1.ebuild:
Add python3.4
diff --git a/virtual/python-argparse/python-argparse-1.ebuild b/virtual/python-argparse/python-argparse-1.ebuild
index 85d879fc6cdd..d65e6b5835fc 100644
--- a/virtual/python-argparse/python-argparse-1.ebuild
+++ b/virtual/python-argparse/python-argparse-1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/python-argparse-1.ebuild,v 1.17 2014/04/02 19:01:44 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/python-argparse-1.ebuild,v 1.18 2014/04/19 17:59:26 mgorny Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy )
inherit python-r1
DESCRIPTION="A virtual for the Python argparse module"
@@ -16,6 +16,4 @@ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86
IUSE=""
RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep \
- "dev-python/argparse[$(python_gen_usedep python2_6)]" \
- python2_6)"
+ $(python_gen_cond_dep 'dev-python/argparse[${PYTHON_USEDEP}]' python2_6)"