summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-05-09 08:05:54 +0000
committerPacho Ramos <pacho@gentoo.org>2015-05-09 08:05:54 +0000
commite04dc259eafe0dd1fce24d0e2d8af8429a8a8577 (patch)
tree6111f4b758b33f54669e4a70bd04f31436d3c4f9 /www-apache/mod_auth_tkt
parentRevision bump to update dependency on ghc to lock to 7.6* (bug #522770). (diff)
downloadgentoo-2-e04dc259eafe0dd1fce24d0e2d8af8429a8a8577.tar.gz
gentoo-2-e04dc259eafe0dd1fce24d0e2d8af8429a8a8577.tar.bz2
gentoo-2-e04dc259eafe0dd1fce24d0e2d8af8429a8a8577.zip
Support apache 2.4 (#532800)
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'www-apache/mod_auth_tkt')
-rw-r--r--www-apache/mod_auth_tkt/ChangeLog11
-rw-r--r--www-apache/mod_auth_tkt/files/mod_auth_tkt-2.1.0-apache-2.4.patch40
-rw-r--r--www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r1.ebuild (renamed from www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0.ebuild)26
3 files changed, 66 insertions, 11 deletions
diff --git a/www-apache/mod_auth_tkt/ChangeLog b/www-apache/mod_auth_tkt/ChangeLog
index 645e5c2b4af0..80e1b6ad6f8d 100644
--- a/www-apache/mod_auth_tkt/ChangeLog
+++ b/www-apache/mod_auth_tkt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apache/mod_auth_tkt
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_tkt/ChangeLog,v 1.6 2012/11/27 19:06:34 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_tkt/ChangeLog,v 1.7 2015/05/09 08:05:54 pacho Exp $
+
+*mod_auth_tkt-2.1.0-r1 (09 May 2015)
+
+ 09 May 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/mod_auth_tkt-2.1.0-apache-2.4.patch, +mod_auth_tkt-2.1.0-r1.ebuild,
+ -mod_auth_tkt-2.1.0.ebuild:
+ Support apache 2.4 (#532800)
27 Nov 2012; Pacho Ramos <pacho@gentoo.org> -mod_auth_tkt-2.0.0_rc2.ebuild,
metadata.xml:
diff --git a/www-apache/mod_auth_tkt/files/mod_auth_tkt-2.1.0-apache-2.4.patch b/www-apache/mod_auth_tkt/files/mod_auth_tkt-2.1.0-apache-2.4.patch
new file mode 100644
index 000000000000..af7cc2475169
--- /dev/null
+++ b/www-apache/mod_auth_tkt/files/mod_auth_tkt-2.1.0-apache-2.4.patch
@@ -0,0 +1,40 @@
+Description: Build fix for apache 2.4
+ Fix for API changes in apache 2.4.
+Author: Ivo De Decker <ivo.dedecker@ugent.be>
+Forwarded: http://sourceforge.net/mailarchive/forum.php?thread_name=20120518111425.GA9186%40ugent.be&forum_name=modauthtkt-users
+Last-Update: 2012-05-17
+
+--- libapache2-mod-auth-tkt-2.1.0.orig/src/mod_auth_tkt.c
++++ libapache2-mod-auth-tkt-2.1.0/src/mod_auth_tkt.c
+@@ -6,6 +6,7 @@
+ #include "http_config.h"
+ #include "http_log.h"
+ #include "http_core.h"
++#include "http_request.h"
+ #include "http_protocol.h"
+ #include "util_md5.h"
+ #include "sha2.h"
+@@ -798,7 +799,11 @@ ticket_digest(request_rec *r, auth_tkt *
+ unsigned char *buf2 = apr_palloc(r->pool, sconf->digest_sz + strlen(secret));
+ int len = 0;
+ char *digest = NULL;
++#if AP_MODULE_MAGIC_AT_LEAST(20111130,0)
++ char *remote_ip = conf->ignore_ip > 0 ? "0.0.0.0" : r->connection->client_ip;
++#else
+ char *remote_ip = conf->ignore_ip > 0 ? "0.0.0.0" : r->connection->remote_ip;
++#endif
+ unsigned long ip;
+ struct in_addr ia;
+ char *d;
+@@ -1575,7 +1580,11 @@ static void
+ auth_tkt_register_hooks (apr_pool_t *p)
+ {
+ ap_hook_post_config(auth_tkt_version, NULL, NULL, APR_HOOK_MIDDLE);
++#if AP_MODULE_MAGIC_AT_LEAST(20080403,1)
++ ap_hook_check_authn(auth_tkt_check, NULL, NULL, APR_HOOK_FIRST, AP_AUTH_INTERNAL_PER_CONF);
++#else
+ ap_hook_check_user_id(auth_tkt_check, NULL, NULL, APR_HOOK_FIRST);
++#endif
+ }
+
+ /* Declare and populate the main module data structure */
diff --git a/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0.ebuild b/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r1.ebuild
index 477c6dada1c9..e75d420b538f 100644
--- a/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0.ebuild
+++ b/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0.ebuild,v 1.1 2009/09/17 07:45:27 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r1.ebuild,v 1.1 2015/05/09 08:05:54 pacho Exp $
-# test suite is completely broken
-RESTRICT="test"
-
-inherit apache-module
+EAPI=5
+inherit apache-module eutils
DESCRIPTION="Apache module for cookie based authentication"
HOMEPAGE="http://www.openfusion.com.au/labs/mod_auth_tkt/"
@@ -24,11 +22,21 @@ APACHE2_MOD_DEFINE="AUTH_TKT"
DOCFILES="README"
-need_apache2_2
+# test suite is completely broken
+RESTRICT="test"
+
+need_apache2
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-apache-2.4.patch
+}
+
+src_configure() {
+ ./configure --apachever=2.2 --apxs=${APXS}
+}
src_compile() {
- ./configure --apachever=2.2 --apxs=${APXS} || die "econf failed"
- emake || die "emake failed"
+ emake
}
src_install() {