summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-09-14 13:25:55 +0000
committerStuart Herbert <stuart@gentoo.org>2004-09-14 13:25:55 +0000
commitc360f19c9d308ed2672c89c5592d01e035b0d24e (patch)
tree761bfceec3ead6c2ebcd159dc594b48b47eeed86 /www-apache/mod_chroot
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-c360f19c9d308ed2672c89c5592d01e035b0d24e.tar.gz
gentoo-2-c360f19c9d308ed2672c89c5592d01e035b0d24e.tar.bz2
gentoo-2-c360f19c9d308ed2672c89c5592d01e035b0d24e.zip
Initial import
Diffstat (limited to 'www-apache/mod_chroot')
-rw-r--r--www-apache/mod_chroot/ChangeLog11
-rw-r--r--www-apache/mod_chroot/Manifest5
-rw-r--r--www-apache/mod_chroot/files/15_mod_chroot.conf4
-rw-r--r--www-apache/mod_chroot/files/digest-mod_chroot-0.21
-rw-r--r--www-apache/mod_chroot/metadata.xml5
-rw-r--r--www-apache/mod_chroot/mod_chroot-0.2.ebuild45
6 files changed, 71 insertions, 0 deletions
diff --git a/www-apache/mod_chroot/ChangeLog b/www-apache/mod_chroot/ChangeLog
new file mode 100644
index 000000000000..5afce0a0ea0e
--- /dev/null
+++ b/www-apache/mod_chroot/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for www-apache/chroot
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_chroot/ChangeLog,v 1.1 2004/09/14 13:25:55 stuart Exp $
+
+*mod_chroot-0.2 (14 Sep 2004)
+
+ 14 Sep 2004; Stuart Herbert <stuart@gentoo.org> +metadata.xml,
+ +mod_chroot-0.2.ebuild:
+ Initial import; see bug #55707; thanks to contraconstantium@mad.scientist.com
+ and magnet@suidzer0.org
+
diff --git a/www-apache/mod_chroot/Manifest b/www-apache/mod_chroot/Manifest
new file mode 100644
index 000000000000..750cfd07eadd
--- /dev/null
+++ b/www-apache/mod_chroot/Manifest
@@ -0,0 +1,5 @@
+MD5 2478e22aef5931739c7f9a4ece707633 mod_chroot-0.2.ebuild 1332
+MD5 d2da0e45d7e39184d1cb7abbe3879086 metadata.xml 159
+MD5 cbbd83fa06ee97b2889f574517dff234 ChangeLog 118
+MD5 58daeab364d19de74ce44e560e77d075 files/15_mod_chroot.conf 87
+MD5 2f8c0ff8330470476ab8fd9bd4a6c0aa files/digest-mod_chroot-0.2 65
diff --git a/www-apache/mod_chroot/files/15_mod_chroot.conf b/www-apache/mod_chroot/files/15_mod_chroot.conf
new file mode 100644
index 000000000000..42551be9e147
--- /dev/null
+++ b/www-apache/mod_chroot/files/15_mod_chroot.conf
@@ -0,0 +1,4 @@
+<IfModule mod_chroot.c>
+ # change this to the web root
+ ChrootDir /var/www
+</IfModule>
diff --git a/www-apache/mod_chroot/files/digest-mod_chroot-0.2 b/www-apache/mod_chroot/files/digest-mod_chroot-0.2
new file mode 100644
index 000000000000..a7751e3c8b24
--- /dev/null
+++ b/www-apache/mod_chroot/files/digest-mod_chroot-0.2
@@ -0,0 +1 @@
+MD5 85211cd8cafcfe64258e02291ea6439e mod_chroot-0.2.tar.gz 10540
diff --git a/www-apache/mod_chroot/metadata.xml b/www-apache/mod_chroot/metadata.xml
new file mode 100644
index 000000000000..c054a8cd9b61
--- /dev/null
+++ b/www-apache/mod_chroot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>apache</herd>
+</pkgmetadata>
diff --git a/www-apache/mod_chroot/mod_chroot-0.2.ebuild b/www-apache/mod_chroot/mod_chroot-0.2.ebuild
new file mode 100644
index 000000000000..69731ab435f8
--- /dev/null
+++ b/www-apache/mod_chroot/mod_chroot-0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_chroot/mod_chroot-0.2.ebuild,v 1.1 2004/09/14 13:25:55 stuart Exp $
+
+
+DESCRIPTION="chroot apache 1.x, the easy way"
+HOMEPAGE="http://core.segfault.pl/~hobbit/mod_chroot/"
+SRC_URI="http://core.segfault.pl/~hobbit/mod_chroot/dist/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="=net-www/apache-1*"
+
+src_unpack() {
+ unpack ${A} || die; cd ${S} || die
+}
+
+src_compile() {
+ apxs -c ${S}/mod_chroot.c -o ${S}/mod_chroot.so || die "Unable to compile mod_chroot.so ."
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe ${PN}.so || die "Cannot install mod_chroot.so"
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/15_${PN}.conf
+ dodoc CAVEATS ChangeLog EAPI INSTALL LICENSE README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/mod_chroot.so mod_chroot.c chroot_module \
+ define=CHROOT addconf=conf/addon-modules/15_mod_chroot.conf
+}