summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-10-30 20:25:29 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-10-30 20:25:29 +0000
commit18f5c82dfaea2701499f60477807570104950b41 (patch)
tree49bb84005c84d33e0bade9f2da3aef1c2e651ce3 /www-apache/mod_perl/files
parentReplace "echo -n" with "echo", bash removes trailing newline in subshells any... (diff)
downloadgentoo-2-18f5c82dfaea2701499f60477807570104950b41.tar.gz
gentoo-2-18f5c82dfaea2701499f60477807570104950b41.tar.bz2
gentoo-2-18f5c82dfaea2701499f60477807570104950b41.zip
Cleanup
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'www-apache/mod_perl/files')
-rw-r--r--www-apache/mod_perl/files/CVE-2009-0796.patch47
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch78
2 files changed, 0 insertions, 125 deletions
diff --git a/www-apache/mod_perl/files/CVE-2009-0796.patch b/www-apache/mod_perl/files/CVE-2009-0796.patch
deleted file mode 100644
index c13db0de155a..000000000000
--- a/www-apache/mod_perl/files/CVE-2009-0796.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- perl/modperl/trunk/lib/Apache2/Status.pm 2007/12/31 08:05:11 607697
-+++ perl/modperl/trunk/lib/Apache2/Status.pm 2009/04/01 15:39:56 760926
-@@ -29,7 +29,7 @@
-
- use Apache2::Const -compile => qw(OK);
-
--$Apache2::Status::VERSION = '4.00'; # mod_perl 2.0
-+$Apache2::Status::VERSION = '4.01'; # mod_perl 2.0
-
- use constant IS_WIN32 => ($^O eq "MSWin32");
-
-@@ -126,7 +126,7 @@
- $r->print(symdump($r, $qs));
- }
- else {
-- my $uri = $r->uri;
-+ my $uri = $r->location;
- $r->print('<p>');
- $r->print(
- map { qq[<a href="$uri?$_">$status{$_}</a><br />\n] } sort { lc $a cmp lc $b } keys %status
-@@ -198,7 +198,7 @@
- sub status_inc {
- my ($r) = @_;
-
-- my $uri = $r->uri;
-+ my $uri = $r->location;
- my @retval = (
- '<table border="1">',
- "<tr>",
-@@ -289,7 +289,7 @@
- my ($r) = @_;
-
- local $_;
-- my $uri = $r->uri;
-+ my $uri = $r->location;
- my $cache = __PACKAGE__->registry_cache;
-
- my @retval = "<h2>Compiled registry scripts grouped by their handler</h2>";
-@@ -765,7 +765,7 @@
- my ($self, $package, $r) = @_;
-
- my @m = qw(<table>);
-- my $uri = $r->uri;
-+ my $uri = $r->location;
- my $is_main = $package eq "main";
-
- my $do_dump = has($r, "dumper");
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch b/www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch
deleted file mode 100644
index 1c7828b48949..000000000000
--- a/www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff --git a/Makefile.PL b/Makefile.PL
-index ca80816..4196f8e 100644
---- a/Makefile.PL
-+++ b/Makefile.PL
-@@ -24,7 +24,7 @@ BEGIN {
-
- }
-
--use lib qw(lib Apache-Test/lib);
-+use lib qw(lib);
-
- use Config;
- use File::Spec::Functions;
-@@ -116,16 +116,6 @@ sub get_DEFINE {
- }
-
- sub configure {
--
-- # mod_perl test suite relies on having Apache-Test bundled with
-- # the mod_perl source, since any pre-installed version may not do
-- # the right thing
-- unless (-d "Apache-Test") {
-- error "Can't find a sub-directory Apache-Test. " .
-- "Make sure that you are using a complete source distribution";
-- exit 1;
-- }
--
- set_modperl_version();
-
- if ($old_modperl_version) {
-@@ -794,47 +784,11 @@ run_tests : test_clean
- run_subtests ::
- $(MAKE) -C ModPerl-Registry test
-
--run_subtests ::
-- $(MAKE) -C Apache-Reload test
--
--run_subtests ::
-- $(MAKE) -C Apache-SizeLimit test
--
- test :: pure_all run_tests test_clean
- EOF
-
- }
-
--sub MY::postamble {
-- my $self = shift;
--
-- my $string = $self->ModPerl::BuildMM::MY::postamble;
--
-- $string .= <<'EOF';
--mydist : Apache-Test/META.yml mod_perl.spec manifest tardist
--
--rpm: dist
-- @[ -d $(PWD)/rpm ] || mkdir $(PWD)/rpm
-- rpmbuild -ta --define "_rpmdir $(PWD)/rpm" \
-- --define "_srcrpmdir $(PWD)/rpm" \
-- $(DISTVNAME).tar.gz
-- @mv $(PWD)/rpm/*/*.rpm $(PWD)/rpm/
-- @rm -rf $(PWD)/rpm/*/
--
--mod_perl.spec: build/make_rpm_spec
-- $(PERL) build/make_rpm_spec
--
--Apache-Test/META.yml:
-- cd Apache-Test && make metafile
--
--tag :
-- svn copy https://svn.apache.org/repos/asf/perl/modperl/branches/release/$(VERSION_SYM) https://svn.apache.org/repos/asf/perl/modperl/tags/$(VERSION_SYM)
-- svn copy https://svn.apache.org/repos/asf/perl/modperl/docs/trunk https://svn.apache.org/repos/asf/perl/modperl/docs/tags/$(VERSION_SYM)
--EOF
--
-- return $string;
--}
--
- # this is a workaround so that ModPerl::MM will move MY::constants
- # away, and Apache-Test/Makefile.PL which has its own MY::constants
- # won't get complaints on MY::constants redefined