summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-07-22 15:08:05 +0000
committerMike Frysinger <vapier@gentoo.org>2015-07-22 15:08:05 +0000
commit961d735e7a68ce0199b3412335ca53cc4ebd1698 (patch)
treef82cd6a1b4bae6c28158c1a1fe828a072cf01a50 /www-apache
parentia64 stable wrt bug #540536 (diff)
downloadgentoo-2-961d735e7a68ce0199b3412335ca53cc4ebd1698.tar.gz
gentoo-2-961d735e7a68ce0199b3412335ca53cc4ebd1698.tar.bz2
gentoo-2-961d735e7a68ce0199b3412335ca53cc4ebd1698.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/ChangeLog7
-rw-r--r--www-apache/mod_h2/mod_h2-0.8.2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/www-apache/mod_h2/ChangeLog b/www-apache/mod_h2/ChangeLog
index da86560dd49b..3559130f3c79 100644
--- a/www-apache/mod_h2/ChangeLog
+++ b/www-apache/mod_h2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_h2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/ChangeLog,v 1.12 2015/07/21 16:13:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/ChangeLog,v 1.13 2015/07/22 15:08:05 vapier Exp $
+
+*mod_h2-0.8.2 (22 Jul 2015)
+
+ 22 Jul 2015; Mike Frysinger <vapier@gentoo.org> +mod_h2-0.8.2.ebuild:
+ Version bump.
*mod_h2-0.8.1 (21 Jul 2015)
diff --git a/www-apache/mod_h2/mod_h2-0.8.2.ebuild b/www-apache/mod_h2/mod_h2-0.8.2.ebuild
new file mode 100644
index 000000000000..8b95ebcf2e78
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-0.8.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/mod_h2-0.8.2.ebuild,v 1.1 2015/07/22 15:08:05 vapier Exp $
+
+EAPI="5"
+
+inherit apache-module
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ ssl? ( www-servers/apache[alpn] )"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_configure() {
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --disable-werror \
+ --disable-sandbox
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_h2.conf" "75_mod_h2.conf"
+}