summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2005-10-03 05:06:28 +0000
committerLance Albertson <ramereth@gentoo.org>2005-10-03 05:06:28 +0000
commit159d96c176268dcfd73429b7c1fa7b4a765fcc5c (patch)
tree99226f19d3f684591e5acc05ba047508120501fb /www-apps/viewcvs/viewcvs-1.0_pre20050929.ebuild
parentPatch fix. (diff)
downloadgentoo-2-159d96c176268dcfd73429b7c1fa7b4a765fcc5c.tar.gz
gentoo-2-159d96c176268dcfd73429b7c1fa7b4a765fcc5c.tar.bz2
gentoo-2-159d96c176268dcfd73429b7c1fa7b4a765fcc5c.zip
Marked 0.9.3 stable on x86, New CVS snapshot with numerous fixes (see changelog)
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-apps/viewcvs/viewcvs-1.0_pre20050929.ebuild')
-rw-r--r--www-apps/viewcvs/viewcvs-1.0_pre20050929.ebuild115
1 files changed, 115 insertions, 0 deletions
diff --git a/www-apps/viewcvs/viewcvs-1.0_pre20050929.ebuild b/www-apps/viewcvs/viewcvs-1.0_pre20050929.ebuild
new file mode 100644
index 000000000000..d3c74e7f43c2
--- /dev/null
+++ b/www-apps/viewcvs/viewcvs-1.0_pre20050929.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewcvs/viewcvs-1.0_pre20050929.ebuild,v 1.1 2005/10/03 05:06:28 ramereth Exp $
+
+inherit webapp depend.apache eutils
+
+PDATE=${PV/1.0_pre/}
+DESCRIPTION="Viewcvs, a web interface to cvs and subversion"
+HOMEPAGE="http://viewcvs.sourceforge.net/"
+SRC_URI="mirror://gentoo/${PN}-${PDATE}.tar.bz2"
+
+LICENSE="viewcvs"
+KEYWORDS="~sparc ~x86"
+IUSE="cvsgraph enscript mod_python mysql standalone"
+
+want_apache
+
+RDEPEND="|| ( >=dev-util/cvs-1.11
+ dev-util/subversion )
+ dev-lang/python
+ >=app-text/rcs-5.7
+ sys-apps/diffutils
+ cvsgraph? ( dev-util/cvsgraph )
+ enscript? ( app-text/enscript )
+ apache2? ( mod_python? ( dev-python/mod_python ) )
+ mysql? ( dev-db/mysql
+ dev-python/mysql-python )
+ !apache? ( !apache2? ( www-servers/lighttpd ) )"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if has_version dev-util/subversion && ! built_with_use dev-util/subversion python ; then
+ eerror "Your subversion has been built without python bindings"
+ eerror "If you want subversion to work with viewcvs, please"
+ eerror "enable the 'python' useflag"
+ die "pkg_setup failed"
+ fi
+ if use mod_python && ! use apache2 ; then
+ eerror "mod_python requires at least apache2"
+ die "pkg_setup failed"
+ fi
+ if use standalone && ! built_with_use dev-lang/python tcltk ; then
+ eerror "Standalone client requires tkinter, please enable the"
+ eerror "tcltk useflag for python and recompile"
+ die "pkg_setup failed"
+ fi
+ webapp_pkg_setup
+}
+
+src_compile() {
+ sed -i -e "s:1.0-dev:${PV}:" lib/viewcvs.py
+}
+
+src_install() {
+ webapp_src_preinst
+ dodir ${MY_CGIBINDIR}/${PN} ${MY_HOSTROOTDIR}/${PN}
+
+ exeinto ${MY_CGIBINDIR}/${PN}
+ doexe www/cgi/viewcvs.cgi
+
+ if use mysql ; then
+ exeinto ${MY_CGIBINDIR}/${PN}
+ doexe www/cgi/query.cgi
+ fi
+
+ if use mod_python && use apache2 ; then
+ exeinto ${MY_HTDOCSDIR}
+ doexe www/mod_python/viewcvs.py www/mod_python/query.py
+ if use mysql ; then
+ exeinto ${MY_HTDOCSDIR}
+ doexe www/mod_python/query.py
+ fi
+ insinto ${MY_HTDOCSDIR}
+ doins www/mod_python/.htaccess
+ fi
+
+ cp -r lib/ ${D}/${MY_HOSTROOTDIR}/${PN}/
+ cp -r templates/ ${D}/${MY_HOSTROOTDIR}/${PN}/
+ cp -r tools/ ${D}/${MY_HOSTROOTDIR}/${PN}/
+ cp -r tests/ ${D}/${MY_HOSTROOTDIR}/${PN}/
+ insinto ${MY_HOSTROOTDIR}/${PN}
+ newins viewcvs.conf.dist viewcvs.conf
+ newins cvsgraph.conf.dist cvsgraph.conf
+
+ dosym /usr/share/doc/${PF}/html ${MY_HTDOCSDIR}/doc
+ dodoc INSTALL TODO CHANGES README
+ dohtml -r website/*
+
+ if use standalone ; then
+ exeinto /usr/sbin
+ newexe standalone.py viewcvs-standalone
+ fi
+
+ webapp_configfile ${MY_HOSTROOTDIR}/${PN}/viewcvs.conf
+ webapp_configfile ${MY_HOSTROOTDIR}/${PN}/cvsgraph.conf
+ webapp_postinst_txt en ${FILESDIR}/postinstall-new-en.txt
+ webapp_hook_script ${FILESDIR}/reconfig
+
+ if use mysql && has_version "=dev-db/mysql-4.0*" ; then
+ webapp_sqlscript mysql ${FILESDIR}/viewcvs-mysql-4.0.sql
+ elif use mysql && has_version "=dev-db/mysql-4.1*" ; then
+ webapp_sqlscript mysql ${FILESDIR}/viewcvs-mysql-4.1.sql
+ fi
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ if use standalone ; then
+ einfo "The standalone script is called viewcvs-standalone"
+ einfo "instead of standalone.py for clarity sake"
+ fi
+}