summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2014-11-28 07:55:26 +0000
committerAlfredo Tupone <tupone@gentoo.org>2014-11-28 07:55:26 +0000
commit0f2569b0af9cf2e50009aa1091ad1cbea7a97609 (patch)
treed63ed969cc1d88f26f5d3aa0bf88b72d1dd150ea /www-apps
parentBump (diff)
downloadgentoo-2-0f2569b0af9cf2e50009aa1091ad1cbea7a97609.tar.gz
gentoo-2-0f2569b0af9cf2e50009aa1091ad1cbea7a97609.tar.bz2
gentoo-2-0f2569b0af9cf2e50009aa1091ad1cbea7a97609.zip
Version bump to 2.2.6 needed by frontend 2.2.7
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/liquid_feedback_core/ChangeLog9
-rw-r--r--www-apps/liquid_feedback_core/files/liquid_feedback_core-2.2.6-gentoo.patch24
-rw-r--r--www-apps/liquid_feedback_core/liquid_feedback_core-2.2.6.ebuild48
3 files changed, 80 insertions, 1 deletions
diff --git a/www-apps/liquid_feedback_core/ChangeLog b/www-apps/liquid_feedback_core/ChangeLog
index 6e2011823d95..6d8b78fc8b10 100644
--- a/www-apps/liquid_feedback_core/ChangeLog
+++ b/www-apps/liquid_feedback_core/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/liquid_feedback_core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/liquid_feedback_core/ChangeLog,v 1.2 2014/11/03 14:04:37 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/liquid_feedback_core/ChangeLog,v 1.3 2014/11/28 07:55:26 tupone Exp $
+
+*liquid_feedback_core-2.2.6 (28 Nov 2014)
+
+ 28 Nov 2014; Alfredo Tupone <tupone@gentoo.org>
+ +liquid_feedback_core-2.2.6.ebuild,
+ +files/liquid_feedback_core-2.2.6-gentoo.patch:
+ Version bump to 2.2.6 needed by frontend 2.2.7
03 Nov 2014; Aaron W. Swenson <titanofold@gentoo.org>
liquid_feedback_core-2.2.3.ebuild:
diff --git a/www-apps/liquid_feedback_core/files/liquid_feedback_core-2.2.6-gentoo.patch b/www-apps/liquid_feedback_core/files/liquid_feedback_core-2.2.6-gentoo.patch
new file mode 100644
index 000000000000..f4d555121745
--- /dev/null
+++ b/www-apps/liquid_feedback_core/files/liquid_feedback_core-2.2.6-gentoo.patch
@@ -0,0 +1,24 @@
+--- Makefile.old 2013-03-22 15:26:23.340764442 +0100
++++ Makefile 2013-03-22 15:36:50.838733773 +0100
+@@ -1,16 +1,10 @@
+ all:: lf_update lf_update_suggestion_order
+
+-lf_update: lf_update.c
+- cc -Wall -O2 \
+- -I "`pg_config --includedir`" \
+- -L "`pg_config --libdir`" \
+- -o lf_update lf_update.c -lpq
+-
+-lf_update_suggestion_order: lf_update_suggestion_order.c
+- cc -Wall -O2 \
+- -I "`pg_config --includedir`" \
+- -L "`pg_config --libdir`" \
+- -o lf_update_suggestion_order lf_update_suggestion_order.c -lpq
++CPPFLAGS=-I `pg_config --includedir`
++LDFLAGS=-L `pg_config --libdir`
++CFLAGS=-Wall -O2
++CC=cc
++LDLIBS=-lpq
+
+ clean::
+ rm -f lf_update lf_update_suggestion_order
diff --git a/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.6.ebuild b/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.6.ebuild
new file mode 100644
index 000000000000..b23af40a04a6
--- /dev/null
+++ b/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.6.ebuild,v 1.1 2014/11/28 07:55:26 tupone Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Internet platforms for proposition development and decision making"
+HOMEPAGE="http://www.public-software-group.org/liquid_feedback"
+SRC_URI="http://www.public-software-group.org/pub/projects/liquid_feedback/backend/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="HPND CC-BY-2.5"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="virtual/postgresql"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CPPFLAGS="-I $(pg_config --includedir)" \
+ LDFLAGS="${LDFLAGS} -L $(pg_config --libdir)" \
+ LDLIBS="-lpq $(pg_config --libs)"
+}
+
+src_install() {
+ dobin lf_update lf_update_suggestion_order lf_export
+ insinto /usr/share/${PN}
+ doins -r {core,init,demo,test}.sql update
+ dodoc README "${FILESDIR}"/postinstall-en.txt
+}
+
+pkg_postinst() {
+ elog "If you just upgraded, remember to update database schema"
+ elog "with the scripts in /usr/share/${PN}/update"
+}