summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-04-23 18:05:45 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-04-23 18:05:45 +0000
commit7fc7a153e2f90cf3c8e969294813cc18dc1bace5 (patch)
treecfc1a3738f2fafa13c93cd14d7e81b86a76ad332 /www-apps
parentppc stable, bug #130960 (diff)
downloadgentoo-2-7fc7a153e2f90cf3c8e969294813cc18dc1bace5.tar.gz
gentoo-2-7fc7a153e2f90cf3c8e969294813cc18dc1bace5.tar.bz2
gentoo-2-7fc7a153e2f90cf3c8e969294813cc18dc1bace5.zip
Version bump
(Portage version: 2.1_pre9-r1)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/bugzilla/ChangeLog12
-rw-r--r--www-apps/bugzilla/bugzilla-2.20.2.ebuild68
-rw-r--r--www-apps/bugzilla/bugzilla-2.22.ebuild70
-rw-r--r--www-apps/bugzilla/files/2.22/apache.htaccess3
-rw-r--r--www-apps/bugzilla/files/2.22/bugzilla.cron.daily5
-rw-r--r--www-apps/bugzilla/files/2.22/bugzilla.cron.tab1
-rw-r--r--www-apps/bugzilla/files/2.22/postinstall-en.txt16
-rw-r--r--www-apps/bugzilla/files/2.22/reconfig19
-rw-r--r--www-apps/bugzilla/files/digest-bugzilla-2.18.52
-rw-r--r--www-apps/bugzilla/files/digest-bugzilla-2.20.23
-rw-r--r--www-apps/bugzilla/files/digest-bugzilla-2.223
11 files changed, 201 insertions, 1 deletions
diff --git a/www-apps/bugzilla/ChangeLog b/www-apps/bugzilla/ChangeLog
index 4567ee28a4c6..bcecc669ac60 100644
--- a/www-apps/bugzilla/ChangeLog
+++ b/www-apps/bugzilla/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for www-apps/bugzilla
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.60 2006/04/04 21:08:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.61 2006/04/23 18:05:44 rl03 Exp $
+
+*bugzilla-2.22 (23 Apr 2006)
+*bugzilla-2.20.2 (23 Apr 2006)
+
+ 23 Apr 2006; Renat Lumpau <rl03@gentoo.org>
+ +files/2.22/bugzilla.cron.daily, +files/2.22/bugzilla.cron.tab,
+ +files/2.22/apache.htaccess, +files/2.22/postinstall-en.txt,
+ +files/2.22/reconfig, -bugzilla-2.20.1.ebuild, +bugzilla-2.20.2.ebuild,
+ +bugzilla-2.22.ebuild:
+ Version bump
04 Apr 2006; Aron Griffis <agriffis@gentoo.org> bugzilla-2.18.5.ebuild:
Mark 2.18.5 stable on ia64
diff --git a/www-apps/bugzilla/bugzilla-2.20.2.ebuild b/www-apps/bugzilla/bugzilla-2.20.2.ebuild
new file mode 100644
index 000000000000..2ff2fc75b0aa
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-2.20.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-2.20.2.ebuild,v 1.1 2006/04/23 18:05:44 rl03 Exp $
+
+inherit webapp
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1 NPL-1.1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="apache2 graphviz mysql postgres"
+
+RDEPEND="
+ >=dev-lang/perl-5.6.1
+ postgres? ( >=dev-db/postgresql-7.3 >=dev-perl/DBD-Pg-1.43 )
+ mysql? ( >=dev-db/mysql-3.23.41 <=dev-perl/DBD-mysql-3.0002 )
+ apache2? ( >=net-www/apache-2.0 )
+ !apache2? ( =net-www/apache-1* )
+ graphviz? ( media-gfx/graphviz )
+ >=dev-perl/AppConfig-1.52
+ >=virtual/perl-CGI-2.93
+ >=dev-perl/TimeDate-1.16
+ >=dev-perl/DBI-1.38
+ >=virtual/perl-File-Spec-0.84
+ virtual/perl-File-Temp
+ >=dev-perl/Template-Toolkit-2.08
+ >=dev-perl/Text-Tabs+Wrap-2001.0131
+ >=dev-perl/MailTools-1.67
+ virtual/perl-Storable
+ >=dev-perl/GD-1.20
+ >=dev-perl/Chart-2.3
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil
+ dev-perl/XML-Parser
+ >=dev-perl/PatchReader-0.9.4
+ dev-perl/MIME-tools
+ dev-perl/perl-ldap
+ virtual/mta
+"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # remove CVS directories
+ find . -type d -name 'CVS' -print | xargs rm -rf
+}
+
+src_install () {
+ webapp_src_preinst
+
+ cp -r ${S}/* ${D}/${MY_HTDOCSDIR} || die
+ for file in `find -type d -printf "%p/* "`; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ cp ${FILESDIR}/2.20/apache.htaccess ${D}/${MY_HTDOCSDIR}/.htaccess
+
+ local FILE="bugzilla.cron.daily bugzilla.cron.tab"
+ cd ${FILESDIR}/2.20
+ cp ${FILE} ${D}/${MY_HTDOCSDIR}
+
+ webapp_hook_script ${FILESDIR}/2.20/reconfig
+ webapp_postinst_txt en ${FILESDIR}/2.20/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/bugzilla/bugzilla-2.22.ebuild b/www-apps/bugzilla/bugzilla-2.22.ebuild
new file mode 100644
index 000000000000..5cbc0d8e8d4a
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-2.22.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-2.22.ebuild,v 1.1 2006/04/23 18:05:44 rl03 Exp $
+
+inherit webapp
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1 NPL-1.1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="apache2 extras graphviz mysql postgres"
+
+RDEPEND="
+ >=dev-lang/perl-5.6.1
+ postgres? ( >=dev-db/postgresql-7.3 >=dev-perl/DBD-Pg-1.45 )
+ mysql? ( >=dev-db/mysql-4.0.14 <=dev-perl/DBD-mysql-3.0002 )
+ apache2? ( >=net-www/apache-2.0 )
+ !apache2? ( =net-www/apache-1* )
+ graphviz? ( media-gfx/graphviz )
+ >=dev-perl/AppConfig-1.52
+ >=virtual/perl-CGI-2.93
+ >=dev-perl/TimeDate-1.16
+ >=dev-perl/DBI-1.38
+ >=virtual/perl-File-Spec-0.84
+ virtual/perl-File-Temp
+ >=dev-perl/Template-Toolkit-2.08
+ >=dev-perl/Text-Tabs+Wrap-2001.0131
+ >=dev-perl/MailTools-1.67
+ >=virtual/perl-MIME-Base64-3.01
+ dev-perl/MIME-tools
+ virtual/perl-Storable
+
+ !ppc64? ( extras? (
+ >=dev-perl/Chart-2.3
+ >=dev-perl/GD-1.20
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil
+ dev-perl/perl-ldap
+ >=dev-perl/PatchReader-0.9.4
+ dev-perl/XML-Twig ) )
+"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # remove CVS directories
+ find . -type d -name 'CVS' -print | xargs rm -rf
+}
+
+src_install () {
+ webapp_src_preinst
+
+ cp -r ${S}/* ${D}/${MY_HTDOCSDIR} || die
+ for file in `find -type d -printf "%p/* "`; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ cp ${FILESDIR}/2.22/apache.htaccess ${D}/${MY_HTDOCSDIR}/.htaccess
+
+ local FILE="bugzilla.cron.daily bugzilla.cron.tab"
+ cd ${FILESDIR}/2.22
+ cp ${FILE} ${D}/${MY_HTDOCSDIR}
+
+ webapp_hook_script ${FILESDIR}/2.22/reconfig
+ webapp_postinst_txt en ${FILESDIR}/2.22/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/bugzilla/files/2.22/apache.htaccess b/www-apps/bugzilla/files/2.22/apache.htaccess
new file mode 100644
index 000000000000..eb747223ccec
--- /dev/null
+++ b/www-apps/bugzilla/files/2.22/apache.htaccess
@@ -0,0 +1,3 @@
+AddHandler cgi-script .cgi
+Options +Indexes +ExecCGI +FollowSymLinks
+DirectoryIndex index.cgi
diff --git a/www-apps/bugzilla/files/2.22/bugzilla.cron.daily b/www-apps/bugzilla/files/2.22/bugzilla.cron.daily
new file mode 100644
index 000000000000..e3e86589891d
--- /dev/null
+++ b/www-apps/bugzilla/files/2.22/bugzilla.cron.daily
@@ -0,0 +1,5 @@
+#!/bin/sh
+cd /var/www/bugzilla/
+./collectstats.pl
+./whineatnews.pl
+echo "*** Bugzilla nighlty flush has done! ***"
diff --git a/www-apps/bugzilla/files/2.22/bugzilla.cron.tab b/www-apps/bugzilla/files/2.22/bugzilla.cron.tab
new file mode 100644
index 000000000000..0ac2ef6d65a6
--- /dev/null
+++ b/www-apps/bugzilla/files/2.22/bugzilla.cron.tab
@@ -0,0 +1 @@
+0 0 * * * /var/www/bugzilla/bugzilla.cron.daily
diff --git a/www-apps/bugzilla/files/2.22/postinstall-en.txt b/www-apps/bugzilla/files/2.22/postinstall-en.txt
new file mode 100644
index 000000000000..9e7a6225d186
--- /dev/null
+++ b/www-apps/bugzilla/files/2.22/postinstall-en.txt
@@ -0,0 +1,16 @@
+0. Bugzilla has been installed into ${MY_INSTALLDIR}
+
+1. To finish the installation, please read
+ http://www.bugzilla.org/docs/2.22/html/installation.html
+ You will need to run ${MY_INSTALLDIR}/checksetup.pl
+
+ IMPORTANT: If you have customized the values in your Status/Resolution
+ field, you must edit checksetup.pl BEFORE YOU RUN IT. Please see the
+ Release Notes for more details.
+
+2. Please read the Release Notes, especially if you are upgrading:
+ http://www.bugzilla.org/releases/2.22/release-notes.html
+
+3. Please note that Apache2 sets AllowOverride None by default. You may have
+ to edit it to process the .htaccess file provided by Bugzilla. Please see
+ http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride for more info.
diff --git a/www-apps/bugzilla/files/2.22/reconfig b/www-apps/bugzilla/files/2.22/reconfig
new file mode 100644
index 000000000000..71b0acea2585
--- /dev/null
+++ b/www-apps/bugzilla/files/2.22/reconfig
@@ -0,0 +1,19 @@
+#!/bin/bash
+
+FILE="bugzilla.cron.daily bugzilla.cron.tab"
+
+function die ()
+{
+ echo
+ echo "***"
+ echo "*** Fatal error: $*"
+ echo "***"
+ exit 1
+}
+
+if [ $1 = "install" ]; then
+ cd "${MY_INSTALLDIR}" || die "Cannot find install dir ${MY_INSTALLDIR}"
+ sed -e "s|/var/www/bugzilla|${MY_INSTALLDIR}|g" -i ${FILE} || die "sed failed"
+else
+ echo "done."
+fi
diff --git a/www-apps/bugzilla/files/digest-bugzilla-2.18.5 b/www-apps/bugzilla/files/digest-bugzilla-2.18.5
index 7c00f08e2f28..0c7d78a94264 100644
--- a/www-apps/bugzilla/files/digest-bugzilla-2.18.5
+++ b/www-apps/bugzilla/files/digest-bugzilla-2.18.5
@@ -1 +1,3 @@
MD5 5df6fac49f72bc8efb06c178b492cf39 bugzilla-2.18.5.tar.gz 1662727
+RMD160 8832c6529fb806be6f9f4873a595933471f287d2 bugzilla-2.18.5.tar.gz 1662727
+SHA256 03ddc714913b6992187e42be578412707ae231c437d20924b6bb7e62086b669f bugzilla-2.18.5.tar.gz 1662727
diff --git a/www-apps/bugzilla/files/digest-bugzilla-2.20.2 b/www-apps/bugzilla/files/digest-bugzilla-2.20.2
new file mode 100644
index 000000000000..6fdc1bdfc8bb
--- /dev/null
+++ b/www-apps/bugzilla/files/digest-bugzilla-2.20.2
@@ -0,0 +1,3 @@
+MD5 dcbac4b5a476c8042d534bbd7d3008fb bugzilla-2.20.2.tar.gz 1940455
+RMD160 aaa43b7c80225f1f645d11c837ae891f0d1beb2f bugzilla-2.20.2.tar.gz 1940455
+SHA256 2c42bf4b007d5dbd1617e50cb31ea1d12962a3bb7a58d7fdf89a5df5255c19cf bugzilla-2.20.2.tar.gz 1940455
diff --git a/www-apps/bugzilla/files/digest-bugzilla-2.22 b/www-apps/bugzilla/files/digest-bugzilla-2.22
new file mode 100644
index 000000000000..b6d07117556e
--- /dev/null
+++ b/www-apps/bugzilla/files/digest-bugzilla-2.22
@@ -0,0 +1,3 @@
+MD5 bbf2f1ec5607978d39855df104231973 bugzilla-2.22.tar.gz 1956898
+RMD160 2f9e5573e15d3ddcc4b997ac3a645d79585f9ea7 bugzilla-2.22.tar.gz 1956898
+SHA256 9d7e2144cd8499430c802ef5267dd2237aaec401546e5b9476db4f9ca19ebd4d bugzilla-2.22.tar.gz 1956898