summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2011-03-12 13:15:55 +0000
committerChristian Faulhammer <fauli@gentoo.org>2011-03-12 13:15:55 +0000
commitfb8c575e32f17b821f0090d40899bdc505bdb2ea (patch)
treeab883144ab2e4c412efd6230e46eb20f6f55082b /www-apps
parentx86 stable per bug 356255 (diff)
downloadgentoo-2-fb8c575e32f17b821f0090d40899bdc505bdb2ea.tar.gz
gentoo-2-fb8c575e32f17b821f0090d40899bdc505bdb2ea.tar.bz2
gentoo-2-fb8c575e32f17b821f0090d40899bdc505bdb2ea.zip
version bump, thanks to Olivier Huber in bug 357473
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/joomla/ChangeLog9
-rw-r--r--www-apps/joomla/joomla-1.6.1.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/www-apps/joomla/ChangeLog b/www-apps/joomla/ChangeLog
index 2a159403c6df..0a95c08d9c50 100644
--- a/www-apps/joomla/ChangeLog
+++ b/www-apps/joomla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/joomla
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/joomla/ChangeLog,v 1.48 2010/11/16 08:32:05 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/joomla/ChangeLog,v 1.49 2011/03/12 13:15:55 fauli Exp $
+
+*joomla-1.6.1 (12 Mar 2011)
+
+ 12 Mar 2011; Christian Faulhammer <fauli@gentoo.org> +joomla-1.6.1.ebuild:
+ version bump, thanks to Olivier Huber in bug 357473
16 Nov 2010; Christian Faulhammer <fauli@gentoo.org>
-joomla-1.5.21.ebuild:
diff --git a/www-apps/joomla/joomla-1.6.1.ebuild b/www-apps/joomla/joomla-1.6.1.ebuild
new file mode 100644
index 000000000000..669a473cf92b
--- /dev/null
+++ b/www-apps/joomla/joomla-1.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/joomla/joomla-1.6.1.ebuild,v 1.1 2011/03/12 13:15:55 fauli Exp $
+
+EAPI=2
+
+inherit webapp depend.php
+
+DESCRIPTION="Joomla is a powerful Open Source Content Management System."
+HOMEPAGE="http://www.joomla.org/"
+SRC_URI="http://joomlacode.org/gf/download/frsrelease/14236/62394/Joomla_${PV}-Stable-Full_Package.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"
+
+DEPEND="${DEPEND}
+ app-arch/unzip"
+RDEPEND="dev-lang/php[json,mysql,zlib,xml]"
+
+src_install () {
+ webapp_src_preinst
+
+ dodoc installation/CHANGELOG installation/INSTALL README.txt
+
+ touch configuration.php
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local files=" administrator/cache administrator/components
+ administrator/language administrator/language/en-GB
+ administrator/manifests/packages
+ administrator/modules administrator/templates cache components images
+ images/banners language language/en-GB media modules plugins
+ plugins/authentication plugins/content plugins/editors plugins/editors-xtd
+ plugins/search plugins/system plugins/user plugins tmp templates"
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${file}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/configuration.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/configuration.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}