summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-05-31 00:35:24 +0000
committerBen de Groot <yngwin@gentoo.org>2009-05-31 00:35:24 +0000
commit7b618fd65d4310745b8a65d52f87b76b6c4b87e6 (patch)
tree77638387cd1071d1ca7dd2faaf4e60fc37051b64 /www-client/arora
parentRemove older ebuilds. (diff)
downloadgentoo-2-7b618fd65d4310745b8a65d52f87b76b6c4b87e6.tar.gz
gentoo-2-7b618fd65d4310745b8a65d52f87b76b6c4b87e6.tar.bz2
gentoo-2-7b618fd65d4310745b8a65d52f87b76b6c4b87e6.zip
Version bump. This release fixes parallel make issues, bug 271240.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'www-client/arora')
-rw-r--r--www-client/arora/ChangeLog7
-rw-r--r--www-client/arora/arora-0.7.1.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/www-client/arora/ChangeLog b/www-client/arora/ChangeLog
index a23a45887ccc..32b48a7fac94 100644
--- a/www-client/arora/ChangeLog
+++ b/www-client/arora/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/arora
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.16 2009/05/25 22:43:03 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.17 2009/05/31 00:35:24 yngwin Exp $
+
+*arora-0.7.1 (31 May 2009)
+
+ 31 May 2009; Ben de Groot <yngwin@gentoo.org> +arora-0.7.1.ebuild:
+ Version bump. This release fixes parallel make issues, bug 271240.
25 May 2009; Ben de Groot <yngwin@gentoo.org> arora-0.7.0.ebuild:
Ensure compilation by enforcing make -j1, fixes bug 271240
diff --git a/www-client/arora/arora-0.7.1.ebuild b/www-client/arora/arora-0.7.1.ebuild
new file mode 100644
index 000000000000..019224265fcc
--- /dev/null
+++ b/www-client/arora/arora-0.7.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/arora-0.7.1.ebuild,v 1.1 2009/05/31 00:35:24 yngwin Exp $
+
+EAPI=2
+inherit eutils qt4
+
+DESCRIPTION="A cross-platform Qt4 WebKit browser"
+HOMEPAGE="http://arora.googlecode.com/"
+SRC_URI="http://arora.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/qt-gui
+ x11-libs/qt-sql
+ x11-libs/qt-webkit"
+DEPEND="$RDEPEND"
+
+ARORA_LANGS="es es_CR et_EE fr_CA gl ms nb_NO uk zh_CN"
+ARORA_NOLONGLANGS="cs_CZ da_DK de_DE fr_FR he_IL hu_HU it_IT ja_JP nl_NL pl_PL
+ ru_RU sk_SK tr_TR"
+
+for L in $ARORA_LANGS; do
+ IUSE="$IUSE linguas_$L"
+done
+for L in $ARORA_NOLONGLANGS; do
+ IUSE="$IUSE linguas_${L%_*}"
+done
+
+src_prepare() {
+ # process linguas
+ local langs=
+ for lingua in $LINGUAS; do
+ if has $lingua $ARORA_LANGS; then
+ langs="$langs ${lingua}.ts"
+ else
+ for a in $ARORA_NOLONGLANGS; do
+ if [[ $lingua == ${a%_*} ]]; then
+ langs="$langs ${a}.ts"
+ fi
+ done
+ fi
+ done
+
+ # remove all translations, then add only the ones we want
+ sed -i '/ts/d' src/locale/locale.pri || die 'sed failed'
+ sed -i "/^TRANSLATIONS/s:\\\:${langs}:" src/locale/locale.pri \
+ || die 'sed failed'
+}
+
+src_configure() {
+ eqmake4 arora.pro PREFIX=/usr
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ # don't pre-strip
+ sed -i "/strip/d" src/Makefile || die 'sed failed'
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die 'make install failed'
+ dodoc AUTHORS ChangeLog README
+}