summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-11-17 14:27:25 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-11-17 14:27:25 +0000
commit2e2a70b9174de84849b7dad6cc44d03f36b87682 (patch)
tree691742877bb6608a9b1cb16c04853684a28eb416 /www-client/chromium-bin
parentRemove old ebuilds, the November release will be pushed for stable soon. The ... (diff)
downloadgentoo-2-2e2a70b9174de84849b7dad6cc44d03f36b87682.tar.gz
gentoo-2-2e2a70b9174de84849b7dad6cc44d03f36b87682.tar.bz2
gentoo-2-2e2a70b9174de84849b7dad6cc44d03f36b87682.zip
Cleanups, suggestions by Andrey Vihrov <andrey.vihrov@gmail.com> in bug #293415
(Portage version: 2.2_rc50/cvs/Linux x86_64)
Diffstat (limited to 'www-client/chromium-bin')
-rw-r--r--www-client/chromium-bin/ChangeLog8
-rw-r--r--www-client/chromium-bin/chromium-bin-4.0.240.0_p31382.ebuild8
-rw-r--r--www-client/chromium-bin/chromium-bin-4.0.248.0_p32003.ebuild11
-rw-r--r--www-client/chromium-bin/chromium-bin-9999.ebuild21
4 files changed, 32 insertions, 16 deletions
diff --git a/www-client/chromium-bin/ChangeLog b/www-client/chromium-bin/ChangeLog
index ff3d1ac990a8..ae73e20557f0 100644
--- a/www-client/chromium-bin/ChangeLog
+++ b/www-client/chromium-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/chromium-bin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium-bin/ChangeLog,v 1.41 2009/11/15 20:19:38 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium-bin/ChangeLog,v 1.42 2009/11/17 14:27:25 voyageur Exp $
+
+ 17 Nov 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ chromium-bin-4.0.240.0_p31382.ebuild,
+ chromium-bin-4.0.248.0_p32003.ebuild, chromium-bin-9999.ebuild:
+ Cleanups, suggestions by Andrey Vihrov <andrey.vihrov@gmail.com> in bug
+ #293415
*chromium-bin-4.0.248.0_p32003 (15 Nov 2009)
diff --git a/www-client/chromium-bin/chromium-bin-4.0.240.0_p31382.ebuild b/www-client/chromium-bin/chromium-bin-4.0.240.0_p31382.ebuild
index 322ee31ab125..fb5877fa687c 100644
--- a/www-client/chromium-bin/chromium-bin-4.0.240.0_p31382.ebuild
+++ b/www-client/chromium-bin/chromium-bin-4.0.240.0_p31382.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium-bin/chromium-bin-4.0.240.0_p31382.ebuild,v 1.1 2009/11/09 14:55:24 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium-bin/chromium-bin-4.0.240.0_p31382.ebuild,v 1.2 2009/11/17 14:27:25 voyageur Exp $
EAPI="2"
inherit eutils multilib
@@ -38,7 +38,7 @@ QA_PRESTRIPPED="opt/chromium.org/chrome-linux/libffmpegsumo.so"
pkg_setup() {
# Built with SSE2 enabled, so will fail on older processors
- if ! grep -q sse2 /proc/cpuinfo; then
+ if [[ ${ROOT} == "/" ]] && ! grep -q sse2 /proc/cpuinfo; then
die "This binary requires SSE2 support, it will not work on older processors"
fi
}
@@ -77,4 +77,8 @@ pkg_postinst() {
ewarn "This binary requires the C++ runtime from >=sys-devel/gcc-4.2"
ewarn "If you get the \"version \`GLIBCXX_3.4.9' not found\" error message,"
ewarn "switch your active gcc to a version >=4.2 with gcc-config"
+ if [[ ${ROOT} != "/" ]]; then
+ ewarn "This package will not work on processors without SSE2 instruction"
+ ewarn "set support (Intel Pentium III/AMD Athlon or older)."
+ fi
}
diff --git a/www-client/chromium-bin/chromium-bin-4.0.248.0_p32003.ebuild b/www-client/chromium-bin/chromium-bin-4.0.248.0_p32003.ebuild
index 562f44e018b7..68aa9afbaa9c 100644
--- a/www-client/chromium-bin/chromium-bin-4.0.248.0_p32003.ebuild
+++ b/www-client/chromium-bin/chromium-bin-4.0.248.0_p32003.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium-bin/chromium-bin-4.0.248.0_p32003.ebuild,v 1.1 2009/11/15 20:19:38 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium-bin/chromium-bin-4.0.248.0_p32003.ebuild,v 1.2 2009/11/17 14:27:25 voyageur Exp $
EAPI="2"
inherit eutils multilib
@@ -25,7 +25,8 @@ RDEPEND="gnome-base/gconf
>=sys-devel/gcc-4.2
>=dev-libs/nspr-4.7
>=dev-libs/nss-3.12
- x11-libs/pango"
+ x11-libs/pango
+ x11-themes/gnome-icon-theme"
S=${WORKDIR}
@@ -37,7 +38,7 @@ QA_PRESTRIPPED="opt/chromium.org/chrome-linux/libffmpegsumo.so"
pkg_setup() {
# Built with SSE2 enabled, so will fail on older processors
- if ! grep -q sse2 /proc/cpuinfo; then
+ if [[ ${ROOT} == "/" ]] && ! grep -q sse2 /proc/cpuinfo; then
die "This binary requires SSE2 support, it will not work on older processors"
fi
}
@@ -76,4 +77,8 @@ pkg_postinst() {
ewarn "This binary requires the C++ runtime from >=sys-devel/gcc-4.2"
ewarn "If you get the \"version \`GLIBCXX_3.4.9' not found\" error message,"
ewarn "switch your active gcc to a version >=4.2 with gcc-config"
+ if [[ ${ROOT} != "/" ]]; then
+ ewarn "This package will not work on processors without SSE2 instruction"
+ ewarn "set support (Intel Pentium III/AMD Athlon or older)."
+ fi
}
diff --git a/www-client/chromium-bin/chromium-bin-9999.ebuild b/www-client/chromium-bin/chromium-bin-9999.ebuild
index 0a80654ae4aa..51a546cdc7e1 100644
--- a/www-client/chromium-bin/chromium-bin-9999.ebuild
+++ b/www-client/chromium-bin/chromium-bin-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium-bin/chromium-bin-9999.ebuild,v 1.21 2009/11/15 13:10:16 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium-bin/chromium-bin-9999.ebuild,v 1.22 2009/11/17 14:27:25 voyageur Exp $
EAPI="2"
inherit eutils multilib
@@ -19,23 +19,20 @@ RDEPEND="gnome-base/gconf
>=sys-devel/gcc-4.2
>=dev-libs/nspr-4.7
>=dev-libs/nss-3.12
- x11-libs/pango"
+ x11-libs/pango
+ x11-themes/gnome-icon-theme"
S=${WORKDIR}
QA_EXECSTACK="opt/chromium.org/chrome-linux/chrome"
# Ogg/Theora/Vorbis-only FFmpeg binaries
-QA_TEXTRELS="opt/chromium.org/chrome-linux/libavcodec.so.52
- opt/chromium.org/chrome-linux/libavformat.so.52
- opt/chromium.org/chrome-linux/libavutil.so.50"
-QA_PRESTRIPPED="opt/chromium.org/chrome-linux/libavcodec.so.52
- opt/chromium.org/chrome-linux/libavformat.so.52
- opt/chromium.org/chrome-linux/libavutil.so.50"
+QA_TEXTRELS="opt/chromium.org/chrome-linux/libffmpegsumo.so"
+QA_PRESTRIPPED="opt/chromium.org/chrome-linux/libffmpegsumo.so"
pkg_setup() {
# Built with SSE2 enabled, so will fail on older processors
- if ! grep -q sse2 /proc/cpuinfo; then
+ if [[ ${ROOT} == "/" ]] && ! grep -q sse2 /proc/cpuinfo; then
die "This binary requires SSE2 support, it will not work on older processors"
fi
}
@@ -48,7 +45,7 @@ src_unpack() {
elog "Installing/updating to version ${LV}"
wget -c "http://build.chromium.org/buildbot/snapshots/chromium-rel-linux${arch_path}/${LV}/chrome-linux.zip" -O "${T}"/${PN}-${LV}.zip
unzip -qo "${T}"/${PN}-${LV}.zip || die "Unpack failed"
- chmod -fR a+rX,u+w,g-w,o-w chrome-linux/
+ chmod -fR a+rX,u+w,g-w,o-w chrome-linux/ || die "chmod failed"
}
src_install() {
@@ -85,4 +82,8 @@ pkg_postinst() {
ewarn "This binary requires the C++ runtime from >=sys-devel/gcc-4.2"
ewarn "If you get the \"version \`GLIBCXX_3.4.9' not found\" error message,"
ewarn "switch your active gcc to a version >=4.2 with gcc-config"
+ if [[ ${ROOT} != "/" ]]; then
+ ewarn "This package will not work on processors without SSE2 instruction"
+ ewarn "set support (Intel Pentium III/AMD Athlon or older)."
+ fi
}