summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-09-08 21:55:00 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-09-08 21:55:00 +0000
commitab45085730eff14ed88599d219cb42e1f876d951 (patch)
tree2dc52b6012359ba19d72668e9f0856496ce56d63 /www-client/epiphany-extensions
parentBump to 2.6.6 (from 2.6.4). Make --lockwait -1 mean forever. Previously (diff)
downloadgentoo-2-ab45085730eff14ed88599d219cb42e1f876d951.tar.gz
gentoo-2-ab45085730eff14ed88599d219cb42e1f876d951.tar.bz2
gentoo-2-ab45085730eff14ed88599d219cb42e1f876d951.zip
Some cleanups; remove firefox use flag and seamonkey; add missing extensions
(Portage version: 2.1.1_rc1-r6)
Diffstat (limited to 'www-client/epiphany-extensions')
-rw-r--r--www-client/epiphany-extensions/ChangeLog6
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-2.16.0.ebuild23
2 files changed, 13 insertions, 16 deletions
diff --git a/www-client/epiphany-extensions/ChangeLog b/www-client/epiphany-extensions/ChangeLog
index a841cbc822e8..51ecfcab589f 100644
--- a/www-client/epiphany-extensions/ChangeLog
+++ b/www-client/epiphany-extensions/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/epiphany-extensions
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.36 2006/09/07 17:19:49 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.37 2006/09/08 21:55:00 dang Exp $
+
+ 08 Sep 2006; Daniel Gryniewicz <dang@gentoo.org>
+ epiphany-extensions-2.16.0.ebuild:
+ Some cleanups; remove firefox use flag and seamonkey; add missing extensions
07 Sep 2006; Daniel Gryniewicz <dang@gentoo.org>
epiphany-extensions-2.16.0.ebuild:
diff --git a/www-client/epiphany-extensions/epiphany-extensions-2.16.0.ebuild b/www-client/epiphany-extensions/epiphany-extensions-2.16.0.ebuild
index fbafb1ca8588..070576f9368a 100644
--- a/www-client/epiphany-extensions/epiphany-extensions-2.16.0.ebuild
+++ b/www-client/epiphany-extensions/epiphany-extensions-2.16.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.16.0.ebuild,v 1.3 2006/09/07 17:19:49 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.16.0.ebuild,v 1.4 2006/09/08 21:55:00 dang Exp $
inherit eutils gnome2
@@ -10,7 +10,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="dbus debug firefox pcre python"
+IUSE="dbus debug pcre python"
RDEPEND=">=www-client/epiphany-2.16
>=dev-libs/libxml2-2.6
@@ -18,9 +18,7 @@ RDEPEND=">=www-client/epiphany-2.16
>=x11-libs/gtk+-2.8
>=gnome-base/libglade-2
app-text/opensp
- sparc? ( >=www-client/mozilla-firefox-1.0.2-r1 )
- !sparc? ( !firefox? ( www-client/seamonkey ) )
- firefox? ( >=www-client/mozilla-firefox-1.0.2-r1 )
+ >=www-client/mozilla-firefox-1.0.2-r1
pcre? ( >=dev-libs/libpcre-3.9-r2 )
dbus? ( >=sys-apps/dbus-0.34 )
python? ( >=dev-lang/python-2.3 )"
@@ -32,9 +30,10 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog HACKING NEWS README"
pkg_setup() {
- local extensions="actions certificates error-viewer extensions-manager-ui \
- gestures livehttpheaders page-info sample sample-mozilla \
- select-stylesheet sidebar smart-bookmarks tab-groups"
+ local extensions="actions auto-reload auto-scroller certificates
+ error-viewer extensions-manager-ui gestures java-console livehttpheaders
+ page-info permissions push-scroller sample sample-mozilla select-stylesheet
+ sidebar smart-bookmarks tab-groups tab-states"
if use dbus && ! built_with_use www-client/epiphany dbus; then
ewarn
@@ -58,12 +57,6 @@ pkg_setup() {
list_exts="${list_exts}${ext}"
done
- G2CONF="${G2CONF} --with-extensions=${list_exts}"
-
- if use firefox || use sparc; then
- G2CONF="${G2CONF} --with-mozilla=firefox"
- else
- G2CONF="${G2CONF} --with-mozilla=seamonkey"
- fi
+ G2CONF="${G2CONF} --with-extensions=${list_exts} --with-mozilla=firefox"
}