summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-11-29 12:34:42 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-11-29 12:34:42 +0000
commit3e9a78f0ffabc75d1ea9c70417c17d6b31a0f486 (patch)
tree9f42d6e3dc1854fb2c0c1da70dc292eb26e9aa12 /www-client/epiphany
parentBump to 2.24.1. Bug fixes and translation updates. (diff)
downloadgentoo-2-3e9a78f0ffabc75d1ea9c70417c17d6b31a0f486.tar.gz
gentoo-2-3e9a78f0ffabc75d1ea9c70417c17d6b31a0f486.tar.bz2
gentoo-2-3e9a78f0ffabc75d1ea9c70417c17d6b31a0f486.zip
Bump to 2.24.2.1. Bugx fixes, redist with libtool2, translation updates.
(Portage version: 2.2_rc16/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/ChangeLog9
-rw-r--r--www-client/epiphany/epiphany-2.24.2.1-r10.ebuild78
-rw-r--r--www-client/epiphany/epiphany-2.24.2.1.ebuild86
3 files changed, 172 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index c3d199bc462e..63bdc8b09842 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/epiphany
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.175 2008/11/13 19:37:15 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.176 2008/11/29 12:34:42 eva Exp $
+
+*epiphany-2.24.2.1-r10 (29 Nov 2008)
+*epiphany-2.24.2.1 (29 Nov 2008)
+
+ 29 Nov 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +epiphany-2.24.2.1.ebuild, +epiphany-2.24.2.1-r10.ebuild:
+ Bump to 2.24.2.1. Bugx fixes, redist with libtool2, translation updates.
13 Nov 2008; Brent Baude <ranger@gentoo.org> epiphany-2.22.3.ebuild:
Marking epiphany-2.22.3 ppc64 stable for bug 236971
diff --git a/www-client/epiphany/epiphany-2.24.2.1-r10.ebuild b/www-client/epiphany/epiphany-2.24.2.1-r10.ebuild
new file mode 100644
index 000000000000..d60606650d19
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.24.2.1-r10.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.24.2.1-r10.ebuild,v 1.1 2008/11/29 12:34:42 eva Exp $
+
+EAPI="1"
+
+inherit gnome2 eutils multilib
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sparc ~x86"
+IUSE="avahi doc networkmanager python spell"
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=x11-libs/gtk+-2.14.0
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=x11-libs/libnotify-0.4
+ >=media-libs/libcanberra-0.3
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ networkmanager? ( net-misc/networkmanager )
+ =net-libs/xulrunner-1.9*
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6
+ )
+ spell? ( app-text/enchant )
+ x11-themes/gnome-icon-theme"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ >=app-text/gnome-doc-utils-0.3.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ # FIXME: I'm automagic
+ if ! built_with_use media-libs/libcanberra gtk; then
+ eerror "You need to rebuild media-libs/libcanberra with gtk support."
+ die "Rebuild media-libs/libcanberra with USE='gtk'"
+ fi
+
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --with-gecko=libxul-embedding
+ --enable-certificate-manager
+ --with-distributor-name=Gentoo
+ $(use_enable avahi zeroconf)
+ $(use_enable networkmanager network-manager)
+ $(use_enable spell spell-checker)
+ $(use_enable python)"
+}
+
+src_compile() {
+ addpredict /usr/$(get_libdir)/xulrunner-1.9/components/xpti.dat
+ addpredict /usr/$(get_libdir)/xulrunner-1.9/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/xulrunner-1.9/components/compreg.dat.tmp
+
+ # Why are these write-opened per bug 228589?
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat.tmp
+
+ gnome2_src_compile
+}
diff --git a/www-client/epiphany/epiphany-2.24.2.1.ebuild b/www-client/epiphany/epiphany-2.24.2.1.ebuild
new file mode 100644
index 000000000000..36c91c17ed47
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.24.2.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.24.2.1.ebuild,v 1.1 2008/11/29 12:34:42 eva Exp $
+
+inherit gnome2 eutils multilib
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+IUSE="avahi doc networkmanager python spell xulrunner"
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=x11-libs/gtk+-2.14.0
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=x11-libs/libnotify-0.4
+ >=media-libs/libcanberra-0.3
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ networkmanager? ( net-misc/networkmanager )
+ !xulrunner? ( =www-client/mozilla-firefox-2* )
+ xulrunner? ( =net-libs/xulrunner-1.8* )
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6
+ )
+ spell? ( app-text/enchant )
+ x11-themes/gnome-icon-theme"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ >=app-text/gnome-doc-utils-0.3.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ # FIXME: I'm automagic
+ if ! built_with_use media-libs/libcanberra gtk; then
+ eerror "You need to rebuild media-libs/libcanberra with gtk support."
+ die "Rebuild media-libs/libcanberra with USE='gtk'"
+ fi
+
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --enable-certificate-manager
+ --with-distributor-name=Gentoo
+ $(use_enable avahi zeroconf)
+ $(use_enable networkmanager network-manager)
+ $(use_enable spell spell-checker)
+ $(use_enable python)"
+
+ if use xulrunner; then
+ G2CONF="${G2CONF} --with-gecko=xulrunner"
+ else
+ G2CONF="${G2CONF} --with-gecko=firefox"
+ fi
+}
+
+src_compile() {
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/xulrunner/components/xpti.dat
+ addpredict /usr/$(get_libdir)/xulrunner/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/xulrunner/components/compreg.dat.tmp
+
+ # Why are these write-opened per bug 228589?
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat.tmp
+
+ gnome2_src_compile
+}