summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-01-03 11:38:35 +0000
committerRémi Cardona <remi@gentoo.org>2009-01-03 11:38:35 +0000
commit545860a6dbeaf95b5701db06b056756f3baacfb6 (patch)
treeec72c70b78b35ba9b66860571dfe8d762dacb51a /www-client/epiphany
parentDrop ia64 keyword, no hardware to test (diff)
downloadgentoo-2-545860a6dbeaf95b5701db06b056756f3baacfb6.tar.gz
gentoo-2-545860a6dbeaf95b5701db06b056756f3baacfb6.tar.bz2
gentoo-2-545860a6dbeaf95b5701db06b056756f3baacfb6.zip
www-client/epiphany: add patch to fix libnotify crash (see bug #250031)
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-rc6-00020-gf608f49 i686, RepoMan options: --force)
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/ChangeLog12
-rw-r--r--www-client/epiphany/epiphany-2.22.3-r1.ebuild94
-rw-r--r--www-client/epiphany/epiphany-2.22.3-r11.ebuild79
-rw-r--r--www-client/epiphany/files/epiphany-2.22.3-notify-crash-fix.patch65
4 files changed, 248 insertions, 2 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index e304af737e26..f3e68a7b74c2 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/epiphany
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.177 2008/12/17 17:47:47 ranger Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.178 2009/01/03 11:38:34 remi Exp $
+
+*epiphany-2.22.3-r11 (03 Jan 2009)
+*epiphany-2.22.3-r1 (03 Jan 2009)
+
+ 03 Jan 2009; Rémi Cardona <remi@gentoo.org>
+ +files/epiphany-2.22.3-notify-crash-fix.patch, +epiphany-2.22.3-r1.ebuild,
+ +epiphany-2.22.3-r11.ebuild:
+ add patch to fix libnotify crash (see bug #250031)
17 Dec 2008; Brent Baude <ranger@gentoo.org> epiphany-2.24.0.1.ebuild:
Marking epiphany-2.24.0.1 ~ppc64 for bug 239847
diff --git a/www-client/epiphany/epiphany-2.22.3-r1.ebuild b/www-client/epiphany/epiphany-2.22.3-r1.ebuild
new file mode 100644
index 000000000000..85b9b2d9b7c3
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.22.3-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.22.3-r1.ebuild,v 1.1 2009/01/03 11:38:34 remi Exp $
+
+inherit gnome2 eutils multilib
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi doc networkmanager python spell xulrunner"
+
+# This release should work with xulrunner 1.9, but this revision is a
+# stable candidate, so stick with 1.8 here.
+# xulrunner-1.9 can be achieved via --with-engine=xulrunner, while
+# --with-engine=mozilla goes with 1.8
+
+RDEPEND=">=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.12.0
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=x11-libs/libnotify-0.4
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ networkmanager? ( net-misc/networkmanager )
+ !xulrunner? ( =www-client/mozilla-firefox-2* )
+ xulrunner? ( =net-libs/xulrunner-1.8* )
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6
+ )
+ spell? ( app-text/enchant )
+ x11-themes/gnome-icon-theme"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ >=app-text/gnome-doc-utils-0.3.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --with-engine=mozilla
+ --enable-certificate-manager
+ --with-distributor-name=Gentoo
+ $(use_enable avahi zeroconf)
+ $(use_enable networkmanager network-manager)
+ $(use_enable spell spell-checker)
+ $(use_enable python)"
+
+ if use xulrunner; then
+ G2CONF="${G2CONF} --with-gecko=xulrunner"
+ else
+ G2CONF="${G2CONF} --with-gecko=firefox"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # build fix with firefox 2.0 (bug #230834)
+ epatch "${FILESDIR}/${P}-firefox2.0-header-fix.patch"
+
+ # fix libnotify crasher (bug #250031)
+ epatch "${FILESDIR}/${P}-notify-crash-fix.patch"
+}
+
+src_compile() {
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/xulrunner/components/xpti.dat
+ addpredict /usr/$(get_libdir)/xulrunner/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/xulrunner/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat.tmp
+
+ gnome2_src_compile
+}
diff --git a/www-client/epiphany/epiphany-2.22.3-r11.ebuild b/www-client/epiphany/epiphany-2.22.3-r11.ebuild
new file mode 100644
index 000000000000..e6feec2fe0f2
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.22.3-r11.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.22.3-r11.ebuild,v 1.1 2009/01/03 11:38:34 remi Exp $
+
+inherit gnome2 eutils multilib
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="avahi doc networkmanager python spell"
+
+# This revision is meant to work with xulrunner 1.9, an earlier revision
+# is the earlier stable candidate against xulrunner-1.8 and co.
+
+RDEPEND=">=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.12.0
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=x11-libs/libnotify-0.4
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ networkmanager? ( net-misc/networkmanager )
+ =net-libs/xulrunner-1.9*
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6
+ )
+ spell? ( app-text/enchant )
+ x11-themes/gnome-icon-theme"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ >=app-text/gnome-doc-utils-0.3.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --with-gecko=libxul-embedding
+ --enable-certificate-manager
+ --with-distributor-name=Gentoo
+ $(use_enable avahi zeroconf)
+ $(use_enable networkmanager network-manager)
+ $(use_enable spell spell-checker)
+ $(use_enable python)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix libnotify crasher (bug #250031)
+ epatch "${FILESDIR}/${P}-notify-crash-fix.patch"
+}
+
+src_compile() {
+ addpredict /usr/$(get_libdir)/xulrunner-1.9/components/xpti.dat
+ addpredict /usr/$(get_libdir)/xulrunner-1.9/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/xulrunner-1.9/components/compreg.dat.tmp
+
+ # Why are these write-opened per bug 228589?
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat.tmp
+
+ gnome2_src_compile
+}
diff --git a/www-client/epiphany/files/epiphany-2.22.3-notify-crash-fix.patch b/www-client/epiphany/files/epiphany-2.22.3-notify-crash-fix.patch
new file mode 100644
index 000000000000..1cd12088e50c
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-2.22.3-notify-crash-fix.patch
@@ -0,0 +1,65 @@
+3cc902d2fd203127a98e027f42175db35dafa579
+diff --git a/embed/downloader-view.c b/embed/downloader-view.c
+index 66de70b..68ce1af 100644
+--- a/embed/downloader-view.c
++++ b/embed/downloader-view.c
+@@ -141,11 +141,6 @@ downloader_view_class_init (DownloaderViewClass *klass)
+ object_class->finalize = downloader_view_finalize;
+
+ g_type_class_add_private (object_class, sizeof(DownloaderViewPrivate));
+-
+-#ifdef HAVE_LIBNOTIFY
+- notify_init (PACKAGE);
+-#endif
+-
+ }
+
+ static void
+@@ -289,13 +284,6 @@ downloader_view_finalize (GObject *object)
+
+ G_OBJECT_CLASS (downloader_view_parent_class)->finalize (object);
+
+-#ifdef HAVE_LIBNOTIFY
+- if (notify_is_initted ())
+- {
+- notify_uninit ();
+- }
+-#endif
+-
+ if (idle_unref)
+ {
+ ephy_object_idle_unref (embed_shell);
+diff --git a/src/ephy-main.c b/src/ephy-main.c
+index 13c8f9e..4e92d42 100644
+--- a/src/ephy-main.c
++++ b/src/ephy-main.c
+@@ -50,6 +50,10 @@
+ #include <errno.h>
+ #include <string.h>
+
++#ifdef HAVE_LIBNOTIFY
++#include <libnotify/notify.h>
++#endif
++
+ static GQuark startup_error_quark = 0;
+ #define STARTUP_ERROR_QUARK (startup_error_quark)
+
+@@ -737,9 +741,18 @@ main (int argc,
+ g_object_weak_ref (G_OBJECT (ephy_shell), shell_weak_notify, NULL);
+ ephy_object_idle_unref (ephy_shell);
+
++#ifdef HAVE_LIBNOTIFY
++ /* Init notifications for the download manager */
++ notify_init (PACKAGE);
++#endif
++
+ gtk_main ();
+
+ /* Shutdown */
++#ifdef HAVE_LIBNOTIFY
++ if (notify_is_initted ())
++ notify_uninit ();
++#endif
+ eel_gconf_monitor_remove ("/apps/epiphany/general");
+ gnome_accelerators_sync ();
+ ephy_state_save ();