summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-09-19 08:05:52 +0000
committerBen de Groot <yngwin@gentoo.org>2012-09-19 08:05:52 +0000
commit8abde99e8a7156dad2cea9ab2b9d180b330153a2 (patch)
tree2258edaddd1df0d3c33b91f100ab45e8f9892b82 /www-client/qupzilla
parentStable for x86, wrt bug #429218 (diff)
downloadgentoo-2-8abde99e8a7156dad2cea9ab2b9d180b330153a2.tar.gz
gentoo-2-8abde99e8a7156dad2cea9ab2b9d180b330153a2.tar.bz2
gentoo-2-8abde99e8a7156dad2cea9ab2b9d180b330153a2.zip
Version bump, with some new features. Add localization handling.
(Portage version: 2.2.0_alpha129/cvs/Linux x86_64)
Diffstat (limited to 'www-client/qupzilla')
-rw-r--r--www-client/qupzilla/ChangeLog8
-rw-r--r--www-client/qupzilla/metadata.xml8
-rw-r--r--www-client/qupzilla/qupzilla-1.3.5.ebuild64
3 files changed, 78 insertions, 2 deletions
diff --git a/www-client/qupzilla/ChangeLog b/www-client/qupzilla/ChangeLog
index 2ee76a19ba56..580df4183296 100644
--- a/www-client/qupzilla/ChangeLog
+++ b/www-client/qupzilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/qupzilla
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/ChangeLog,v 1.13 2012/09/17 17:04:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/ChangeLog,v 1.14 2012/09/19 08:05:52 yngwin Exp $
+
+*qupzilla-1.3.5 (19 Sep 2012)
+
+ 19 Sep 2012; Ben de Groot <yngwin@gentoo.org> +qupzilla-1.3.5.ebuild,
+ metadata.xml:
+ Version bump, with some new features. Add localization handling.
17 Sep 2012; Agostino Sarubbo <ago@gentoo.org> qupzilla-1.3.1.ebuild:
Fix broken SRC_URI and use mirror:// wrt to bug 435346
diff --git a/www-client/qupzilla/metadata.xml b/www-client/qupzilla/metadata.xml
index dc439f7e84f5..b38ad16fab0c 100644
--- a/www-client/qupzilla/metadata.xml
+++ b/www-client/qupzilla/metadata.xml
@@ -1,5 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>qt</herd>
+ <herd>qt</herd>
+ <use>
+ <flag name='nonblockdialogs'>Enable fancy non-blocking JavaScript dialogs
+ shown inside the page, not blocking the application window. When closing
+ browser windows with open dialogs, this can crash the application.
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/www-client/qupzilla/qupzilla-1.3.5.ebuild b/www-client/qupzilla/qupzilla-1.3.5.ebuild
new file mode 100644
index 000000000000..3c30b31c9974
--- /dev/null
+++ b/www-client/qupzilla/qupzilla-1.3.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/qupzilla-1.3.5.ebuild,v 1.1 2012/09/19 08:05:52 yngwin Exp $
+
+EAPI=4
+PLOCALES="cs_CZ de_DE el_GR es_ES es_VE fa_IR fr_FR hu_HU id_ID it_IT ja_JP
+ka_GE nl_NL pl_PL pt_BR pt_PT ro_RO ru_RU sk_SK sr_BA sr_RS sv_SE uk_UA
+zh_CN zh_TW"
+inherit l10n multilib qt4-r2 vcs-snapshot
+
+MY_P="QupZilla-${PV}"
+
+DESCRIPTION="Qt WebKit web browser"
+HOMEPAGE="http://www.qupzilla.com/"
+SRC_URI="https://github.com/downloads/QupZilla/qupzilla/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus debug kde nonblockdialogs"
+
+DEPEND="
+ >=x11-libs/qt-core-4.7:4
+ >=x11-libs/qt-gui-4.7:4
+ >=x11-libs/qt-script-4.7:4
+ >=x11-libs/qt-sql-4.7:4
+ >=x11-libs/qt-webkit-4.7:4
+ dbus? ( >=x11-libs/qt-dbus-4.7:4 )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS BUILDING CHANGELOG FAQ README.md TODO"
+
+src_prepare() {
+ # remove outdated copies of localizations:
+ rm -rf bin/locale || die
+}
+
+src_configure() {
+ # see BUILDING document for explanation of options
+ export QUPZILLA_PREFIX=${EPREFIX}/usr/
+ export USE_LIBPATH=${QUPZILLA_PREFIX}$(get_libdir)
+ export DISABLE_DBUS=$(use dbus && echo false || echo true)
+ export KDE=$(use kde && echo true || echo false) # in future this will enable nepomuk integration
+ export NONBLOCK_JS_DIALOGS=$(use nonblockdialogs && echo true || echo false)
+ has_version '>=x11-libs/qt-webkit-4.8.0:4' && export USE_QTWEBKIT_2_2=true
+
+ # needs qt-webkit with webgl enabled (which we currently don't)
+ # export USE_WEBGL=$(use webgl && echo true || echo false)
+
+ eqmake4
+}
+
+src_install() {
+ qt4-r2_src_install
+ l10n_for_each_disabled_locale_do rm_loc
+ # remove duplicated/outdated set of localizations:
+ #find "${D}"/usr/share/${PN}/locale/ -type f -name 'qt_*' -delete || die
+}
+
+rm_loc() {
+ rm "${D}"/usr/share/${PN}/locale/${1}.qm || die
+}