summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-04-09 03:56:59 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-04-09 03:56:59 +0000
commit0d029ed198b118ca8ead479c0226c21f84e2e84e (patch)
tree96533b4f38419f963f3f5944cbf080a964451183 /www-client/seamonkey/files
parentStable for HPPA (bug #305331). (diff)
downloadgentoo-2-0d029ed198b118ca8ead479c0226c21f84e2e84e.tar.gz
gentoo-2-0d029ed198b118ca8ead479c0226c21f84e2e84e.tar.bz2
gentoo-2-0d029ed198b118ca8ead479c0226c21f84e2e84e.zip
Update for dictionaries to be found properly
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-client/seamonkey/files')
-rw-r--r--www-client/seamonkey/files/1002_fix-system-hunspell-dict-detections.patch112
1 files changed, 112 insertions, 0 deletions
diff --git a/www-client/seamonkey/files/1002_fix-system-hunspell-dict-detections.patch b/www-client/seamonkey/files/1002_fix-system-hunspell-dict-detections.patch
new file mode 100644
index 000000000000..5a905aaf4ac0
--- /dev/null
+++ b/www-client/seamonkey/files/1002_fix-system-hunspell-dict-detections.patch
@@ -0,0 +1,112 @@
+diff -r e06632956519 mozilla/extensions/spellcheck/Makefile.in
+--- a/mozilla/extensions/spellcheck/Makefile.in Sun Apr 04 07:02:14 2010 +0300
++++ b/mozilla/extensions/spellcheck/Makefile.in Tue Apr 06 23:07:03 2010 -0500
+@@ -42,13 +42,19 @@
+ include $(DEPTH)/config/autoconf.mk
+
+ MODULE = spellchecker
++ifndef MOZ_NATIVE_HUNSPELL
+ DIRS = idl locales
++else
++DIRS = idl
++endif
+
+ ifeq (camino,$(MOZ_BUILD_APP))
+ DIRS += osxspell
+ else
++ifndef MOZ_NATIVE_HUNSPELL
+ DIRS += hunspell
+ endif
++endif
+
+ DIRS += src
+
+diff -r e06632956519 mozilla/extensions/spellcheck/hunspell/src/mozHunspell.cpp
+--- a/mozilla/extensions/spellcheck/hunspell/src/mozHunspell.cpp Sun Apr 04 07:02:14 2010 +0300
++++ b/mozilla/extensions/spellcheck/hunspell/src/mozHunspell.cpp Tue Apr 06 23:07:03 2010 -0500
+@@ -63,6 +63,9 @@
+ #include "nsISimpleEnumerator.h"
+ #include "nsIDirectoryEnumerator.h"
+ #include "nsIFile.h"
++#ifdef MOZ_NATIVE_HUNSPELL
++#include "nsILocalFile.h"
++#endif
+ #include "nsDirectoryServiceUtils.h"
+ #include "nsDirectoryServiceDefs.h"
+ #include "mozISpellI18NManager.h"
+@@ -307,7 +310,16 @@
+ return;
+
+ nsCOMPtr<nsIFile> dictDir;
+- rv = dirSvc->Get(DICTIONARY_SEARCH_DIRECTORY,
++ #ifdef MOZ_NATIVE_HUNSPELL
++ nsCOMPtr<nsILocalFile> localFile;
++ rv = NS_NewNativeLocalFile(nsDependentCString("/usr/share/myspell"),PR_TRUE, getter_AddRefs(localFile));
++ if (localFile && NS_SUCCEEDED(rv)) {
++ localFile->QueryInterface(NS_GET_IID(nsIFile), getter_AddRefs(dictDir));
++ LoadDictionariesFromDir(dictDir);
++ }
++ else {
++ #endif
++ rv = dirSvc->Get(DICTIONARY_SEARCH_DIRECTORY,
+ NS_GET_IID(nsIFile), getter_AddRefs(dictDir));
+ if (NS_SUCCEEDED(rv)) {
+ LoadDictionariesFromDir(dictDir);
+@@ -332,6 +344,9 @@
+ LoadDictionariesFromDir(appDir);
+ }
+ }
++#ifdef MOZ_NATIVE_HUNSPELL
++ }
++#endif
+
+ nsCOMPtr<nsISimpleEnumerator> dictDirs;
+ rv = dirSvc->Get(DICTIONARY_SEARCH_DIRECTORY_LIST,
+diff -r e06632956519 mozilla/extensions/spellcheck/src/Makefile.in
+--- a/mozilla/extensions/spellcheck/src/Makefile.in Sun Apr 04 07:02:14 2010 +0300
++++ b/mozilla/extensions/spellcheck/src/Makefile.in Tue Apr 06 23:07:03 2010 -0500
+@@ -63,9 +63,15 @@
+ txtsvc \
+ uconv \
+ unicharutil \
++ xulapp \
+ $(NULL)
+
+-CPPSRCS = \
++ifdef MOZ_NATIVE_HUNSPELL
++CPPSRCS += mozHunspell.cpp \
++ mozHunspellDirProvider.cpp
++endif
++
++CPPSRCS += \
+ mozSpellCheckerFactory.cpp \
+ mozSpellChecker.cpp \
+ mozPersonalDictionary.cpp \
+@@ -80,8 +86,15 @@
+ SHARED_LIBRARY_LIBS += ../osxspell/src/$(LIB_PREFIX)osxspell_s.$(LIB_SUFFIX)
+ LOCAL_INCLUDES += -I$(srcdir)/../osxspell/src
+ else
++ifndef MOZ_NATIVE_HUNSPELL
+ SHARED_LIBRARY_LIBS += ../hunspell/src/$(LIB_PREFIX)hunspell_s.$(LIB_SUFFIX)
+ LOCAL_INCLUDES += -I$(srcdir)/../hunspell/src
++else
++LOCAL_INCLUDES += $(MOZ_HUNSPELL_CFLAGS) \
++ -I$(srcdir)/../hunspell/src \
++ -DMOZ_NATIVE_HUNSPELL \
++ $(NULL)
++endif
+ endif
+
+ EXTRA_DSO_LDOPTS = \
+@@ -96,3 +109,11 @@
+ LOCAL_INCLUDES += \
+ -I$(topsrcdir)/xpcom/io \
+ $(NULL)
++
++ifdef MOZ_NATIVE_HUNSPELL
++export:: $(srcdir)/../hunspell/src/mozHunspell.cpp $(srcdir)/../hunspell/src/mozHunspellDirProvider.cpp
++ $(INSTALL) $(srcdir)/../hunspell/src/mozHunspell.* $(srcdir)/../hunspell/src/mozHunspellDirProvider.* .
++GARBAGE += mozHunspell.$(OBJ_SUFFIX) mozHunspell.cpp mozHunspellDirProvider.$(OBJ_SUFFIX) mozHunspellDirProvider.cpp
++clean::
++ rm -f mozHunspell.* mozHunspellDirProvider.*
++endif