summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-06-30 15:17:19 +0000
committerJeroen Roovers <jer@gentoo.org>2009-06-30 15:17:19 +0000
commit43d0436cad4cf47e3c5cc689ab872d1949a759ed (patch)
tree414e2c704480422eb89f22d18a8179cb6c0730f8 /www-client
parentsparc stable wrt #274002 (diff)
downloadgentoo-2-43d0436cad4cf47e3c5cc689ab872d1949a759ed.tar.gz
gentoo-2-43d0436cad4cf47e3c5cc689ab872d1949a759ed.tar.bz2
gentoo-2-43d0436cad4cf47e3c5cc689ab872d1949a759ed.zip
Compress the faux src_ functions. Add a pkg_setup that describes what to post on bugs.g.o.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/opera/ChangeLog6
-rw-r--r--www-client/opera/opera-10.00_pre4453.ebuild23
2 files changed, 16 insertions, 13 deletions
diff --git a/www-client/opera/ChangeLog b/www-client/opera/ChangeLog
index c52f1ab3d958..0668a1f858d0 100644
--- a/www-client/opera/ChangeLog
+++ b/www-client/opera/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/opera
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera/ChangeLog,v 1.355 2009/06/28 14:11:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/ChangeLog,v 1.356 2009/06/30 15:17:19 jer Exp $
+
+ 30 Jun 2009; Jeroen Roovers <jer@gentoo.org> opera-10.00_pre4453.ebuild:
+ Compress the faux src_ functions. Add a pkg_setup that describes what to
+ post on bugs.g.o.
28 Jun 2009; Jeroen Roovers <jer@gentoo.org> opera-10.00_pre4453.ebuild:
Fix amd64 SRC_URI (patch by Jouni Rinne, bug #275629).
diff --git a/www-client/opera/opera-10.00_pre4453.ebuild b/www-client/opera/opera-10.00_pre4453.ebuild
index eec6344d69b2..af3c8735f1ea 100644
--- a/www-client/opera/opera-10.00_pre4453.ebuild
+++ b/www-client/opera/opera-10.00_pre4453.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-10.00_pre4453.ebuild,v 1.2 2009/06/28 14:11:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-10.00_pre4453.ebuild,v 1.3 2009/06/30 15:17:19 jer Exp $
EAPI="2"
@@ -118,6 +118,12 @@ opera_linguas() {
done
}
+pkg_setup() {
+ elog "${WARN}If you seek support, please file a bug report at${NORMAL}"
+ elog "${WARN}https://bugs.gentoo.org and post the output of${NORMAL}"
+ elog "${WARN} \`emerge -vp =${CATEGORY}/${P}'${NORMAL}"
+}
+
src_unpack() {
unpack ${A}
if [[ ! -d ${S} ]]; then
@@ -146,17 +152,10 @@ src_prepare() {
install.sh || die "sed failed"
}
-src_configure() {
- # This workaround is sadly needed because gnome2.eclass doesn't check
- # whether a configure script exists.
- true
-}
-
-src_compile() {
- # This workaround is sadly needed because gnome2.eclass doesn't check
- # whether a Makefile exists.
- true
-}
+# These workarounds are sadly needed because gnome2.eclass doesn't check
+# whether a configure/Makefile script exists.
+src_configure() { :; }
+src_compile() { :; }
src_install() {
# Prepare installation directories for Opera's installer script.